Hyper-V: Instance ports not bound after resize

Bug #1657424 reported by Lucian Petrut on 2017-01-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Matt Riedemann
compute-hyperv
Undecided
Unassigned

Bug Description

When using OVS, the Hyper-V driver creates the OVS ports only after the instance is powered on (due to a Hyper-V limitation).

The issue is that in case of cold migrations/resize, this step is currently skipped, as the driver doesn't pass the network info object when powering on the instance:
https://github.com/openstack/nova/blob/07b6580a1648a860eefb5a949cb443c2a335a89a/nova/virt/hyperv/migrationops.py#L300-L301

Simply passing that object will fix the issue.

Matt Riedemann (mriedem) on 2017-01-18
tags: added: hyper-v resize
Matt Riedemann (mriedem) wrote :

I see that doesn't pass the block_device_info into the power_on method either, is that needed as well?

Matt Riedemann (mriedem) wrote :

I guess we don't test ssh after a resize in Tempest...

Fix proposed to branch: master
Review: https://review.openstack.org/422314

Changed in nova:
assignee: nobody → Matt Riedemann (mriedem)
status: New → In Progress
Matt Riedemann (mriedem) on 2017-01-18
Changed in nova:
importance: Undecided → High

Reviewed: https://review.openstack.org/422314
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=568a682e5efa6e4fd49b69e02cbd80f1d8a96c63
Submitter: Jenkins
Branch: master

commit 568a682e5efa6e4fd49b69e02cbd80f1d8a96c63
Author: Matt Riedemann <email address hidden>
Date: Wed Jan 18 18:47:24 2017 -0500

    hyperv: make sure to plug OVS VIFs after resize/migrate

    Since the network_info wasn't getting passed to vmops.power_on
    after a resize/cold migrate confirmation, the OVS VIFs weren't
    getting plugged.

    Change-Id: Ia9b7dc11cd74ba896a7254c16a95b7a834a28475
    Closes-Bug: #1657424

Changed in nova:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/434897
Committed: https://git.openstack.org/cgit/openstack/compute-hyperv/commit/?id=5eb0db9b369dbcf594e0dd66fcebf12c69699417
Submitter: Jenkins
Branch: master

commit 5eb0db9b369dbcf594e0dd66fcebf12c69699417
Author: Claudiu Belu <email address hidden>
Date: Thu Feb 16 15:11:11 2017 +0200

    hyperv: make sure to plug OVS VIFs after resize/migrate

    Since the network_info wasn't getting passed to vmops.power_on
    after a resize/cold migrate confirmation, the OVS VIFs weren't
    getting plugged.

    (cherry-picked from commit 568a682e5efa6e4fd49b69e02cbd80f1d8a96c63)

    Change-Id: I9097debeb68cb25dec27e7b3e979cf51d951c250
    Closes-Bug: #1657424

Changed in compute-hyperv:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers