disconnect_volume calls are made during a remote rebuild of a volume backed instance

Bug #1583284 reported by Lee Yarwood on 2016-05-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Lee Yarwood

Bug Description

Description
===========
disconnect_volume calls are made during a remote rebuild of a volume backed instance

Steps to reproduce
==================
- Evacuate a volume backed instance.
- disconnect_volume is called for each previously attached volume on the now remote node rebuilding the instance.

Expected result
===============
disconnect_volume is not called unless the instance was previously running on the current host.

Actual result
=============
disconnect_volume is called regardless of the instance previously running on the current host.

Environment
===========
1. Exact version of OpenStack you are running. See the following
  list for all releases: http://docs.openstack.org/releases/

   Multinode devstack

2. Which hypervisor did you use?
   (For example: Libvirt + KVM, Libvirt + XEN, Hyper-V, PowerKVM, ...)

   libvirt + KVM

2. Which storage type did you use?
   (For example: Ceph, LVM, GPFS, ...)
   What's the version of that?

   LVM/iSCSI

3. Which networking type did you use?
   (For example: nova-network, Neutron with OpenVSwitch, ...)

   N/A

Fix proposed to branch: master
Review: https://review.openstack.org/318266

Changed in nova:
assignee: nobody → Lee Yarwood (lyarwood)
status: New → In Progress
Lee Yarwood (lyarwood) wrote :

> 1. Exact version of OpenStack you are running. See the following
> list for all releases: http://docs.openstack.org/releases/
>
> Multinode devstack

Apologies, this was reproduced against master (Newton) with private downstream reports for RH OSP against Kilo, Liberty and Mitaka.

Matt Riedemann (mriedem) wrote :

What Cinder backend are you using? LVM/iscsi? Rbd? Other?

tags: added: compute volumes

Reviewed: https://review.openstack.org/318266
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=fdf3328107e53f1c5578c2e4dfbad78d832b01c6
Submitter: Jenkins
Branch: master

commit fdf3328107e53f1c5578c2e4dfbad78d832b01c6
Author: Lee Yarwood <email address hidden>
Date: Wed May 18 17:11:16 2016 +0100

    compute: Skip driver detach calls for non local instances

    Only call for a driver detach from a volume if the instance is currently
    associated with the local compute host. This avoids potential virt
    driver and volume backend issues when attempting to disconnect from
    volumes that have never been connected to from the current host.

    Closes-Bug: #1583284
    Change-Id: I36b8532554d75b24130f456a35acd0be838b62d6

Changed in nova:
status: In Progress → Fix Released

This issue was fixed in the openstack/nova 14.0.0.0b3 development milestone.

Reviewed: https://review.openstack.org/351072
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=76f1d60be87f629d898123756480312055547bd0
Submitter: Jenkins
Branch: stable/mitaka

commit 76f1d60be87f629d898123756480312055547bd0
Author: Lee Yarwood <email address hidden>
Date: Wed May 18 17:11:16 2016 +0100

    compute: Skip driver detach calls for non local instances

    Only call for a driver detach from a volume if the instance is currently
    associated with the local compute host. This avoids potential virt
    driver and volume backend issues when attempting to disconnect from
    volumes that have never been connected to from the current host.

    NOTE(lyarwood): Test conflict caused by the mox to mock migration in
    I8d4d8a. As a result test_rebuild_on_remote_host_with_volumes remains a
    mox based test.

    Conflicts:
     nova/tests/unit/compute/test_compute.py

    Closes-Bug: #1583284
    Change-Id: I36b8532554d75b24130f456a35acd0be838b62d6
    (cherry picked from commit fdf3328107e53f1c5578c2e4dfbad78d832b01c6)

tags: added: in-stable-mitaka

This issue was fixed in the openstack/nova 13.1.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers