[SRU] block migration fail with libvirt since version 1.2.17

Bug #1576093 reported by Eli Qiao on 2016-04-28
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Pawel Koniszewski
Nominated for Mitaka by Pawel Koniszewski
Ubuntu Cloud Archive
Undecided
Unassigned
Mitaka
Undecided
Unassigned
nova (Ubuntu)
High
Corey Bryant
Xenial
High
Corey Bryant
Yakkety
High
Corey Bryant

Bug Description

[Impact]

Try to do block migration but fail and libvirt reports that

"Selecting disks to migrate is not implemented for tunneled migration"

Nova: a4e15e329f9adbcfe72fbcd6acb94f0743ad02f8

libvirt: 1.3.1

[Test Case]

reproduce:

default devstack setting and do block migration (no shared instance_dir and shared instance storage used)

[Regression Potential]

Patch was cherry picked from upstream gerrit review, which was cherry picked with little change from master branch.

Eli Qiao (taget-9) on 2016-04-28
Changed in nova:
assignee: nobody → Eli Qiao (taget-9)
Eli Qiao (taget-9) on 2016-04-28
tags: added: libvirt live-migration

Fix proposed to branch: master
Review: https://review.openstack.org/310707

Changed in nova:
status: New → In Progress
Changed in nova:
importance: Undecided → High
tags: added: mitaka-backport-potential
Changed in nova:
assignee: Eli Qiao (taget-9) → Pawel Koniszewski (pawel-koniszewski)
Changed in nova:
assignee: Pawel Koniszewski (pawel-koniszewski) → Eli Qiao (taget-9)
summary: - block migration fail with libvirt 1.3.1
+ block migration fail with libvirt since version 1.2.17
Changed in nova:
assignee: Eli Qiao (taget-9) → Pawel Koniszewski (pawel-koniszewski)
Changed in nova:
assignee: Pawel Koniszewski (pawel-koniszewski) → Matt Riedemann (mriedem)
Changed in nova:
assignee: Matt Riedemann (mriedem) → Pawel Koniszewski (pawel-koniszewski)

Reviewed: https://review.openstack.org/310707
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=1885a39083776605348523002f4a6aedace12cce
Submitter: Jenkins
Branch: master

commit 1885a39083776605348523002f4a6aedace12cce
Author: Eli Qiao <email address hidden>
Date: Fri Jun 10 14:44:54 2016 +0200

    libvirt: Prevent block live migration with tunnelled flag

    libvirt will report "Selecting disks to migrate is not
    implemented for tunneled migration" while doing block migration
    with VIR_MIGRATE_TUNNELLED flag.

    This patch does 2 changes:

    1. Raise exception.MigrationPreCheckError if block live migration with
       with mapped volumes and tunnelled flag on.
    2. Remove migrate_disks from params of migrateToURI3 in case of
       tunnelled block live migration w/o mapped volumes since we want
       to copy all disks to destination

    Co-Authored-By: Pawel Koniszewski <email address hidden>
    Closes-bug: #1576093
    Change-Id: Id6e49f298133c53d21386ea619c83e413ef3117a

Changed in nova:
status: In Progress → Fix Released
James Page (james-page) on 2016-06-15
no longer affects: ubuntu (Ubuntu)

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nova (Ubuntu Xenial):
status: New → Confirmed
Changed in nova (Ubuntu):
status: New → Confirmed
summary: - block migration fail with libvirt since version 1.2.17
+ [SRU] block migration fail with libvirt since version 1.2.17
description: updated
Changed in nova (Ubuntu Yakkety):
status: Confirmed → Fix Released
importance: Undecided → High
Changed in nova (Ubuntu Xenial):
importance: Undecided → High
Changed in nova (Ubuntu Yakkety):
assignee: nobody → Corey Bryant (corey.bryant)
Changed in nova (Ubuntu Xenial):
assignee: nobody → Corey Bryant (corey.bryant)
Corey Bryant (corey.bryant) wrote :

This has been uploaded to yakkety and the xenial review queue, awaiting sru team review.

Hello Eli, or anyone else affected,

Accepted nova into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova/2:13.0.0-0ubuntu5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nova (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed
Ryan Beisner (1chb1n) wrote :

Hello Eli, or anyone else affected,

Accepted nova into mitaka-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:mitaka-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-mitaka-needed to verification-mitaka-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-mitaka-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-mitaka-needed
Corey Bryant (corey.bryant) wrote :

Hello Martin and Ryan,

nova 2:13.0.0-0ubuntu5 and nova 2:13.0.0-0ubuntu5~cloud0 have been successfully tested.

Thanks,
Corey

tags: added: verification-done verification-mitaka-done
removed: verification-mitaka-needed verification-needed

The verification of the Stable Release Update for nova has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2:13.0.0-0ubuntu5

---------------
nova (2:13.0.0-0ubuntu5) xenial; urgency=medium

  * d/p/fix-block-migration.patch: Cherry pick and rebase patch from
    stable/mitaka gerrit review to fix block migration (LP: #1576093).
  * Note: Skipping 0ubuntu3/4 because they were yakkety-only releases.

 -- Corey Bryant <email address hidden> Thu, 16 Jun 2016 11:52:04 -0400

Changed in nova (Ubuntu Xenial):
status: Fix Committed → Fix Released
James Page (james-page) wrote :

The verification of the Stable Release Update for nova has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package nova - 2:13.0.0-0ubuntu5~cloud0
---------------

 nova (2:13.0.0-0ubuntu5~cloud0) trusty-mitaka; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 nova (2:13.0.0-0ubuntu5) xenial; urgency=medium
 .
   * d/p/fix-block-migration.patch: Cherry pick and rebase patch from
     stable/mitaka gerrit review to fix block migration (LP: #1576093).
   * Note: Skipping 0ubuntu3/4 because they were yakkety-only releases.

This issue was fixed in the openstack/nova 14.0.0.0b2 development milestone.

James Page (james-page) on 2016-09-08
Changed in cloud-archive:
status: New → Invalid

Reviewed: https://review.openstack.org/328910
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=4bc51937a26041fbe38d6ed388942332458905ef
Submitter: Jenkins
Branch: stable/mitaka

commit 4bc51937a26041fbe38d6ed388942332458905ef
Author: Eli Qiao <email address hidden>
Date: Mon Jun 13 10:58:29 2016 +0200

    libvirt: Prevent block live migration with tunnelled flag

    libvirt will report "Selecting disks to migrate is not
    implemented for tunneled migration" while doing block migration
    with VIR_MIGRATE_TUNNELLED flag.

    This patch does 2 changes:

    1. Raise exception.MigrationPreCheckError if block live migration with
       with mapped volumes and tunnelled flag on.
    2. Remove migrate_disks from params of migrateToURI3 in case of
       tunnelled block live migration w/o mapped volumes since we want
       to copy all disks to destination

    Co-Authored-By: Pawel Koniszewski <email address hidden>
    Closes-bug: #1576093

    Conflicts:
     nova/tests/unit/virt/libvirt/test_driver.py
     nova/virt/libvirt/driver.py

    Change-Id: Id6e49f298133c53d21386ea619c83e413ef3117a
    (cherry picked from commit 1885a39083776605348523002f4a6aedace12cce)

tags: added: in-stable-mitaka

This issue was fixed in the openstack/nova 13.1.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers