VMware: NFC lease has to be updated when transferring streamOpt images

Bug #1546454 reported by Radoslav Gerganov on 2016-02-17
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Radoslav Gerganov
Declined for Mitaka by Sean Dague

Bug Description

Booting large streamOptimized images (>2GB) fails because the NFC lease is not updated. This causes the lease to timeout and kill the image transfer. The fix is to call update_progress() method every 60sec. This is also an opportunity to refactor the image transfer code and make it simpler.

Changed in nova:
status: New → In Progress
Sabari Murugesan (smurugesan) wrote :

This definitely affects booting any larger image. We are consistently seeing that the "deploy ovf template" operation is getting timed out in vCenter because the lease is not updated.

Sean Dague (sdague) on 2016-02-20
Changed in nova:
importance: High → Medium
Changed in nova:
status: In Progress → Confirmed
Sarafraj Singh (sarafraj-singh) wrote :

Radoslav,
Are you working on the fix? Please change status to Inprogress if you are, otherwise change Assigned to ->nobody.

Changed in nova:
status: Confirmed → In Progress
Radoslav Gerganov (rgerganov) wrote :

There is a patch under review: https://review.openstack.org/#/c/281134/

Not sure why the CI didn't indicate this here

Jay Jahns (jjahns) wrote :

I'm really confused as to why this got rejected for Mitaka.

The patch fixes a core functionality problem associated with images > 2GB being copied over to vSphere. Users running 6.0.0 are going to run into this problem for sure, irrespective of the Glance backend, because I've tested multiple options there.

Considering the low impact of the change and the severity of the issue, @sdague, why was this rejected? It was also downgraded to Medium??? Seems to me this is critical to the vSphere driver that is included with Nova.

As an operator, I don't understand how these fixes can be downgraded or rejected without any sort of reasoning why. Perhaps someone from the community can clarify?

Alexander Arzhanov (aarzhanov) wrote :

I agree with Jay Jahns (jjahns). Seems to me this is critical to the vSphere driver that is included with Nova.

Change abandoned by Matt Riedemann (<email address hidden>) on branch: stable/mitaka
Review: https://review.openstack.org/322681
Reason: Cleaning this out of the stable/mitaka backlog since the change on master hasn't merged yet.

Reviewed: https://review.openstack.org/281134
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=2df83abaa0a5c828421fc38602cc1e5145b46ff4
Submitter: Jenkins
Branch: master

commit 2df83abaa0a5c828421fc38602cc1e5145b46ff4
Author: Radoslav Gerganov <email address hidden>
Date: Wed Feb 17 10:35:59 2016 +0200

    VMware: Refactor the image transfer

    The image transfer is unnecessary complicated and buggy. When
    transferring streamOptimized images we have to update the progress of
    the NFC lease to prevent timeouts.
    This patch replaces the complex usage of blocking queues and threads with
    a simple read+write loop. It has the same performance and the code is
    much cleaner. The NFC lease is updated with the loopingcall utility.

    Closes-Bug: #1546454
    Closes-Bug: #1278690
    Related-Bug: #1495429
    Change-Id: I96e8e0682bcc642a2a5c4b7d2851812bef60d2ff

Changed in nova:
status: In Progress → Fix Released

This issue was fixed in the openstack/nova 14.0.0.0rc1 release candidate.

Reviewed: https://review.openstack.org/322681
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=f60a6d1c9d8d1c8e4bba1db48de070dd5c9b22a8
Submitter: Jenkins
Branch: stable/mitaka

commit f60a6d1c9d8d1c8e4bba1db48de070dd5c9b22a8
Author: Radoslav Gerganov <email address hidden>
Date: Wed Feb 17 10:35:59 2016 +0200

    VMware: Refactor the image transfer

    The image transfer is unnecessary complicated and buggy. When
    transferring streamOptimized images we have to update the progress of
    the NFC lease to prevent timeouts.
    This patch replaces the complex usage of blocking queues and threads with
    a simple read+write loop. It has the same performance and the code is
    much cleaner. The NFC lease is updated with the loopingcall utility.

    Closes-Bug: #1546454
    Closes-Bug: #1278690
    Related-Bug: #1495429
    Change-Id: I96e8e0682bcc642a2a5c4b7d2851812bef60d2ff
    (cherry picked from commit 2df83abaa0a5c828421fc38602cc1e5145b46ff4)

tags: added: in-stable-mitaka

This issue was fixed in the openstack/nova 13.1.2 release.

This issue was fixed in the openstack/nova 14.0.0.0rc1 release candidate.

This issue was fixed in the openstack/nova 13.1.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers