nova.tests.unit.test_wsgi.TestWSGIServerWithSSL fails with testtools.matchers._impl.MismatchError: 'OK\r\n' != 'PONG' and eventlet 0.18.2

Bug #1543766 reported by Matt Riedemann
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Fix Released
High
Chris Dent
Kilo
Fix Released
High
Matt Riedemann
Liberty
Fix Released
High
Matt Riedemann

Bug Description

http://logs.openstack.org/04/273104/5/gate/gate-nova-python27/0a68bad/console.html#_2016-02-09_18_39_51_792

2016-02-09 18:39:51.792 | nova.tests.unit.test_wsgi.TestWSGIServerWithSSL.test_two_servers
2016-02-09 18:39:51.792 | ----------------------------------------------------------------
2016-02-09 18:39:51.792 |
2016-02-09 18:39:51.792 | Captured traceback:
2016-02-09 18:39:51.792 | ~~~~~~~~~~~~~~~~~~~
2016-02-09 18:39:51.793 | Traceback (most recent call last):
2016-02-09 18:39:51.793 | File "nova/tests/unit/test_wsgi.py", line 282, in test_two_servers
2016-02-09 18:39:51.793 | self.assertEqual(response[-4:], "PONG")
2016-02-09 18:39:51.793 | File "/home/jenkins/workspace/gate-nova-python27/.tox/py27/local/lib/python2.7/site-packages/testtools/testcase.py", line 362, in assertEqual
2016-02-09 18:39:51.793 | self.assertThat(observed, matcher, message)
2016-02-09 18:39:51.793 | File "/home/jenkins/workspace/gate-nova-python27/.tox/py27/local/lib/python2.7/site-packages/testtools/testcase.py", line 447, in assertThat
2016-02-09 18:39:51.793 | raise mismatch_error
2016-02-09 18:39:51.793 | testtools.matchers._impl.MismatchError: 'OK\r\n' != 'PONG'

http://logstash.openstack.org/#dashboard/file/logstash.json?query=message%3A%5C%22testtools.matchers._impl.MismatchError%3A%20'OK%5C%5C%5C%5Cr%5C%5C%5C%5Cn'%20!%3D%20'PONG'%5C%22%20AND%20tags%3A%5C%22console%5C%22&from=7d

Matt Riedemann (mriedem)
Changed in nova:
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Matt Riedemann (mriedem) wrote :
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to nova (master)

Fix proposed to branch: master
Review: https://review.openstack.org/278089

Changed in nova:
assignee: nobody → Chris Dent (cdent)
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to nova (stable/liberty)

Fix proposed to branch: stable/liberty
Review: https://review.openstack.org/278108

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to nova (stable/kilo)

Fix proposed to branch: stable/kilo
Review: https://review.openstack.org/278113

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to nova (master)

Reviewed: https://review.openstack.org/278089
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=d754a830861fb55b047e7b4d43ba7f485fc120dd
Submitter: Jenkins
Branch: master

commit d754a830861fb55b047e7b4d43ba7f485fc120dd
Author: Chris Dent <email address hidden>
Date: Tue Feb 9 21:10:23 2016 +0000

    Replace eventlet-based raw socket client with requests

    There's no discernable reason why we need to use a raw
    eventlet-based client TestWSGIServerWithSSL to confirm that a
    wsgi server is listening correctly and returning the expected
    response, especially since using eventlet leads to unreliable
    i/o on the socket unless there is an explicit yield before
    asserting the value of the response.

    So requests is used to query the servers and verify the response.

    Change-Id: I00c1c1e93eb7c66c3370434db4e3e6c00087f8aa
    Closes-Bug: #1543766

Changed in nova:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to nova (stable/liberty)

Reviewed: https://review.openstack.org/278108
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=0d5b3c6d7a4463ba6972507d38300f70cbf87c16
Submitter: Jenkins
Branch: stable/liberty

commit 0d5b3c6d7a4463ba6972507d38300f70cbf87c16
Author: Chris Dent <email address hidden>
Date: Tue Feb 9 21:10:23 2016 +0000

    Replace eventlet-based raw socket client with requests

    There's no discernable reason why we need to use a raw
    eventlet-based client TestWSGIServerWithSSL to confirm that a
    wsgi server is listening correctly and returning the expected
    response, especially since using eventlet leads to unreliable
    i/o on the socket unless there is an explicit yield before
    asserting the value of the response.

    So requests is used to query the servers and verify the response.

    Change-Id: I00c1c1e93eb7c66c3370434db4e3e6c00087f8aa
    Closes-Bug: #1543766
    (cherry picked from commit d754a830861fb55b047e7b4d43ba7f485fc120dd)

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to nova (stable/kilo)

Reviewed: https://review.openstack.org/278113
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=d95b321486f0ff4fd2d3d7f11b656b5b28031d49
Submitter: Jenkins
Branch: stable/kilo

commit d95b321486f0ff4fd2d3d7f11b656b5b28031d49
Author: Chris Dent <email address hidden>
Date: Tue Feb 9 21:10:23 2016 +0000

    Replace eventlet-based raw socket client with requests

    There's no discernable reason why we need to use a raw
    eventlet-based client TestWSGIServerWithSSL to confirm that a
    wsgi server is listening correctly and returning the expected
    response, especially since using eventlet leads to unreliable
    i/o on the socket unless there is an explicit yield before
    asserting the value of the response.

    So requests is used to query the servers and verify the response.

    Change-Id: I00c1c1e93eb7c66c3370434db4e3e6c00087f8aa
    Closes-Bug: #1543766
    (cherry picked from commit d754a830861fb55b047e7b4d43ba7f485fc120dd)
    (cherry picked from commit 0d5b3c6d7a4463ba6972507d38300f70cbf87c16)

Revision history for this message
Doug Hellmann (doug-hellmann) wrote : Fix included in openstack/nova 13.0.0.0b3

This issue was fixed in the openstack/nova 13.0.0.0b3 development milestone.

Revision history for this message
Doug Hellmann (doug-hellmann) wrote : Fix included in openstack/nova 12.0.2

This issue was fixed in the openstack/nova 12.0.2 release.

Revision history for this message
Doug Hellmann (doug-hellmann) wrote : Fix included in openstack/nova 2015.1.4

This issue was fixed in the openstack/nova 2015.1.4 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

This issue was fixed in the openstack/nova 2015.1.4 release.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers