"nova list-extensions" not showing Summary for all extensions

Bug #1532098 reported by Juha Rajamaki on 2016-01-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Pushkar Umaranikar

Bug Description

In OpenStack Liberty installed with RDO Packstack, the output of "nova list-extensions" is showing question marks as summary for many extensions, even if those extensions have properly defined description in the docstring of their code.

For me it looks like the logic is that if the extension exists only in /usr/lib/python2.7/site-packages/nova/api/openstack/compute/legacy_v2/contrib, then its description isn't visible, for example /usr/lib/python2.7/site-packages/nova/api/openstack/compute/legacy_v2/contrib/extended_ips.py is such case. But docstring is in reality found in that file:

class Extended_ips(extensions.ExtensionDescriptor):
    """Adds type parameter to the ip list."""

But for extensions whose implementation exists in /usr/lib/python2.7/site-packages/nova/api/openstack/compute, the description is shown ok.

[root@rdo2controller ~(keystone_admin)]# nova list-extensions
+----------------------------+-----------------------------------------------------------------------+---------------------------------+----------------------+
| Name | Summary | Alias | Updated |
+----------------------------+-----------------------------------------------------------------------+---------------------------------+----------------------+
| Multinic | Multiple network support. | NMN | 2014-12-03T00:00:00Z |
| DiskConfig | Disk Management Extension. | OS-DCF | 2014-12-03T00:00:00Z |
| ExtendedAvailabilityZone | Extended Availability Zone support. | OS-EXT-AZ | 2014-12-03T00:00:00Z |
| ImageSize | Adds image size to image listings. | OS-EXT-IMG-SIZE | 2014-12-03T00:00:00Z |
| ExtendedIps | ?? | OS-EXT-IPS | 2014-12-03T00:00:00Z |
| ExtendedIpsMac | ?? | OS-EXT-IPS-MAC | 2014-12-03T00:00:00Z |
| ExtendedServerAttributes | Extended Server Attributes support. | OS-EXT-SRV-ATTR | 2014-12-03T00:00:00Z |
| ExtendedStatus | ?? | OS-EXT-STS | 2014-12-03T00:00:00Z |
| ExtendedVIFNet | ?? | OS-EXT-VIF-NET | 2014-12-03T00:00:00Z |
| FlavorDisabled | ?? | OS-FLV-DISABLED | 2014-12-03T00:00:00Z |
| FlavorExtraData | ?? | OS-FLV-EXT-DATA | 2014-12-03T00:00:00Z |
| SchedulerHints | Pass arbitrary key/value pairs to the scheduler. | OS-SCH-HNT | 2014-12-03T00:00:00Z |
| ServerUsage | Adds launched_at and terminated_at on Servers. | OS-SRV-USG | 2014-12-03T00:00:00Z |
| AccessIPs | Access IPs support. | os-access-ips | 2014-12-03T00:00:00Z |
| AdminActions | Enable admin-only server actions... | os-admin-actions | 2014-12-03T00:00:00Z |
| AdminPassword | Admin password management support. | os-admin-password | 2014-12-03T00:00:00Z |
| Agents | Agents support. | os-agents | 2014-12-03T00:00:00Z |
| Aggregates | Admin-only aggregate administration. | os-aggregates | 2014-12-03T00:00:00Z |
| AssistedVolumeSnapshots | Assisted volume snapshots. | os-assisted-volume-snapshots | 2014-12-03T00:00:00Z |
| AttachInterfaces | Attach interface support. | os-attach-interfaces | 2014-12-03T00:00:00Z |
| AvailabilityZone | 1. Add availability_zone to the Create Server API.... | os-availability-zone | 2014-12-03T00:00:00Z |
| BareMetalExtStatus | ?? | os-baremetal-ext-status | 2014-12-03T00:00:00Z |
| BareMetalNodes | Admin-only bare-metal node administration. | os-baremetal-nodes | 2014-12-03T00:00:00Z |
| BlockDeviceMapping | Block device mapping boot support. | os-block-device-mapping | 2014-12-03T00:00:00Z |
| BlockDeviceMappingV2Boot | ?? | os-block-device-mapping-v2-boot | 2014-12-03T00:00:00Z |
| CellCapacities | ?? | os-cell-capacities | 2014-12-03T00:00:00Z |
| Cells | Enables cells-related functionality such as adding neighbor cells,... | os-cells | 2014-12-03T00:00:00Z |
| Certificates | Certificates support. | os-certificates | 2014-12-03T00:00:00Z |
| Cloudpipe | Adds actions to create cloudpipe instances.... | os-cloudpipe | 2014-12-03T00:00:00Z |
| CloudpipeUpdate | ?? | os-cloudpipe-update | 2014-12-03T00:00:00Z |
| ConfigDrive | Config Drive Extension. | os-config-drive | 2014-12-03T00:00:00Z |
| ConsoleAuthTokens | Console token authentication support. | os-console-auth-tokens | 2014-12-03T00:00:00Z |
| ConsoleOutput | Console log output support, with tailing ability. | os-console-output | 2014-12-03T00:00:00Z |
| Consoles | Interactive Console support. | os-consoles | 2014-12-03T00:00:00Z |
| CreateBackup | Create a backup of a server. | os-create-backup | 2014-12-03T00:00:00Z |
| Createserverext | ?? | os-create-server-ext | 2014-12-03T00:00:00Z |
| DeferredDelete | Instance deferred delete. | os-deferred-delete | 2014-12-03T00:00:00Z |
| Evacuate | Enables server evacuation. | os-evacuate | 2014-12-03T00:00:00Z |
| ExtendedEvacuateFindHost | ?? | os-extended-evacuate-find-host | 2014-12-03T00:00:00Z |
| ExtendedFloatingIps | ?? | os-extended-floating-ips | 2014-12-03T00:00:00Z |
| ExtendedHypervisors | ?? | os-extended-hypervisors | 2014-12-03T00:00:00Z |
| ExtendedNetworks | ?? | os-extended-networks | 2014-12-03T00:00:00Z |
| ExtendedQuotas | ?? | os-extended-quotas | 2014-12-03T00:00:00Z |
| ExtendedRescueWithImage | ?? | os-extended-rescue-with-image | 2014-12-03T00:00:00Z |
| ExtendedServices | ?? | os-extended-services | 2014-12-03T00:00:00Z |
| ExtendedServicesDelete | ?? | os-extended-services-delete | 2014-12-03T00:00:00Z |
| ExtendedStatus | Extended Status support. | os-extended-status | 2014-12-03T00:00:00Z |
| ExtendedVolumes | Extended Volumes support. | os-extended-volumes | 2014-12-03T00:00:00Z |
| FixedIPs | Fixed IPs support. | os-fixed-ips | 2014-12-03T00:00:00Z |
| FlavorAccess | Flavor access support. | os-flavor-access | 2014-12-03T00:00:00Z |
| FlavorExtraSpecs | Flavors extra specs support. | os-flavor-extra-specs | 2014-12-03T00:00:00Z |
| FlavorManage | Flavor create/delete API support. | os-flavor-manage | 2014-12-03T00:00:00Z |
| FlavorRxtx | Support to show the rxtx status of a flavor. | os-flavor-rxtx | 2014-12-03T00:00:00Z |
| FlavorSwap | ?? | os-flavor-swap | 2014-12-03T00:00:00Z |
| FloatingIpDns | Floating IP DNS support. | os-floating-ip-dns | 2014-12-03T00:00:00Z |
| FloatingIpPools | Floating IPs support. | os-floating-ip-pools | 2014-12-03T00:00:00Z |
| FloatingIps | Floating IPs support. | os-floating-ips | 2014-12-03T00:00:00Z |
| FloatingIpsBulk | Bulk handling of Floating IPs. | os-floating-ips-bulk | 2014-12-03T00:00:00Z |
| Fping | Fping Management Extension. | os-fping | 2014-12-03T00:00:00Z |
| HideServerAddresses | Support hiding server addresses in certain states. | os-hide-server-addresses | 2014-12-03T00:00:00Z |
| Hosts | Admin-only host administration. | os-hosts | 2014-12-03T00:00:00Z |
| HypervisorStatus | ?? | os-hypervisor-status | 2014-12-03T00:00:00Z |
| Hypervisors | Admin-only hypervisor administration. | os-hypervisors | 2014-12-03T00:00:00Z |
| InstanceActions | View a log of actions and events taken on an instance. | os-instance-actions | 2014-12-03T00:00:00Z |
| OSInstanceUsageAuditLog | Admin-only Task Log Monitoring. | os-instance_usage_audit_log | 2014-12-03T00:00:00Z |
| Keypairs | Keypair Support. | os-keypairs | 2014-12-03T00:00:00Z |
| LockServer | Enable lock/unlock server actions. | os-lock-server | 2014-12-03T00:00:00Z |
| MigrateServer | Enable migrate and live-migrate server actions. | os-migrate-server | 2014-12-03T00:00:00Z |
| Migrations | Provide data on migrations. | os-migrations | 2014-12-03T00:00:00Z |
| MultipleCreate | Allow multiple create in the Create Server v2.1 API. | os-multiple-create | 2014-12-03T00:00:00Z |
| Networks | Admin-only Network Management Extension. | os-networks | 2014-12-03T00:00:00Z |
| NetworkAssociationSupport | Network association support. | os-networks-associate | 2014-12-03T00:00:00Z |
| PauseServer | Enable pause/unpause server actions. | os-pause-server | 2014-12-03T00:00:00Z |
| Personality | Personality support. | os-personality | 2014-12-03T00:00:00Z |
| PreserveEphemeralOnRebuild | Allow preservation of the ephemeral partition on rebuild. | os-preserve-ephemeral-rebuild | 2014-12-03T00:00:00Z |
| QuotaClasses | Quota classes management support. | os-quota-class-sets | 2014-12-03T00:00:00Z |
| Quotas | Quotas management support. | os-quota-sets | 2014-12-03T00:00:00Z |
| Rescue | Instance rescue mode. | os-rescue | 2014-12-03T00:00:00Z |
| SecurityGroupDefaultRules | Default rules for security group support. | os-security-group-default-rules | 2014-12-03T00:00:00Z |
| SecurityGroups | Security group support. | os-security-groups | 2014-12-03T00:00:00Z |
| ServerDiagnostics | Allow Admins to view server diagnostics through server action. | os-server-diagnostics | 2014-12-03T00:00:00Z |
| ServerExternalEvents | Server External Event Triggers. | os-server-external-events | 2014-12-03T00:00:00Z |
| ServerGroupQuotas | ?? | os-server-group-quotas | 2014-12-03T00:00:00Z |
| ServerGroups | Server group support. | os-server-groups | 2014-12-03T00:00:00Z |
| ServerListMultiStatus | ?? | os-server-list-multi-status | 2014-12-03T00:00:00Z |
| ServerPassword | Server password support. | os-server-password | 2014-12-03T00:00:00Z |
| ServerSortKeys | ?? | os-server-sort-keys | 2014-12-03T00:00:00Z |
| ServerStartStop | ?? | os-server-start-stop | 2014-12-03T00:00:00Z |
| Services | Services support. | os-services | 2014-12-03T00:00:00Z |
| Shelve | Instance shelve mode. | os-shelve | 2014-12-03T00:00:00Z |
| SimpleTenantUsage | Simple tenant usage extension. | os-simple-tenant-usage | 2014-12-03T00:00:00Z |
| SuspendServer | Enable suspend/resume server actions. | os-suspend-server | 2014-12-03T00:00:00Z |
| OSTenantNetworks | Tenant-based Network Management Extension. | os-tenant-networks | 2014-12-03T00:00:00Z |
| UsedLimits | Provide data on limited resources that are being used. | os-used-limits | 2014-12-03T00:00:00Z |
| UsedLimitsForAdmin | ?? | os-used-limits-for-admin | 2014-12-03T00:00:00Z |
| UserData | Add user_data to the Create Server API. | os-user-data | 2014-12-03T00:00:00Z |
| UserQuotas | ?? | os-user-quotas | 2014-12-03T00:00:00Z |
| VirtualInterfaces | Virtual interface support. | os-virtual-interfaces | 2014-12-03T00:00:00Z |
| VolumeAttachmentUpdate | ?? | os-volume-attachment-update | 2014-12-03T00:00:00Z |
| Volumes | Volumes support. | os-volumes | 2014-12-03T00:00:00Z |
+----------------------------+-----------------------------------------------------------------------+---------------------------------+----------------------+

Version information:

[root@rdo2controller compute(keystone_admin)]# rpm -qa |grep nova
openstack-nova-common-12.0.0-1.el7.noarch
openstack-nova-compute-12.0.0-1.el7.noarch
python-novaclient-2.30.1-1.el7.noarch
openstack-nova-cert-12.0.0-1.el7.noarch
python-nova-12.0.0-1.el7.noarch
openstack-nova-console-12.0.0-1.el7.noarch
openstack-nova-novncproxy-12.0.0-1.el7.noarch
openstack-nova-scheduler-12.0.0-1.el7.noarch
openstack-nova-api-12.0.0-1.el7.noarch
openstack-nova-conductor-12.0.0-1.el7.noarch

Tags: api Edit Tag help
Juha Rajamaki (jurajama) wrote :
Pallavi (p-pallavi) on 2016-01-11
Changed in nova:
assignee: nobody → Pallavi (p-pallavi)
tags: added: api
Fahri Cihan Demirci (cihand) wrote :

I can replicate this with stable/liberty but not with stable/kilo.

Changed in nova:
status: New → Confirmed
Pallavi (p-pallavi) on 2016-02-01
Changed in nova:
assignee: Pallavi (p-pallavi) → nobody
jichenjc (jichenjc) wrote :

should say https://bugs.launchpad.net/nova/+bug/1519760 duplicate to this since it's more detail here :)

Sean Dague (sdague) on 2016-02-12
Changed in nova:
importance: Undecided → Low
Changed in nova:
assignee: nobody → Pushkar Umaranikar (pushkar-umaranikar)

Fix proposed to branch: master
Review: https://review.openstack.org/286130

Changed in nova:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/286130
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=50c4033ac29268dc3f4be9147bf23eef11cc6546
Submitter: Jenkins
Branch: master

commit 50c4033ac29268dc3f4be9147bf23eef11cc6546
Author: Pushkar Umaranikar <email address hidden>
Date: Mon Feb 29 15:57:28 2016 +0000

    "nova list-extensions" not showing summary for all

    Change nova extensions API to show summary
    description for V2.1 API.

    Change-Id: Iefd087baddd65a52a20f1b98ae3efe22b3c5085c
    Closes-Bug: #1532098

Changed in nova:
status: In Progress → Fix Released

This issue was fixed in the openstack/nova 14.0.0.0b3 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers