rename the scheduler_default_filters opt

Bug #1449934 reported by zhangtralon on 2015-04-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Unassigned

Bug Description

 Currently, the value of "scheduler_default_filters" is real one, not default one. so the "scheduler_default_filters" option is misleading.

Changed in nova:
assignee: nobody → zhangtralon (zhangchunlong1)
jichenjc (jichenjc) wrote :

a little bit confusing...
scheduler_default_filters should be able to be changed by admin
so default means default system setting

e.g you can change this value , but the value on it is default
default_availability_zone

zhangtralon (zhangchunlong1) wrote :

@jichenjc, look at the following patch, https://review.openstack.org/#/c/143285/.
there is some discussions in it starting the patchset 9 . thanks

Sylvain Bauza (sylvain-bauza) wrote :

I won't give an opinion here about the bug, hence the wishlist importance.

Let's discuss on the change directly.

Changed in nova:
importance: Undecided → Wishlist
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/180910

Changed in nova:
status: Confirmed → In Progress

Change abandoned by John Garbutt (<email address hidden>) on branch: master
Review: https://review.openstack.org/180910
Reason: This patch seems to have stalled, lets abandon it.
Please restore the patch if that is no longer true.

Any questions, please catch me via email or on IRC johnthetubaguy

Changed in nova:
status: In Progress → Triaged
tags: added: scheduler
Changed in nova:
assignee: zhangtralon (zhangchunlong1) → nobody

@whoever wants to work on this:
Please have a look at [1]. There is the config option which needs to be renamed. The new name could be "scheduler_hosts_filters". Be aware that other config options make use of that name in their help text, which means that needs to be updated too. You can use the "deprecated_name" attribute of the config option. Ping me in IRC (markus_z) if you have questions.

References:
[1] https://github.com/openstack/nova/blob/7e2f5c7d340a0131ac083ed036e417976d6342da/nova/conf/scheduler.py#L125

Changed in nova:
importance: Wishlist → Low
tags: added: low-hanging-fruit
tags: added: config
removed: scheduler
Changed in nova:
assignee: nobody → Antony Francis Maliakal (antonyfm)
Changed in nova:
assignee: Antony Francis Maliakal (antonyfm) → Anusha Unnam (anusha-unnam)

Fix proposed to branch: master
Review: https://review.openstack.org/339233

Changed in nova:
status: Triaged → In Progress

Change abandoned by Anusha Unnam (<email address hidden>) on branch: master
Review: https://review.openstack.org/339233

Anusha Unnam (anusha-unnam) wrote :

Abondoned my patch because it looks like the issue is already addressed in the master.

Changed in nova:
assignee: Anusha Unnam (anusha-unnam) → nobody
status: In Progress → Confirmed
Zhenyu Zheng (zhengzhenyu) wrote :
Changed in nova:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers