flavor access create should check public/private first

Bug #1361476 reported by jichenjc on 2014-08-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Sergey Nikitin

Bug Description

jichen@cloudcontroller:~$ nova flavor-access-add 1 2
+-----------+-----------+
| Flavor_ID | Tenant_ID |
+-----------+-----------+
| 1 | 2 |
+-----------+-----------+

jichen@cloudcontroller:~$ nova flavor-access-list --flavor 1
ERROR (CommandError): Failed to get access list for public flavor type.

we should check public/private before access add

Tags: api Edit Tag help
jichenjc (jichenjc) on 2014-08-26
Changed in nova:
assignee: nobody → jichenjc (jichenjc)
Tracy Jones (tjones-i) on 2014-08-27
tags: added: api
Changed in nova:
status: New → Confirmed
importance: Undecided → Low

Fix proposed to branch: master
Review: https://review.openstack.org/124338

Changed in nova:
status: Confirmed → In Progress

Change abandoned by Sean Dague (<email address hidden>) on branch: master
Review: https://review.openstack.org/124338
Reason: This review is > 4 weeks without comment, and failed Jenkins the last time it was checked. We are abandoning this for now. Feel free to reactivate the review by pressing the restore button and leaving a 'recheck' comment to get fresh test results.

Removing "In Progress" status and assignee as change is abandoned.

Changed in nova:
status: In Progress → Confirmed
assignee: jichenjc (jichenjc) → nobody
jichenjc (jichenjc) wrote :

waiting microversion and use it

Changed in nova:
assignee: nobody → jichenjc (jichenjc)
Changed in nova:
assignee: jichenjc (jichenjc) → Ed Leafe (ed-leafe)
status: Confirmed → In Progress
Changed in nova:
assignee: Ed Leafe (ed-leafe) → jichenjc (jichenjc)
Changed in nova:
assignee: jichenjc (jichenjc) → Sean Dague (sdague)
Changed in nova:
assignee: Sean Dague (sdague) → jichenjc (jichenjc)
Changed in nova:
assignee: jichenjc (jichenjc) → Sergey Nikitin (snikitin)

Reviewed: https://review.openstack.org/124338
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=6abb88befe2914040e3307b0bc5dfd13683db8b2
Submitter: Jenkins
Branch: master

commit 6abb88befe2914040e3307b0bc5dfd13683db8b2
Author: jichenjc <email address hidden>
Date: Sun Sep 21 03:16:32 2014 +0800

    Check flavor type before add tenant access

    Currently we allow tenant access for public flavor, however,
    we can't query it after that because flavor is public.
    This patch adds check for add access function to raise exception
    if the flavor is public.

    Also, a nit change is use methods introduced in
    793bcc07b9ae41b3de2c146cf69117632c88e27b to get flavor.

    APIImpact: Adds new 2.7 API microversion due to new error condition
               in flavor access API
    Implements blueprint check-flavor-type-before-add-tenant
    Closes-Bug: #1361476

    Change-Id: I461175e9969a0dd5b2b7ef75ea7d9f36f3a306d0

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2015-07-28
Changed in nova:
milestone: none → liberty-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-10-15
Changed in nova:
milestone: liberty-2 → 12.0.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers