"FixedIpLimitExceeded: Maximum number of fixed ips exceeded" in tempest nova-network runs since 7/4

Bug #1338844 reported by Matt Riedemann
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Unassigned
tempest
High
Joe Gordon
Revision history for this message
Matt Riedemann (mriedem) wrote :
Matt Riedemann (mriedem)
Changed in nova:
importance: Undecided → High
Revision history for this message
Vish Ishaya (vishvananda) wrote :

I have seen this error a couple of times and it always seems to hit in one of the variations of tempest.api.compute.admin.test_fixed_ips.FixedIPsTest(Json|Xml). Is it possible there is a bug in the test causing us to run out of quota?

Revision history for this message
Vish Ishaya (vishvananda) wrote :

Also the fixed_ip quota limit defaults to -1 which should be unlimited which also leads me to suspect a testing error. It wouldn't show up for neutron because if neutron is running then it manages quota internally.

Revision history for this message
Joe Gordon (jogo) wrote :

As vish said, It looks like this may be a tempest issue. Perhaps its related to https://review.openstack.org/#/c/100342/ which was merged around the same time this bug cropped up.

tempest.api.compute.admin.test_quotas.QuotaClassesAdminTestJSON.test_update_default_quotas was run right before

setUpClass (tempest.api.compute.admin.test_fixed_ips.FixedIPsTestJson) failed

Revision history for this message
Joe Gordon (jogo) wrote :

The offending code is line 183 in https://review.openstack.org/#/c/100342/6/tempest/api/compute/admin/test_quotas.py

Since the default value is -1, adding one sets the quota to 0.

Joe Gordon (jogo)
Changed in tempest:
importance: Undecided → High
Changed in nova:
status: New → Invalid
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tempest (master)

Fix proposed to branch: master
Review: https://review.openstack.org/105651

Changed in tempest:
assignee: nobody → Joe Gordon (jogo)
status: New → In Progress
Matt Riedemann (mriedem)
Changed in tempest:
status: In Progress → Fix Committed
milestone: none → juno-2
Changed in tempest:
status: Fix Committed → Fix Released
Revision history for this message
Matt Riedemann (mriedem) wrote :

This started up again after the tempest fix, 26 hits in 10 days so something else must be causing quota issues now.

Revision history for this message
Ihar Hrachyshka (ihar-hrachyshka) wrote :
Changed in tempest:
status: Fix Released → Confirmed
Revision history for this message
Yaroslav Lobankov (ylobankov) wrote :

Guys, is this issue still reproduced? if yes, could anyone please provide some logs or something else? Thanks.

Revision history for this message
Bradley Klein (brad-klein) wrote :

Yaroslav,

I haven't seen it in a very long time -- you can close it as far as I'm concerned...

Thanks!
Brad

Revision history for this message
Yaroslav Lobankov (ylobankov) wrote :

Brad, thank you for the response! It looks like this bug hasn't been seen by anyone a long time. Moving the bug status back to "Fix released". Feel free to reopen the bug and set the status back to ''Confirmed'' if you encounter the issue.

Changed in tempest:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers