Unable to connect to VCenter 5.5 VimFaultException: Server raised fault: 'Element tag ns0:RetrieveServiceContent uses an undefined namespace prefix ns0

Bug #1314674 reported by Sebastian Rieger on 2014-04-30
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Unassigned
suds (Ubuntu)
Undecided
Unassigned
Trusty
High
James Page
Utopic
Undecided
Unassigned

Bug Description

[Impact]
Users of the Nova VMWare integration can't use the distro provided package.

[Test Case]
sudo apt-get install nova-compute-vmware
(configure /etc/nova/nova.conf to point to a vsphere deployment)
error in original bug report

[Regression potential]
The fix is to drop a distro patch which has all ready been dropped in Debian and utopic.

[Original Bug Report]
I'm currently trying to integrate an OpenStack testbed (based on Icehouse nova-2014.1 , Ubuntu 14.04 standard packages) with VCenter. I configured nova.conf http://docs.openstack.org/trunk/config-reference/content/vmware.html:

compute_driver=vmwareapi.VMwareVCDriver

reserved_host_memory_mb=0

[vmware]
host_ip=192.168.0.146
host_username=root
host_password=<password_here>
cluster_name=VCOS
datastore_regex=qnap*

Using the password I'm able to login to VCenter using vSphere Web Client, Cluster VCOS was created using DRS, and I also defined a port group br-int on the ESXi hosts in the cluster. Although OpenStack Nova using KVM works like a breeze on two other compute nodes, I constantly get error messages on the node running VMwareVCDriver in note-compute.log

2014-04-30 16:44:10.263 1383 ERROR suds.client [-] <?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:ns1="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
   <ns1:Body>
      <ns0:RetrieveServiceContent>
         <_this type="ServiceInstance">ServiceInstance</_this>
      </ns0:RetrieveServiceContent>
   </ns1:Body>
</SOAP-ENV:Envelope>
2014-04-30 16:44:10.265 1383 CRITICAL nova.virt.vmwareapi.driver [-] Unable to connect to server at 192.168.78.103, sleeping for 60 seconds
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver Traceback (most recent call last):
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver File "/usr/lib/python2.7/dist-packages/nova/virt/vmwareapi/driver.py", line 795, in _create_session
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver self.vim = self._get_vim_object()
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver File "/usr/lib/python2.7/dist-packages/nova/virt/vmwareapi/driver.py", line 784, in _get_vim_object
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver return vim.Vim(protocol=self._scheme, host=self._host_ip)
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver File "/usr/lib/python2.7/dist-packages/nova/virt/vmwareapi/vim.py", line 117, in __init__
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver self._service_content = self.retrieve_service_content()
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver File "/usr/lib/python2.7/dist-packages/nova/virt/vmwareapi/vim.py", line 120, in retrieve_service_content
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver return self.RetrieveServiceContent("ServiceInstance")
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver File "/usr/lib/python2.7/dist-packages/nova/virt/vmwareapi/vim.py", line 196, in vim_request_handler
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver raise error_util.VimFaultException(fault_list, excep)
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver VimFaultException: Server raised fault: 'Element tag ns0:RetrieveServiceContent uses an undefined namespace prefix ns0
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver while parsing SOAP body
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver at line 1, column 224
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver while parsing SOAP envelope
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver at line 1, column 38
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver while parsing HTTP request before method was determined
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver at line 1, column 0'
2014-04-30 16:44:10.265 1383 TRACE nova.virt.vmwareapi.driver

...to me it seems like there is some problem with the SOAP message... ns0 is not defined as a namespace und <SOAP-ENV:Envelope>?

I also tried a fresh install of the VCenter Appliance 5.1 and 5.5 without any luck. From the error message names above I cannot see any configuration etc. I might have missed?

Tracy Jones (tjones-i) on 2014-04-30
tags: added: vmware
Sebastian Rieger (a-sebastian) wrote :

I tracked this down to be a problem with package python-suds 0.4.1-11build1 in Ubuntu 14.04... I was finally able to successfully connect to VCenter 5.5 without recieving the error named above after:

mv /usr/lib/python2.7/dist-packages/suds /usr/lib/python2.7/dist-packages/suds.old
mv /usr/lib/python2.7/dist-packages/ suds-0.4.1.egg-info /usr/lib/python2.7/dist-packages/ suds-0.4.1.egg-info.old

# since python-suds is a dependency for python-nova I didn't want to purge both...

pip install suds

After restarting nova-compute the problem disappeared... maybe I will dig deeper later on the find the differences between Ubuntu 14.04 suds package and the one installed using pip...

...so this doesn't seem to be a nova problem, but rather a problem in combination with the python-suds package in Ubuntu 14.04...

Tracy Jones (tjones-i) wrote :

thanks for finding the solution. marking as invalid as there is nothing for us to do in the product to fix tho

Changed in nova:
status: New → Invalid
James Page (james-page) wrote :

Fixed version uploaded to trusty-proposed for SRU team review.

description: updated
Changed in suds (Ubuntu Utopic):
status: New → Fix Released
Changed in suds (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
assignee: nobody → James Page (james-page)

Hello Sebastian, or anyone else affected,

Accepted suds into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/suds/0.4.1-11ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in suds (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Scott Talbert (swt-techie) wrote :

I ran into this bug (the namespace handling regression in Suds) in a different way (congruity package is also broken by this). However, I verified that the python-suds in trusty-proposed resolves the issue in congruity.

James Page (james-page) wrote :

Verified using trusty-proposed with the VMware compute driver - marking verification-done.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for suds has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package suds - 0.4.1-11ubuntu0.1

---------------
suds (0.4.1-11ubuntu0.1) trusty; urgency=medium

  * d/p/04-merge-schema.patch: Dropped, because it introduces errors in
    namespace detection (LP: #1314674).
 -- James Page <email address hidden> Mon, 09 Jun 2014 18:02:30 +0100

Changed in suds (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers