Remove nova.conf.sample from the tree replace with README.nova.conf

Bug #1294774 reported by Tracy Jones on 2014-03-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Tracy Jones

Bug Description

We decided not to try to kep nova.conf.sample in sync so we need to remove it from the tree. However we should either generate it in setup.py OR add a README in the sample dir telling people how to generate it

Tracy Jones (tjones-i) on 2014-03-19
Changed in nova:
milestone: none → icehouse-rc1
status: New → Confirmed
importance: Undecided → Medium
status: Confirmed → New
Tracy Jones (tjones-i) wrote :

We decided to replace with a README and remove the file from the tree. will add docimpact to ensure the doc team will not be affected

Changed in nova:
assignee: nobody → Tracy Jones (tjones-i)
Tracy Jones (tjones-i) on 2014-03-19
summary: - Remove nova.conf.sample from the tree and decide how to handle it
+ Remove nova.conf.sample from the tree replace with README.nova.conf

Fix proposed to branch: master
Review: https://review.openstack.org/81588

Changed in nova:
status: New → In Progress

Reviewed: https://review.openstack.org/81588
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=918f6eab7c69ca2c698fa6782ecf1a6639a41938
Submitter: Jenkins
Branch: master

commit 918f6eab7c69ca2c698fa6782ecf1a6639a41938
Author: Tracy Jones <email address hidden>
Date: Wed Mar 19 10:56:49 2014 -0700

    Remove the nova.config.sample file

    This file is not gated anymore and therefore it gets
    out of date. Replacing it with a README that explains
    how to generate it

    DocImpact
    Closes-Bug: 1294774
    Change-Id: I2a72a005208a2c86d69ac461d72e54c53bd395cf

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-03-31
Changed in nova:
status: Fix Committed → Fix Released
Alan Pevec (apevec) wrote :

> "either generate it in setup.py OR add a README in the sample dir telling people how to generate it"

This isn't "either...or" but AND
Reopening to generate it in setup.py so that source tarball includes fresh nova.conf.sample

Changed in nova:
status: Fix Released → Confirmed
Russell Bryant (russellb) wrote :

> > "either generate it in setup.py OR add a README in the sample dir telling people how to generate it"

> This isn't "either...or" but AND
> Reopening to generate it in setup.py so that source tarball includes fresh nova.conf.sample

That's problematic because an accurate config depends on what versions of other libraries you have installed on the system, like oslo.config, oslo.messaging, keystoneclient ...

Russell Bryant (russellb) wrote :

If we need to make further enhancements, please open a new bug. This bug is complete as described.

Changed in nova:
status: Confirmed → Fix Released
Alan Pevec (apevec) wrote :

New bug is 1301519 - please traget it to Icehouse rc2

Thierry Carrez (ttx) on 2014-04-17
Changed in nova:
milestone: icehouse-rc1 → 2014.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers