Conductor support for networking on Icehouse

Bug #1290568 reported by Matt Kassawara
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Fix Released
High
Dan Smith

Bug Description

I'm updating the installation guide for Icehouse. Based on the following blueprint, I removed the database configuration keys from nova.conf on the compute node in my test environment.

https://blueprints.launchpad.net/nova/+spec/nova-network-objects

However, when attempting to boot an instance, the Nova network service fails to retrieve network information from the controller. Adding the the database keys resolves the problem. I'm using the 2014.1~b3-0ubuntu1~cloud0 packages on Ubuntu 12.04.

Here's my network configuration and instance boot information:

matt@hst-osctl5:~$ nova net-list
+--------------------------------------+-------+------------------+
| ID | Label | CIDR |
+--------------------------------------+-------+------------------+
| a4fd0905-2589-4cda-b1d2-d2ec5e4ec50d | demo | 172.24.246.24/29 |
+--------------------------------------+-------+------------------+

matt@hst-osctl5:~$ nova boot --flavor 1 --image cirros-0.3.1-x86_64 --key-name demo test1
+--------------------------------------+------------------------------------------------------------+
| Property | Value |
+--------------------------------------+------------------------------------------------------------+
| OS-DCF:diskConfig | MANUAL |
| OS-EXT-AZ:availability_zone | nova |
| OS-EXT-STS:power_state | 0 |
| OS-EXT-STS:task_state | scheduling |
| OS-EXT-STS:vm_state | building |
| OS-SRV-USG:launched_at | - |
| OS-SRV-USG:terminated_at | - |
| accessIPv4 | |
| accessIPv6 | |
| adminPass | bDNSwTHU77ru |
| config_drive | |
| created | 2014-03-10T21:33:24Z |
| flavor | m1.tiny (1) |
| hostId | |
| id | 85a3a620-6419-4f6f-a540-5e85c4213189 |
| image | cirros-0.3.1-x86_64 (a768f831-0515-4a42-b4ef-b9492512c6f1) |
| key_name | demo |
| metadata | {} |
| name | test1 |
| os-extended-volumes:volumes_attached | [] |
| progress | 0 |
| security_groups | default |
| status | BUILD |
| tenant_id | f2908e1135c1435f856650b674e665fb |
| updated | 2014-03-10T21:33:24Z |
| user_id | 65b3a89d2990456887544410ad875d92 |
+--------------------------------------+------------------------------------------------------------+

Due to size, I'm attaching the output from nova-network.log when attempting to boot an instance.

Tags: network
Revision history for this message
Matt Kassawara (ionosphere80) wrote :
Dan Smith (danms)
Changed in nova:
milestone: none → icehouse-rc1
importance: Undecided → Medium
assignee: nobody → Dan Smith (danms)
Changed in nova:
status: New → Confirmed
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to nova (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/79680

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Related fix proposed to branch: master
Review: https://review.openstack.org/79714

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Related fix proposed to branch: master
Review: https://review.openstack.org/79715

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Related fix proposed to branch: master
Review: https://review.openstack.org/79716

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Related fix proposed to branch: master
Review: https://review.openstack.org/79826

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Related fix proposed to branch: master
Review: https://review.openstack.org/79949

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to nova (master)

Reviewed: https://review.openstack.org/79714
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=250e72ed1acf3981ac3bee847d16a325cb8ee3c4
Submitter: Jenkins
Branch: master

commit 250e72ed1acf3981ac3bee847d16a325cb8ee3c4
Author: Dan Smith <email address hidden>
Date: Tue Mar 11 10:44:15 2014 -0700

    Add get_by_network() to FixedIPList

    This adds support for get_by_network() to FixedIPList, which is needed
    by the linux_net module to go full-objects. Since it depends on
    information in the VirtualInterface object, this also adds a nested
    FixedIP.virtual_interface object, which currently is only reachable
    when queried in this way.

    Related to blueprint nova-network-objects

    Change-Id: I6b53e6eed1dee049a51d95f385132fc28c7cce05
    Related-bug: 1290568

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Reviewed: https://review.openstack.org/79715
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=006627ed3ebe473984b0d8cdeb58ea4712e6f765
Submitter: Jenkins
Branch: master

commit 006627ed3ebe473984b0d8cdeb58ea4712e6f765
Author: Dan Smith <email address hidden>
Date: Tue Mar 11 09:27:09 2014 -0700

    Make linux_net use objects for last fixed ip query

    This converts the final uses of direct database calls from the
    linux_net module by utilizing the calls just added to the
    FixedIP object.

    Related to blueprint nova-network-objects

    Related-bug: 1290568
    Change-Id: I58828e9112e43967fe8daa070575ca122041690a

Changed in nova:
importance: Medium → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Reviewed: https://review.openstack.org/79826
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=4d24d23fa0903957c7d124a38f2578fcaa1f2491
Submitter: Jenkins
Branch: master

commit 4d24d23fa0903957c7d124a38f2578fcaa1f2491
Author: Dan Smith <email address hidden>
Date: Tue Mar 11 18:33:43 2014 -0700

    Make nova-network use quotas object

    This makes nova-network use the quotas object for its work.

    Related to blueprint nova-network-objects
    Related-bug: 1290568

    Change-Id: I416f63d2a4e4aa8220931ccf8f386009902e653e

Dan Smith (danms)
Changed in nova:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Reviewed: https://review.openstack.org/79949
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=b1838c258df2465756e551fdb879b1d4a748cb2b
Submitter: Jenkins
Branch: master

commit b1838c258df2465756e551fdb879b1d4a748cb2b
Author: Dan Smith <email address hidden>
Date: Wed Mar 12 06:28:36 2014 -0700

    Make nova-network use conductor for security groups refresh

    This makes nova-network use the existing conductor interface for
    triggering security groups member refreshes.

    Related to blueprint nova-network-objects

    Change-Id: Ieca163d67cd005534acb225df83457d755295af9
    Related-bug: 1290568

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Reviewed: https://review.openstack.org/79716
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=1351816314753e35afde79f044b0bfb3c7ffe3fc
Submitter: Jenkins
Branch: master

commit 1351816314753e35afde79f044b0bfb3c7ffe3fc
Author: Dan Smith <email address hidden>
Date: Tue Mar 11 10:49:43 2014 -0700

    Block database access in nova-network binary

    This mirrors the code we have in cmd/compute.py to wedge the database
    module so that we can't add any more direct calls, and will highlight
    any stragglers.

    Related to blueprint nova-network-objects

    Change-Id: Ib12415d84de950265626b4a804f33717203d9765
    Related-bug: 1290568

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx)
Changed in nova:
status: Fix Committed → Fix Released
Revision history for this message
Matt Kassawara (ionosphere80) wrote :

I still cannot launch an instance using nova-network after removing the database configuration keys from nova.conf on a compute node. Attaching output from nova-compute.log for analysis.

Changed in nova:
status: Fix Released → New
Revision history for this message
Matt Kassawara (ionosphere80) wrote :

This bug was marked "fix released" with RC1 milestone, so I assumed RC1 would work without database access on the compute node. However, apparently a patch in RC2 addresses this issue. I'll test again after Ubuntu releases RC2 packages.

Tracy Jones (tjones-i)
tags: added: network
Thierry Carrez (ttx)
Changed in nova:
milestone: icehouse-rc1 → 2014.1
Thierry Carrez (ttx)
Changed in nova:
status: New → Fix Released
Revision history for this message
Matt Kassawara (ionosphere80) wrote :

Bug still valid on Ubuntu with 2014.1-0ubuntu1~cloud0.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers