pep8 gating fails due to tools/config/check_uptodate.sh

Bug #1268614 reported by Ivan Melnikov on 2014-01-13
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ceilometer
Fix Released
Critical
Ildiko Vancsa
Havana
Fix Released
Critical
Ildiko Vancsa
Cinder
Critical
Eric Harney
OpenStack Compute (nova)
Undecided
Ivan Melnikov
OpenStack Heat
Fix Released
Undecided
Jason Dunsmore

Bug Description

I see several changes, including https://review.openstack.org/#/c/63735/ , failed pep8 gating with error from check_uptodate tool:

2014-01-13 14:06:39.643 | pep8 runtests: commands[1] | /home/jenkins/workspace/gate-nova-pep8/tools/config/check_uptodate.sh
2014-01-13 14:06:39.649 | /home/jenkins/workspace/gate-nova-pep8$ /home/jenkins/workspace/gate-nova-pep8/tools/config/check_uptodate.sh
2014-01-13 14:06:43.581 | 2741,2746d2740
2014-01-13 14:06:43.581 | < # (optional) indicate whether to set the X-Service-Catalog
2014-01-13 14:06:43.581 | < # header. If False, middleware will not ask for service
2014-01-13 14:06:43.581 | < # catalog on token validation and will not set the X-Service-
2014-01-13 14:06:43.581 | < # Catalog header. (boolean value)
2014-01-13 14:06:43.581 | < #include_service_catalog=true
2014-01-13 14:06:43.582 | <
2014-01-13 14:06:43.582 | E: nova.conf.sample is not up to date, please run tools/config/generate_sample.sh
2014-01-13 14:06:43.582 | ERROR: InvocationError: '/home/jenkins/workspace/gate-nova-pep8/tools/config/check_uptodate.sh'

Ivan Melnikov (imelnikov) wrote :

Looks like it's due to updated python-keystoneclient. With python-keystoneclient 0.4.1 check_uptodate.sh works just fine. Keystoneclient 0.4.2 introduces include_service_catalog option in commit a97b293501fa504dd154fc921809a40bc2a34049.

Changed in nova:
assignee: nobody → Ivan Melnikov (imelnikov)
Ivan Melnikov (imelnikov) wrote :

I proposed change for master: https://review.openstack.org/#/c/66346/

Changed in nova:
status: New → Confirmed
Changed in ceilometer:
assignee: nobody → Ildiko Vancsa (ildiko-vancsa)
Balazs Gibizer (balazs-gibizer) wrote :

This bug also affect Ceilometer:

2014-01-13 18:15:12.965 | py27 runtests: commands[1] | /home/jenkins/workspace/gate-ceilometer-python27/tools/config/check_uptodate.sh
2014-01-13 18:15:13.947 | 838,843d837
2014-01-13 18:15:13.947 | < # (optional) indicate whether to set the X-Service-Catalog
2014-01-13 18:15:13.947 | < # header. If False, middleware will not ask for service
2014-01-13 18:15:13.947 | < # catalog on token validation and will not set the X-Service-
2014-01-13 18:15:13.947 | < # Catalog header. (boolean value)
2014-01-13 18:15:13.947 | < #include_service_catalog=true
2014-01-13 18:15:13.947 | <
2014-01-13 18:15:13.948 | E: ceilometer.conf.sample is not up to date, please run tools/config/generate_sample.sh
2014-01-13 18:15:13.948 | ERROR: InvocationError: '/home/jenkins/workspace/gate-ceilometer-python27/tools/config/check_uptodate.sh'

Fix proposed to branch: master
Review: https://review.openstack.org/66402

Changed in ceilometer:
status: New → In Progress
Changed in nova:
status: Confirmed → Fix Committed

Reviewed: https://review.openstack.org/66346
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=7e9f0de5c1b4703f3477062609c5bf43b5cf91dc
Submitter: Jenkins
Branch: master

commit 7e9f0de5c1b4703f3477062609c5bf43b5cf91dc
Author: Ivan A. Melnikov <email address hidden>
Date: Mon Jan 13 18:51:17 2014 +0400

    Update nova.conf.sample

    Recent version of python-keystoneclient introduces new option,
    include_service_catalog, so nova.conf.sample should be updated.

    Closes-bug: #1268614
    Change-Id: I8f5f76770b8af8002f6a296594303224ec37846c

Changed in heat:
assignee: nobody → Jason Dunsmore (jasondunsmore)

Fix proposed to branch: master
Review: https://review.openstack.org/66428

Changed in heat:
status: New → In Progress
Changed in nova:
milestone: none → icehouse-2

Reviewed: https://review.openstack.org/66428
Committed: https://git.openstack.org/cgit/openstack/heat/commit/?id=f75369eecfcaa185ed10c6be8727428f79b7bff0
Submitter: Jenkins
Branch: master

commit f75369eecfcaa185ed10c6be8727428f79b7bff0
Author: Jason Dunsmore <email address hidden>
Date: Mon Jan 13 14:51:19 2014 -0600

    Update heat.conf.sample

    A new version of python-keystoneclient introduces an option,
    include_service_catalog, so heat.conf.sample should be updated.

    Closes-Bug: #1268614
    Change-Id: I3caf012d1ecfd852b736f52a1269f742449ffee9

Changed in heat:
status: In Progress → Fix Committed
Dima Shulyak (dshulyak) on 2014-01-14
Changed in cinder:
assignee: nobody → Dima Shulyak (dshulyak)
Dima Shulyak (dshulyak) on 2014-01-14
Changed in cinder:
status: New → Fix Committed
Changed in cinder:
status: Fix Committed → In Progress
assignee: Dima Shulyak (dshulyak) → Eric Harney (eharney)
Changed in cinder:
milestone: none → icehouse-2

Reviewed: https://review.openstack.org/66402
Committed: https://git.openstack.org/cgit/openstack/ceilometer/commit/?id=76c06e03eaef0c66689c62aece24baee0b372644
Submitter: Jenkins
Branch: master

commit 76c06e03eaef0c66689c62aece24baee0b372644
Author: Ildiko Vancsa <email address hidden>
Date: Mon Jan 13 20:26:07 2014 +0100

    Update ceilometer.conf.sample

    Due to python-keystoneclient update.

    Change-Id: Ie683d3fbf8086d2be6a2fbe19374b8d31abaf976
    Closes-bug: #1268614

Changed in ceilometer:
status: In Progress → Fix Committed
Eric Harney (eharney) on 2014-01-15
Changed in cinder:
importance: Undecided → Critical

Reviewed: https://review.openstack.org/66372
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=6f1e6f473c84657b33dde094cb4b047fbdaf7c45
Submitter: Jenkins
Branch: master

commit 6f1e6f473c84657b33dde094cb4b047fbdaf7c45
Author: Eric Harney <email address hidden>
Date: Mon Jan 13 12:19:12 2014 -0500

    Update cinder.conf.sample for keystoneclient change

    A new version of python-keystoneclient adds the
    "include_service_catalog" option, so the sample conf needs to be
    updated.

    Closes-Bug: #1268614

    Change-Id: Ie6913e481caf61ee517c1c101565401fe33c60d6

Changed in cinder:
status: In Progress → Fix Committed
gordon chung (chungg) on 2014-01-16
Changed in ceilometer:
importance: Undecided → Critical
milestone: none → icehouse-2

Reviewed: https://review.openstack.org/67200
Committed: https://git.openstack.org/cgit/openstack/ceilometer/commit/?id=16eb199124e73df48a15193ad31b681e382becc8
Submitter: Jenkins
Branch: stable/havana

commit 16eb199124e73df48a15193ad31b681e382becc8
Author: Ildiko Vancsa <email address hidden>
Date: Mon Jan 13 20:26:07 2014 +0100

    Update ceilometer.conf.sample

    Due to python-keystoneclient update.

    Change-Id: Ie683d3fbf8086d2be6a2fbe19374b8d31abaf976
    Closes-bug: #1268614
    (cherry picked from commit 76c06e03eaef0c66689c62aece24baee0b372644)

tags: added: in-stable-havana
Thierry Carrez (ttx) on 2014-01-22
Changed in ceilometer:
status: Fix Committed → Fix Released
Matt Riedemann (mriedem) wrote :

This will break us next:

https://github.com/openstack/python-keystoneclient/commit/8744cb674165542df8f711fbabf129c5005e997a

Seems that check_uptodate needs to change somehow, otherwise we're always going to be reacting to this.

Thierry Carrez (ttx) on 2014-01-22
Changed in heat:
milestone: none → icehouse-2
status: Fix Committed → Fix Released
Changed in nova:
status: Fix Committed → Fix Released
Ben Nemec (bnemec) wrote :

Well, check_uptodate is doing its job, the problem is that the project sample config includes config options imported from another project, so when that project changes the nova.conf.sample needs to change too.

I see a couple of options to address this:

1) Set up a Jenkins job that triggers on keystoneclient releases to check whether it changed their config options and automatically propose an update to the other projects. I expect this could work like the requirements sync job.

2) Move the keystoneclient config back to a separate file and don't automatically generate it. This will likely result in it getting out of date again though. I assume that's why we started including keystoneclient directly in the generated config.

Thierry Carrez (ttx) on 2014-01-22
Changed in cinder:
status: Fix Committed → Fix Released
Brant Knudson (blk-u) wrote :

This should not be considered fixed until the projects are not going to fail with this again when auth_token middleware config changes.

no longer affects: oslo
Thierry Carrez (ttx) on 2014-04-17
Changed in ceilometer:
milestone: icehouse-2 → 2014.1
Thierry Carrez (ttx) on 2014-04-17
Changed in nova:
milestone: icehouse-2 → 2014.1
Thierry Carrez (ttx) on 2014-04-17
Changed in cinder:
milestone: icehouse-2 → 2014.1
Thierry Carrez (ttx) on 2014-04-17
Changed in heat:
milestone: icehouse-2 → 2014.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers