nova-manage fixed list does not report 'reserved' status of fixed ips

Bug #1249526 reported by Mike Dorman on 2013-11-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Wishlist
Matt Riedemann

Bug Description

Use case: I built a Puppet module to manage reserving/unreserving fixed IPs in Nova. However, there is no way to determine the 'reserved' status of a particular fixed IP using nova, nova-manage, or even the nova API.

Tags: api Edit Tag help
Matt Riedemann (mriedem) wrote :

I'm not sure if this is wishlist or not, but looks like adding reserved status for the fixed IP would go into the os-fixed-ips API extension, which currently only returns this response:

"fixed_ip": {
        "address": "192.168.1.1",
        "cidr": "192.168.1.0/24",
        "host": "host",
        "hostname": "openstack"
    }

Matt Riedemann (mriedem) wrote :

I don't see the os-fixed-ips API in the v3 list, so maybe it's being dropped in v3. I sent a note to the openstack-dev mailing list to see if I'm missing something.

http://lists.openstack.org/pipermail/openstack-dev/2013-November/019506.html

tags: added: api
Changed in nova:
status: New → Triaged
Matt Riedemann (mriedem) wrote :

Answer from Chris Yeoh on the mailing list:

It's not ported to the V3 API because we only support neutron in the V3 API
and fixed ip related queries/settings can be made directly to the neutron
API.

I think adding the reserved status for the fixed IP would be ok. It would
have to be handled in the usual way for extending the V2 API though - eg
adding another extension so it can be detected when that feature will be
available.

More broadly speaking we discussed at summit perhaps closing V2 API
development at the end of I-2 (assuming V3 is looking good by that stage) -
except for bug fixes of course.

Changed in nova:
importance: Undecided → Wishlist
Mike Dorman (mdorman-m) wrote :

So what I am hearing here is this needs to be implemented in the API before it's implemented in the CLI? I submitted a patch (https://review.openstack.org/#/c/55705/ ) that implements in only in the CLI, since nova-manage pulls some other fixed IP info directly from the database, and not the API.

Matt Riedemann (mriedem) wrote :

Hey Mike, nova-manage is deprecated for the most part, except for things like db_sync, so adding the functionality in nova-manage isn't the place for this. So yeah, it would need to be in the API before the nova client could use it (and tempest could test against it).

See Chris Yeoh's response on the mailing list thread.

reachlin (reachlin) wrote :

So this has to be implemented as an extension?

Matt Riedemann (mriedem) wrote :

@reachlin, if it's going to be in the nova v2 API, then yes, it has to be an extension. As cyeoh pointed out in the mailing list, it wouldn't be in the nova v3 API since that's using Neutron directly.

The question might be on timing, since the decision to undeprecate nova-network is coming at the end of the icehouse-2 release cycle.

You can see how a v2 extension is implemented here:

https://review.openstack.org/#/c/39998/

Sean Dague (sdague) on 2015-03-30
Changed in nova:
status: Triaged → Confirmed
Matt Riedemann (mriedem) wrote :

The rules around what's in the v2.1 (formerly v3) API have relaxed, so I think this could get into the v2.1 API as a microversion. It would require a blueprint and spec for liberty though since it's an API change.

Matt Riedemann (mriedem) wrote :

I've created a blueprint here for liberty:

https://blueprints.launchpad.net/nova/+spec/show-reserved-status-in-os-fixed-ips-api

I'll work on the spec.

Fix proposed to branch: master
Review: https://review.openstack.org/168966

Changed in nova:
assignee: nobody → Matt Riedemann (mriedem)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/168966
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=8886590f30daf736ae30a95b3e4a77cb586d4f02
Submitter: Jenkins
Branch: master

commit 8886590f30daf736ae30a95b3e4a77cb586d4f02
Author: Matt Riedemann <email address hidden>
Date: Mon Mar 30 07:32:25 2015 -0700

    Show 'reserved' status in os-fixed-ips

    Adds a new microversion to show the 'reserved' status on a FixedIP in
    the os-fixed-ips extension.

    Closes-Bug: #1249526

    Implements blueprint show-reserved-status-in-os-fixed-ips-api

    Change-Id: Iadaae393fce0c78dbdfd3b02958ddfd6276edb94

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2015-06-24
Changed in nova:
milestone: none → liberty-1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-10-15
Changed in nova:
milestone: liberty-1 → 12.0.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers