When createing a volume from an image - nova leaves the volume name empty

Bug #1224972 reported by Nikola Đipanov on 2013-09-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Cinder
Wishlist
Unassigned
OpenStack Compute (nova)
Wishlist
Unassigned

Bug Description

When a block device with source=image, dest=volume to nova instance boot, nova will instruct Cinder to create the volume, however it will not set any name. It would be helpful to set a descriptive name so that the user knows where the volume came from.

Changed in nova:
importance: Undecided → Wishlist
tags: added: volumes
Changed in nova:
assignee: nobody → Nikola Đipanov (ndipanov)
Michael Still (mikal) on 2013-09-14
Changed in nova:
status: New → Triaged
Changed in nova:
assignee: Nikola Đipanov (ndipanov) → sandhya (sandhya-ganapathy)

Hello,

Would the fix for this bug be better handled if it is done at the cinder level? If the request to create a volume comes without a name, a default (image or vol name from which it is created - this is how horizon behaves) name can be given and volume creation can be done.

Thanks.

Changed in cinder:
assignee: nobody → sandhya (sandhya-ganapathy)
Changed in cinder:
status: New → In Progress
Changed in cinder:
importance: Undecided → Wishlist
Changed in nova:
status: Triaged → In Progress

Change abandoned by Duncan Thomas (<email address hidden>) on branch: master
Review: https://review.openstack.org/111659
Reason: Marking as abandoned to stop jenkins continually retriggering. Original poster is welcome to revive if desired

Changed in cinder:
assignee: Sandhya Ganapathy (sandhya-ganapathy) → nobody
Changed in nova:
assignee: Sandhya Ganapathy (sandhya-ganapathy) → nobody
assignee: nobody → Sandhya Ganapathy (sandhya-ganapathy)

Looks like the change needs to be done in cinder. marking as invalid in Nova

Changed in nova:
status: In Progress → Incomplete
Sean Dague (sdague) on 2014-09-18
Changed in nova:
assignee: Sandhya Ganapathy (sandhya-ganapathy) → nobody
status: Incomplete → Invalid
Duncan Thomas (duncan-thomas) wrote :

Far from convinced cinder should make any assumptions about volume names - it's a free text string, and an empty name is entirely valid.

Changed in cinder:
status: In Progress → Opinion
Changed in nova:
assignee: nobody → Feodor Tersin (ftersin)
status: Invalid → In Progress

Change abandoned by Michael Still (<email address hidden>) on branch: master
Review: https://review.openstack.org/213433
Reason: This patch has been idle for a long time, so I am abandoning it to keep the review clean sane. If you're interested in still working on this patch, then please unabandon it and upload a new patchset.

Cleanup
=======

There are no open reviews for this bug report since more than 2 weeks.
To signal that to other contributors which might provide patches for
this bug, I switch the status from "In Progress" to "Confirmed" and
remove the assignee.
Feel free to add yourself as assignee and to push a review for it.

Changed in nova:
status: In Progress → Confirmed
assignee: Feodor Tersin (ftersin) → nobody
Changed in nova:
assignee: nobody → Feodor Tersin (ftersin)
status: Confirmed → In Progress

Change abandoned by Sean Dague (<email address hidden>) on branch: master
Review: https://review.openstack.org/213433
Reason: This review is > 4 weeks without comment, and is not mergable in it's current state. We are abandoning this for now. Feel free to reactivate the review by pressing the restore button and leaving a 'recheck' comment to get fresh test results.

Sean Dague (sdague) wrote :

There are no currently open reviews on this bug, changing the status back to the previous state and unassigning. If there are active reviews related to this bug, please include links in comments.

Changed in nova:
status: In Progress → Confirmed
assignee: Feodor Tersin (ftersin) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers