Nova Attach/Detach Volume can't work if volume endpoint set to v2

Bug #1215772 reported by Dazhao Yu on 2013-08-23
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Mike Perez

Bug Description

Cannot attach or detach volume if use v2 volume endpoint.

How to reproduce this bug:

1, Remove the volume v1 endpoint from keystone, use "keystone endpoint-delete"
2. Create the v2 volume endpoint via CLI command: keystone endpoint-create
3.export OS_VOLUME_API_VERSION=2
4. run 'cinder list' ok, and create one volume
5. run 'nova volume-attach' or 'nova detach' command will be failed. return 500 error.

After investigated, I found the root cause is nova not support cinderclient v2 yet, we need make some code change to let nova to support cinderclient v2.

Dazhao Yu (dzyu) on 2013-08-23
Changed in nova:
assignee: nobody → Dazhao Yu (dzyu)
Matt Riedemann (mriedem) on 2013-08-24
tags: added: volumes
tags: added: api

Fix proposed to branch: master
Review: https://review.openstack.org/43986

Changed in nova:
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/89971

Changed in nova:
assignee: Dazhao Yu (dzyu) → Mike Perez (thingee)

Change abandoned by John Garbutt (<email address hidden>) on branch: master
Review: https://review.openstack.org/89971
Reason: abandoning, so people review https://review.openstack.org/#/c/43986/

Reviewed: https://review.openstack.org/43986
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=c5402ef4fc509047d513a715a1c14e9b4ba9674f
Submitter: Jenkins
Branch: master

commit c5402ef4fc509047d513a715a1c14e9b4ba9674f
Author: Mike Perez <email address hidden>
Date: Wed Jul 16 01:02:14 2014 -0700

    Code change for nova support cinder client v2

    Use v2 volume endpoint to attach/detach volume would be failed,
    due to nova not supporting cinder client v2 yet. This patch is for
    nova support cinder client v2.

    Implements bp support-cinderclient-v2
    Closes-Bug: #1215772
    Co-Authored-By: Mike Perez <email address hidden>
    Co-Authored-By: Yaguang Tang <email address hidden>

    Change-Id: Id8abbbb4d9b0c8c49ab51fc3d958ef0d487467f8

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-09-05
Changed in nova:
milestone: none → juno-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-10-16
Changed in nova:
milestone: juno-3 → 2014.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers