vmware driver does not work with more than one datacenter in vC

Bug #1214850 reported by Shawn Hartsock on 2013-08-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
High
Gary Kotton
Havana
High
Gary Kotton

Bug Description

"CreateVM_Task", vm_folder_ref,
config=config_spec, pool=res_pool_ref)

specifies a vm_folder_ref that has no relationship to the datastore.

This may lead to VM construction and placement errors.

NOTE: code selects the 0th datacenter

Changed in nova:
assignee: nobody → Shawn Hartsock (hartsock)
importance: Undecided → Low
importance: Low → High
status: New → In Progress
tags: added: grizzly-backport-potential
Vui Lam (vui) wrote :

Actually the vm_folder_ref is a reference to a Folder managed entity. It bears no relationship to VM's location on storage, and nor any relationship to datastores. It is mostly used to group VMs for assigning permissions. So I don't believe the choice of a vm folder over another can be the difference in VM spawning behavior. Shawn, as there a particular scenario where you saw a potential problem?

two datacenters.

Sent from my Droid Charge on Verizon 4G LTE

Vui Lam <email address hidden> wrote:

Actually the vm_folder_ref is a reference to a Folder managed entity. It
bears no relationship to VM's location on storage, and nor any
relationship to datastores. It is mostly used to group VMs for assigning
permissions. So I don't believe the choice of a vm folder over another
can be the difference in VM spawning behavior. Shawn, as there a
particular scenario where you saw a potential problem?

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1214850

Title:
  vmware driver selection of vm_folder_ref does not account for
  datastore

Status in OpenStack Compute (Nova):
  In Progress

Bug description:
  "CreateVM_Task", vm_folder_ref,
  config=config_spec, pool=res_pool_ref)

  specifies a vm_folder_ref that has no relationship to the datastore.

  This may lead to VM construction and placement errors.

To manage notifications about this bug go to:
https://bugs.launchpad.net/nova/+bug/1214850/+subscriptions

True, but we got mo' problems when more than one DC is present, as chronicled in https://bugs.launchpad.net/nova/+bug/1180044. Fixing 1180044 will likely entail addressing the more general problems like the vm folder lookup not being DC specific, and DC lookup not being ComputeResource-specific. I am hopeful that this bug will just fall out when 1180044 is addressed.

Shawn Hartsock (hartsock) wrote :

I've been working on that larger bug for months. I'm hoping by breaking this down into smaller bugs we can actually get smaller patches that will have a shot at getting reviewed.

Code in a moment.

description: updated
description: updated

Fix proposed to branch: master
Review: https://review.openstack.org/43270

Okay.

After dealing with some gerrit strangeness. Here's what I have.

Fixing the vm_folder_ref by querying the datastore fixes the root cause of one of the multi-datacenter issues. But, it doesn't fix the issue of the datastore path. Now I see an issue with datastore paths not being unique in the create spec.

This change selects the correct vmFolder helping to fix the larger issue, but it doesn't solve it.

Shawn Hartsock (hartsock) wrote :

Gary, please take these two patches and run them down.

Changed in nova:
assignee: Shawn Hartsock (hartsock) → Gary Kotton (garyk)
Changed in nova:
assignee: Gary Kotton (garyk) → nobody
assignee: nobody → Vui Lam (vui)
Shawn Hartsock (hartsock) wrote :

Work around: don't have more than one datacenter.

Changed in openstack-vmwareapi-team:
status: New → In Progress
importance: Undecided → High
Tracy Jones (tjones-i) on 2013-10-02
Changed in openstack-vmwareapi-team:
assignee: nobody → Vui Lam (vui)
Tracy Jones (tjones-i) on 2013-11-19
tags: added: havana-backport-potential
dan wendlandt (danwent) on 2013-11-22
summary: - vmware driver selection of vm_folder_ref does not account for datastore
+ vmware driver does not work with more than one datacenter in vC
Changed in openstack-vmwareapi-team:
assignee: Vui Lam (vui) → nobody
Gary Kotton (garyk) on 2013-12-08
Changed in nova:
assignee: Vui Lam (vui) → Gary Kotton (garyk)
milestone: none → icehouse-2
Changed in openstack-vmwareapi-team:
importance: High → Critical
assignee: nobody → Gary Kotton (garyk)

Reviewed: https://review.openstack.org/52630
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=a25b2ac5f440f7ace4678b21ada6ebf5ce5dff3c
Submitter: Jenkins
Branch: master

commit a25b2ac5f440f7ace4678b21ada6ebf5ce5dff3c
Author: Gary Kotton <email address hidden>
Date: Fri Oct 18 06:12:40 2013 -0700

    VMware: fix bug when more than one datacenter exists

    In the case that there was more than one datacenter defined on the VC,
    then spawning an instance would result in an exception. The reason for this
    was that the nova compute would not set the correct datacenter for the
    selected datastore.

    The fix also takes care of the correct folder selection. This too was a
    result of not selecting the correct folder for the data center.

    The 'fake' configuration was updated to contain an additional data
    center with its on datastore.

    Closes-Bug: #1180044
    Closes-Bug: #1214850

    Co-authored-by: Shawn Harsock <email address hidden>

    Change-Id: Ib61811fffcbc80385efc3166c9e366fdaa6432bd

Changed in nova:
status: In Progress → Fix Committed
Tracy Jones (tjones-i) on 2014-01-10
no longer affects: openstack-vmwareapi-team
Thierry Carrez (ttx) on 2014-01-22
Changed in nova:
status: Fix Committed → Fix Released
Alan Pevec (apevec) on 2014-01-23
tags: removed: havana-backport-potential
Alan Pevec (apevec) on 2014-03-30
tags: removed: grizzly-backport-potential
Thierry Carrez (ttx) on 2014-04-17
Changed in nova:
milestone: icehouse-2 → 2014.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers