AggregateInstanceExtraSpecsFilter does not support scoped extra_specs on flavors

Bug #1198290 reported by Russell Bryant on 2013-07-05
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Russell Bryant

Bug Description

Scoping was added for filtering on flavor extra_specs so that you could have data that only applies to one filter. The AggregateInstanceExtraSpecsFilter does not support scoping yet. This is problematic if you want to use this filter in combination with other filters that act on flavor extra_specs.

Changed in nova:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Russell Bryant (russellb)

Fix proposed to branch: master
Review: https://review.openstack.org/35867

Changed in nova:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/35867
Committed: http://github.com/openstack/nova/commit/fbedf60a432773716ddb02f990fc744380fee469
Submitter: Jenkins
Branch: master

commit fbedf60a432773716ddb02f990fc744380fee469
Author: Russell Bryant <email address hidden>
Date: Fri Jul 5 15:20:50 2013 -0400

    Support scoped keys in aggregate extra specs filter

    Update AggregateInstanceExtraSpecs to support scoped keys in flavor
    extra_specs. Otherwise, you can't use this filter in combination with
    other filters that act on un-scoped extra specs, because they may
    conflict.

    This recently came up on the mailing list:

    http://lists.openstack.org/pipermail/openstack-dev/2013-July/011421.html

    Fix bug 1198290.

    DocImpact - See updates to filter_scheduler.rst.

    Change-Id: I03d1d3268c800dc6982ffa4b13f8b9489428b991

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in nova:
milestone: none → havana-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in nova:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers