Do not reraise exceptions

Bug #1191730 reported by Boris Pavlovic on 2013-06-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Undecided
Sergey Vilgelm
Glance
Undecided
Sergey Vilgelm
OpenStack Compute (nova)
Low
Boris Pavlovic
OpenStack Identity (keystone)
Low
Sergey Vilgelm
neutron
Undecided
Sergey Vilgelm
oslo-incubator
Low
Sergey Vilgelm

Bug Description

Reraising exception is bad praxis, because we lose TraceBack.
So all places like:

except SomeException as e:
    raise e

should be replaced by

except SomeException:
    raise

Changed in nova:
importance: Undecided → Low
assignee: nobody → Boris Pavlovic (boris-42)
milestone: none → havana-2
Changed in cinder:
assignee: nobody → Sergey Vilgelm (sergey.vilgelm)
status: New → In Progress
Changed in glance:
assignee: nobody → Sergey Vilgelm (sergey.vilgelm)
status: New → In Progress
Changed in quantum:
assignee: nobody → Sergey Vilgelm (sergey.vilgelm)
status: New → In Progress
Changed in nova:
status: New → In Progress
Changed in keystone:
assignee: nobody → Sergey Vilgelm (sergey.vilgelm)
status: New → In Progress
Dolph Mathews (dolph) on 2013-06-19
Changed in keystone:
importance: Undecided → Low

Reviewed: https://review.openstack.org/33061
Committed: http://github.com/openstack/nova/commit/616098dcd36b20e01d38898b8942003df664e6ac
Submitter: Jenkins
Branch: master

commit 616098dcd36b20e01d38898b8942003df664e6ac
Author: Boris Pavlovic <email address hidden>
Date: Fri Jun 14 17:53:53 2013 +0400

    Do not raise NEW exceptions

    Raising NEW exception is bad practice, because we lose TraceBack.
    So all places like:

    except SomeException as e:
        raise e

    should be replaced by

    except SomeException:
        raise

    If we are doing some other actions before reraising we should
    store information about exception then do all actions and then
    reraise it. This is caused by eventlet bug. It lost information
    about exception if it switch threads.

    fixes bug 1191730

    Change-Id: Ia375ecef9f16bda65d5146d14ed4b37a988abb0c

Changed in nova:
status: In Progress → Fix Committed
Changed in oslo:
status: New → In Progress
assignee: nobody → Sergey Vilgelm (sergey.vilgelm)
Mark McLoughlin (markmc) on 2013-06-25
Changed in oslo:
importance: Undecided → Low

Reviewed: https://review.openstack.org/34349
Committed: http://github.com/openstack/oslo-incubator/commit/31325752e1d202c95f65b8af0e656b283043f1cd
Submitter: Jenkins
Branch: master

commit 31325752e1d202c95f65b8af0e656b283043f1cd
Author: Sergey Vilgelm <email address hidden>
Date: Tue Jun 25 14:42:15 2013 +0400

    Do not raise NEW exceptions

    Raising NEW exception is bad practice, because we lose TraceBack.
    So all places like:

    except SomeException as e:
        raise e

    should be replaced by

    except SomeException:
        raise

    If we are doing some other actions before reraising we should
    store information about exception then do all actions and then
    reraise it. This is caused by eventlet bug. It lost information
    about exception if it switch threads.

    fixes bug 1191730

    Change-Id: I7bce659591c4c3e4bc41e12d7d8390128c30e2e4

Changed in oslo:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/33270
Committed: http://github.com/openstack/quantum/commit/3ecd1cbbc95f5dacfd6503818e2c00f394f2c82d
Submitter: Jenkins
Branch: master

commit 3ecd1cbbc95f5dacfd6503818e2c00f394f2c82d
Author: Sergey Vilgelm <email address hidden>
Date: Mon Jun 24 15:26:50 2013 +0400

    Do not raise NEW exceptions

    Raising NEW exception is bad practice, because we lose TraceBack.
    So all places like:

    except SomeException as e:
        raise e

    should be replaced by

    except SomeException:
        raise

    If we are doing some other actions before reraising we should
    store information about exception then do all actions and then
    reraise it. This is caused by eventlet bug. It lost information
    about exception if it switch threads.

    fixes bug 1191730

    Change-Id: Id4aaadde7e69f0bc087cf6d96bb041d53feb131d

Changed in quantum:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/33263
Committed: http://github.com/openstack/cinder/commit/33f6d78c3a0f3e3c34e8b91a8dffb1391f7b46b6
Submitter: Jenkins
Branch: master

commit 33f6d78c3a0f3e3c34e8b91a8dffb1391f7b46b6
Author: Sergey Vilgelm <email address hidden>
Date: Mon Jun 24 15:19:50 2013 +0400

    Do not raise NEW exceptions

    Raising NEW exception is bad practice, because we lose TraceBack.
    So all places like:

    except SomeException as e:
        raise e

    should be replaced by

    except SomeException:
        raise

    If we are doing some other actions before reraising we should
    store information about exception then do all actions and then
    reraise it. This is caused by eventlet bug. It lost information
    about exception if it switch threads.

    fixes bug 1191730
    Change-Id: Ic2be96e9f03d2ca46d060caf6f6f7f713a1d6b82

Changed in cinder:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/33267
Committed: http://github.com/openstack/glance/commit/41cc89afa8ed7dda76eed5669ae1306a131bbbfc
Submitter: Jenkins
Branch: master

commit 41cc89afa8ed7dda76eed5669ae1306a131bbbfc
Author: Sergey Vilgelm <email address hidden>
Date: Mon Jun 24 15:32:14 2013 +0400

    Do not raise NEW exceptions

    Raising NEW exception is bad practice, because we lose TraceBack.
    So all places like:

    except SomeException as e:
        raise e

    should be replaced by

    except SomeException:
        raise

    If we are doing some other actions before reraising we should
    store information about exception then do all actions and then
    reraise it. This is caused by eventlet bug. It lost information
    about exception if it switch threads.

    fixes bug 1191730

    Change-Id: I047e355607318bf9fa6208c2b174b7cc394297f0

Changed in glance:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/33614
Committed: http://github.com/openstack/keystone/commit/f79ccf452b7a0cbf51c63adf259f46896586dc16
Submitter: Jenkins
Branch: master

commit f79ccf452b7a0cbf51c63adf259f46896586dc16
Author: Sergey Vilgelm <email address hidden>
Date: Mon Jun 24 13:41:07 2013 +0400

    Do not raise NEW exceptions

    Raising NEW exception is bad practice, because we lose TraceBack.
    So all places like:

    except SomeException as e:
        raise e

    should be replaced by

    except SomeException:
        raise

    If we are doing some other actions before reraising we should
    store information about exception then do all actions and then
    reraise it. This is caused by eventlet bug. It lost information
    about exception if it switch threads.

    fixes bug 1191730

    Change-Id: I8dffc36ba5780911dd57d7161d218d0324af60b3

Changed in keystone:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in glance:
milestone: none → havana-2
status: Fix Committed → Fix Released
Changed in cinder:
milestone: none → havana-2
status: Fix Committed → Fix Released
Changed in keystone:
milestone: none → havana-2
status: Fix Committed → Fix Released
Changed in nova:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-07-17
Changed in neutron:
milestone: none → havana-2
status: Fix Committed → Fix Released
Changed in oslo:
milestone: none → havana-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in oslo:
milestone: havana-2 → 2013.2
Thierry Carrez (ttx) on 2013-10-17
Changed in glance:
milestone: havana-2 → 2013.2
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-2 → 2013.2
Thierry Carrez (ttx) on 2013-10-17
Changed in neutron:
milestone: havana-2 → 2013.2
Thierry Carrez (ttx) on 2013-10-17
Changed in nova:
milestone: havana-2 → 2013.2
Thierry Carrez (ttx) on 2013-10-17
Changed in keystone:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers