Make nova.virt.netutils.get_injected_network_template use the current network model

Bug #1112659 reported by Amir Sadoughi on 2013-02-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Ben Nemec

Bug Description

Related to bug 1044383, nova.virt.netutils.get_injected_network_template needs to use the current nova.network.model instead of being dependent on legacy().

Chuck Short (zulcss) on 2013-02-04
Changed in nova:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/22372

Changed in nova:
assignee: nobody → Amir Sadoughi (amir-sadoughi)
status: Confirmed → In Progress
Changed in nova:
assignee: Amir Sadoughi (amir-sadoughi) → Ben Nemec (bnemec)

Reviewed: https://review.openstack.org/26012
Committed: http://github.com/openstack/nova/commit/2807ea5464e610b4ac77d95f9216b86b5f36bde0
Submitter: Jenkins
Branch: master

commit 2807ea5464e610b4ac77d95f9216b86b5f36bde0
Author: Ben Nemec <email address hidden>
Date: Mon May 13 23:06:11 2013 +0000

    Don't inject settings for dynamic network

    When using Quantum for networking and setting flat_injected to
    inject network settings into the guest VM, Nova injects a static
    network configuration for networks using DHCP. This change
    checks for the existence of a dhcp server and, if found, does not
    inject static settings for that network.

    Due to limitations of the legacy network info, the fix only
    applies when new-style network info is passed to the injection
    template function. The only code still passing in legacy
    network info is in libvirt, and there is work ongoing to
    remove that dependency.

    Fixes bug 1163985
    Fixes bug 1112659

    Change-Id: I8d3f16bde22e1c6dc0d2432aa263e2b15ae5c93a

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-05-29
Changed in nova:
milestone: none → havana-1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in nova:
milestone: havana-1 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers