Openstack Ubuntu Testing: nova-common dpkg --configure broken

Bug #1110567 reported by Jacob Godin on 2013-01-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Unassigned
openstack-ubuntu-testing
Undecided
Unassigned
nova (Ubuntu)
High
Unassigned

Bug Description

OS - Ubuntu 12.04.1 x86_64

Installing nova-common via aptitude is currently broken due to an inconsistency between the nova-common postinst file's use of nova-manage and the supported arguments of the installed version of nova-manage.

The following line appears to cause the issue (Line36):

        nova-manage config convert --infile=/etc/nova/nova-compute.conf.upgrade \
          --outfile=/etc/nova/nova-compute.conf

It seems that the "config" option is invalid.

When trying to install/upgrade nova-common or anything that depends on it, the following occurs:

Setting up nova-common (2013.1+git201212141401~precise-0ubuntu1) ...
usage: nova-manage [-h] [--version] [--debug] [--nodebug]
                   [--state_path STATE_PATH] [--config-dir DIR]
                   [--log-config PATH] [--log-dir LOG_DIR] [--verbose]
                   [--noverbose] [--log-format FORMAT] [--fake_network]
                   [--nofake_network] [--log-date-format DATE_FORMAT]
                   [--use-syslog] [--nouse-syslog]
                   [--syslog-log-facility SYSLOG_LOG_FACILITY]
                   [--bindir BINDIR] [--config-file PATH]
                   [--pybasedir PYBASEDIR] [--log-file PATH]

                   {version,bash-completion,shell,logs,db,vm,agent,host,flavor,vpn,floating,account,network,service,project,instance_type,fixed}
                   ...
nova-manage: error: argument category: invalid choice: 'config' (choose from 'version', 'bash-completion', 'shell', 'logs', 'db', 'vm', 'agent', 'host', 'flavor', 'vpn', 'floating', 'account', 'network', 'service', 'project', 'instance_type', 'fixed')
dpkg: error processing nova-common (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of nova-api:
 nova-api depends on nova-common (= 2013.1+git201212141401~precise-0ubuntu1); however:
  Package nova-common is not configured yet.
dpkg: error processing nova-api (--configure):
 dependency problems - leaving unconfigured
pkg: dependency problems prevent configuration of nova-cert:
 nova-cert depends on nova-common (= 2013.1+git201212141401~precise-0ubuntu1); however:
  Package nova-common is not configured yet.
dpkg: error processing nova-cert (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nova-consoleauth:
 nova-consoleauth depends on nova-common (= 2013.1+git201212141401~precise-0ubuntu1); however:
  Package nova-common is not configured yet.
dpkg: error processing nova-consoleauth (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nova-scheduler:
 nova-scheduler depends on nova-common (= 2013.1+git2012121414No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                                                                        No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                              No apport report written because MaxReports is reached already
                                                                                                                                                            No apport report written because MaxReports is reached already
                                      01~precise-0ubuntu1); however:
  Package nova-common is not configured yet.
dpkg: error processing nova-scheduler (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nova-common
 nova-api
 nova-cert
 nova-consoleauth
 nova-scheduler
E: Sub-process /usr/bin/dpkg returned an error code (1)

Related branches

Changed in nova (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Chuck Short (zulcss) on 2013-02-11
Changed in nova:
status: New → Invalid
Changed in nova (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2013.1.g3-0ubuntu1

---------------
nova (2013.1.g3-0ubuntu1) raring; urgency=low

  [ Chuck Short ]
  * New usptream release.
  * debian/patches/debian/patches/fix-ubuntu-tests.patch: Refreshed.
  * debian/nova-baremetal.logrotate: Fix logfile path.
  * debian/control, debian/nova-spiceproxy.{install, logrotate, upstart}:
    Add spice html5 proxy support.
  * debian/nova-novncproxy.upstart: Start on runlevel [2345]
  * debian/rules: Call testr directly since run_tests.sh -N gives weird return
    value when tests pass.
  * debian/pyddist-overrides: Add websockify.
  * debian/nova-common.postinst: Removed config file conversion, since
    the option is no longer available. (LP: #1110567)
  * debian/control: Add python-pyasn1 as a dependency.
  * debian/control: Add python-oslo-config as a dependency.
  * debian/control: Suggest sysfsutils, sg3-utils, multipath-tools for fibre
    channel support.

  [ Adam Gandelman ]
  * debian/control: Fix typo (websocikfy -> websockify).
 -- Chuck Short <email address hidden> Fri, 22 Feb 2013 09:27:29 -0600

Changed in nova (Ubuntu):
status: Fix Committed → Fix Released

how to we fix ? seems same issues

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers