OpenStack Compute (Nova)

public hostname get changed from internal hostname to public IP

Reported by Koji on 2013-01-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Sirushti Murugesan

Bug Description

The issue was reported by one of our users, and I've confirmed it happens when I use euca2ools. The command "euca-describe-instances" shows internal hostname as public hostname until the instance gets a public IP.

For example, if the public IP is 192.168.1.1, the output of euca-describe-instances will change like this.

[ Before getting public ip ]
euca-describe-instances i-0000088b
RESERVATION r-bwadwbbb 461884eef90047fbb4eb9ec92f22a1e3 default
INSTANCE i-0000088b ami-000000b4 server-2187 server-2187 running myopkey 0 m1.smal2013-01-05T21:09:31.000Z india aki-000000b3 monitoring-disabled 10.1.2.133 10.1.2.133 instance-store

[ After getting public ip ]
euca-describe-instances i-0000088b
RESERVATION r-bwadwbbb 461884eef90047fbb4eb9ec92f22a1e3 default
INSTANCE i-0000088b ami-000000b4 192.168.1.1 server-2187 running kjmac 0 m1.smal2013-01-05T21:09:31.000Z india aki-000000b3 monitoring-disabled 192.168.1.1 10.1.2.133 instance-store

As you can see, the public hostname is changed from "server-2187" to "192.168.1.1. The user said, "it is a problem for tools that assume the public hostname is not going to change once the VM is running."

So It would be great if it can be fixed.

Our OpenStack is Essex, running on Ubuntu-12.04 hosts with VLAN Manager.

Thanks.

Tags: ec2 Edit Tag help
Chuck Short (zulcss) wrote :

I see this on folsom as well.

Changed in nova:
importance: Undecided → Low
status: New → Confirmed
tags: added: ec2
Changed in nova:
assignee: nobody → Sirushti Murugesan (sirushtim)

Fix proposed to branch: master
Review: https://review.openstack.org/37840

Changed in nova:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/37840
Committed: http://github.com/openstack/nova/commit/050aa2bcbdd440e9d4a485796e8eaf1dbc70ff57
Submitter: Jenkins
Branch: master

commit 050aa2bcbdd440e9d4a485796e8eaf1dbc70ff57
Author: Sirushti Murugesan <email address hidden>
Date: Fri Jul 19 11:05:48 2013 +0530

    EC2-API: Fix ambiguous ipAddress/dnsName issue

    Currently, the public ipAddress and dnsName take in either the
    fixed or floating IP address as a value. The current fix ensures
    that the public dnsName and the public ipAddress both get only
    the floating ip address. A look into Amazon's EC2 API Reference
    tells us that if there is no public IP associated with an instance,
    an empty value is returned for <dnsName> and the key <ipAddress>
    itself is never returned. This was tested with euca2ools.
    Also, the key <publicDnsName> has been removed since it is
    the same as <dnsName>

    Fixes: bug #1096468

    Change-Id: I3b3e3b3f815df41d1976444d33604363e64a7709

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-09-05
Changed in nova:
milestone: none → havana-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in nova:
milestone: havana-3 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers