OpenStack Compute (Nova)

SADeprecationWarning: Pool.add_listener is deprecated. Use event.listen()

Reported by Johannes Erdfelt on 2012-07-31
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Cinder
Undecided
Qiu Yu
Glance
Low
Josh Kearney
Keystone
Low
Anthony Dodd
OpenStack Compute (nova)
Undecided
Johannes Erdfelt

Bug Description

The listeners kwarg has been deprecated in SQLAlchemy 0.7. The replacement is the new event.listen() API.

Fix proposed to branch: master
Review: https://review.openstack.org/10606

Changed in nova:
assignee: nobody → Johannes Erdfelt (johannes.erdfelt)
status: New → In Progress
Jay Pipes (jaypipes) on 2012-07-31
Changed in glance:
status: New → Triaged
importance: Undecided → Low
Jay Pipes (jaypipes) on 2012-07-31
tags: added: low-hanging-fruit

Reviewed: https://review.openstack.org/10606
Committed: http://github.com/openstack/nova/commit/28a7ac658959a8dcc8ba0b7d316fe598e7992c8b
Submitter: Jenkins
Branch: master

commit 28a7ac658959a8dcc8ba0b7d316fe598e7992c8b
Author: Johannes Erdfelt <email address hidden>
Date: Tue Jul 31 15:32:08 2012 +0000

    Use event.listen() instead of deprecated listeners kwarg

    Fixes bug 1031405

    The listeners kwarg is deprecated in SQLAlchemy 0.7.0. Since 0.7.3 is
    the minimum required version of SQLAlchemy, use the new event.listen()
    API instead.

    Change-Id: I3d2bd2e65dbc6787d1c9b69ffd0bcff85c157869

Changed in nova:
status: In Progress → Fix Committed
Josh Kearney (jk0) on 2012-08-01
Changed in glance:
assignee: nobody → Josh Kearney (jk0)
status: Triaged → In Progress
Brian Waldon (bcwaldon) on 2012-08-02
Changed in glance:
milestone: none → folsom-3

Reviewed: https://review.openstack.org/10665
Committed: http://github.com/openstack/glance/commit/6cc23005d042901e01bfee4deeb6367879012d22
Submitter: Jenkins
Branch: master

commit 6cc23005d042901e01bfee4deeb6367879012d22
Author: Josh Kearney <email address hidden>
Date: Wed Aug 1 12:05:42 2012 -0500

    Use event.listen() instead of deprecated listeners kwarg.

    The listeners kwarg is deprecated in SQLAlchemy 0.7.0. Since 0.7.3 is
    the minimum required version of SQLAlchemy, use the new event.listen()
    API instead.

    Fixes bug 1031405.

    Change-Id: Ibbfe46d065575b1954a47b3a28c61151dfb1e06e

Changed in glance:
status: In Progress → Fix Committed

Fix proposed to branch: master
Review: https://review.openstack.org/10746

Changed in keystone:
assignee: nobody → Rafael Durán Castañeda (rafadurancastaneda)
status: New → In Progress
Brian Waldon (bcwaldon) wrote :

Not backporting to glance 2012.1.2 since this is only a deprecation warning.

no longer affects: glance/essex
Thierry Carrez (ttx) on 2012-08-15
Changed in glance:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-08-16
Changed in nova:
milestone: none → folsom-3
status: Fix Committed → Fix Released
Qiu Yu (unicell) on 2012-08-20
Changed in cinder:
assignee: nobody → unicell (unicell)
Qiu Yu (unicell) on 2012-08-20
Changed in cinder:
status: New → In Progress

Reviewed: https://review.openstack.org/11644
Committed: http://github.com/openstack/cinder/commit/5da61a7ad9d7c3320831c437c03c428b9df84ebb
Submitter: Jenkins
Branch: master

commit 5da61a7ad9d7c3320831c437c03c428b9df84ebb
Author: unicell <email address hidden>
Date: Mon Aug 20 19:34:19 2012 +0800

    Use event.listen() instead of deprecated listeners kwarg

    Fixes bug 1031405

    The listeners kwarg is deprecated in SQLAlchemy 0.7.0. Since 0.7.3 is
    the minimum required version of SQLAlchemy, use the new event.listen()
    API instead.

    Change-Id: I1b851e197c04b131ae96e814780b04e6dcdeeb1a

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-09-18
Changed in cinder:
milestone: none → folsom-rc1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-09-27
Changed in glance:
milestone: folsom-3 → 2012.2
Thierry Carrez (ttx) on 2012-09-27
Changed in cinder:
milestone: folsom-rc1 → 2012.2
Thierry Carrez (ttx) on 2012-09-27
Changed in nova:
milestone: folsom-3 → 2012.2
Dolph Mathews (dolph) wrote :

Patch to keystone was abandoned.

Changed in keystone:
importance: Undecided → Low
status: In Progress → Confirmed
assignee: Rafael Durán Castañeda (rafadurancastaneda) → nobody
Anthony Dodd (thedodd) wrote :

I would like to get started on addressing this issue in keystone, but I'm not quite sure where to begin.

You would do pretty much the same thing all of the other projects have done. You can use this patch for nova as an example:

https://review.openstack.org/10606

Anthony Dodd (thedodd) wrote :

Great, thanks gentlemen. I will do the necessary research and, hopefully, have a fixed bug shortly!

Changed in keystone:
assignee: nobody → Anthony Dodd (thedodd)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/34266
Committed: http://github.com/openstack/keystone/commit/05e7a87b893aae0cb22ef85e282ada4979f9db9e
Submitter: Jenkins
Branch: master

commit 05e7a87b893aae0cb22ef85e282ada4979f9db9e
Author: Anthony Dodd <email address hidden>
Date: Mon Jun 24 16:23:00 2013 -0500

    Use event.listen() instead of deprecated listeners kwarg

    The listeners kwarg is deprecated in SQLAlchemy 0.7.0.
    Use the new event.listen() method instead.

    Instead of using the original approach of testing whether or not the string
    'mysql' is in 'connection_dict.drivername', now we are using a more direct
    string equality test to ensure that engine.name == 'mysql' before passing
    it to sql.event.listen().

    We've decided to change the name of our ping_listener function to reflect its
    purpose more accurately. Its name has been changed from "ping_listener" to
    "mysql_on_checkout".

    Change-Id: Ib9ef52404e3d474a60cdc82e8fcf8c6a9616bce3
    Fixes: bug #1031405

Changed in keystone:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-07-17
Changed in keystone:
milestone: none → havana-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in keystone:
milestone: havana-2 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers