Black screen with nouveau on a GeForce 8600M GT, either LiveCD or fresh install

Bug #713864 reported by Mathieu Marquer on 2011-02-06
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
Confirmed
High
linux (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-nouveau

Using Ubuntu Natty up-to-date on a Dell Vostro 1500 with a GeForce 8600M GT GPU. When I boot on the LiveCD or on a fresh install, nouveau seems to load correctly but all I get is a black screen.

On the attached Xorg.log, the lines at 27.960 is when I press Ctrl+Alt+F1 to see if I can get a tty (I still get a black screen), and 31.965 is when I Ctrl+Alt+Del to reboot the computer.

Please let me know if you need additional informations.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
Date: Sun Feb 6 00:58:13 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: vboxhost, 4.0.2: added
GraphicsCard: Subsystem: Dell Device [1028:0228]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110131)
MachineType: Dell Inc. Vostro 1500
ProcEnviron:
 LANGUAGE=fr_FR.UTF-8:fr:en_GB:en
 LANG=fr_FR.UTF-8
 LC_MESSAGES=fr_FR.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-1-generic root=UUID=55a88c4e-93f6-4ba7-aeae-9104bddc2682 ro nomodeset
SourcePackage: xserver-xorg-video-nouveau
dmi.bios.date: 04/21/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: 0WY040
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd04/21/2008:svnDellInc.:pnVostro1500:pvr:rvnDellInc.:rn0WY040:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Vostro 1500
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu9
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

Mathieu Marquer (slasher-fun) wrote :
Mathieu Marquer (slasher-fun) wrote :

Don't know why Xorg.log was a "raw data" file, reuploading as a text file.

Bryce Harrington (bryce) wrote :

Try booting with the vesafb.anything=1 kernel parameter.

This wiki page has details about how to add a kernel boot parameter for
testing:

https://wiki.ubuntu.com/Kernel/KernelBootParameters

Also, try removing 'splash quiet' from the kernel options and see if that matters. That should bypass plymouth which sometimes can leave the GPU in an inconsistent state.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Incomplete
Mathieu Marquer (slasher-fun) wrote :

I still get a black screen when removing quiet splah and adding vesafb.anything=1 as kernel parameters. Xorg.log is attached, 29.900 is when I Ctrl+Alt+F1 to see if that works on the tty (and it doesn't work either). The screen is turned on but black, it's not off.

Note that it kind of works when nVidia proprietary drivers are installed or when I use nomodeset (it actually uses Vesa instead of Nouveau, log attached as well).

Mathieu Marquer (slasher-fun) wrote :
Bryce Harrington (bryce) on 2011-02-12
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
Bryce Harrington (bryce) on 2011-03-19
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Triaged → Confirmed
Bryce Harrington (bryce) wrote :

Mathieu Marquer - I've forwarded this bug upstream to http://bugs.freedesktop.org/show_bug.cgi?id=35514 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

Also, if you could please re-test against current natty in case one of the recent kernel updates resolved the issue. (If the bug still occurs, attaching a fresh `dmesg` to the upstream bug report would likely help.

Bryce Harrington (bryce) wrote :

[Typically blank screen on boot bugs are kernel KMS issues rather than X specifically, so adding a linux task.]

Changed in nouveau:
importance: Unknown → High
status: Unknown → Confirmed
Mathieu Marquer (slasher-fun) wrote :

As requested on the Nouveau ML, I'm also adding the actual dmesg here in case somebody would encounter the same bug. Basically saying "Composite sync not supported"

Jeremy Foshee (jeremyfoshee) wrote :

Hi Mathieu,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Mathieu Marquer (slasher-fun) wrote :

Exact same behavior with kernel 2.6.39-999-generic_2.6.39-999.201104020912

tags: removed: needs-upstream-testing
Gabe Gorelick (gabegorelick) wrote :

I can confirm this on natty with 2.6.38-8-generic-pae (Dell XPS M1530, GeFore 8600M GT). The proprietary driver works fine. Incidentally this made the upgrade process from maverick to natty very difficult, as for some reason it tried to enable nouveau even though I had the proprietary drivers installed.

Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) on 2011-05-19
Changed in linux (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Hey slasher-fun,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Triaged → Incomplete
SarahSlean (yoda4) wrote :

the bug is aslo in the precise daily to yetersday i have written ubuntu low running graphics for the card 8600 gt nvidia . Also the same with the installation nvidia current

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Confirmed

Warning ! I have already seen 3 different machines with video cards :

- Nvidia C77 (Geforce 8200)
and
- Nvidia GeForce 315M (GT218)
and
- Another Nvidia which I don't remember

That will not boot Precise at all (and hang on black screen) if nouveau isn't blacklisted with "nouveau.blacklist=1" in grub command line.

jk (johan-illwinter) wrote :

I get the same black screen on xubuntu 12.04 beta 2.

Video card: nVidia Corporation GF116 [GeForce GTX 550 Ti]

Maarten Lankhorst (mlankhorst) wrote :

Would it be possible to attach a dmesg of a more recent kernel version? It looks like not all output connectors are recognised correctly, which explains the black screen.

Gabe Gorelick (gabegorelick) wrote :

This seems to be fixed for me. The only big problem now is plymouth is totally broken, but that's probably related to bug #713088 or some other issue.

Is this still a problem in Precise for anyone?

Mathieu Marquer, thank you for reporting this and helping make Ubuntu better. Natty reached EOL on October 2012.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue in a supported release? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-nouveau <replace-with-bug-number>

Please let us know your results. Thank you for your understanding.

Helpful Bug Reporting Tips:
https://help.ubuntu.com/community/ReportingBugs

tags: added: needs-upstream-testing
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) wrote :

Expired, here and upstream.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.