not work --expire-time attribute for notify-send

Bug #490065 reported by Sukochev Roman (Leolik) on 2009-11-29
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Notify OSD
Confirmed
Undecided
Unassigned

Bug Description

My system: Ubuntu 9.10 x86_64

not work --expire-time attribute for notify-send
always displayed 10 seconds

Sorry for my English.

Mirco Müller (macslow) wrote :

It is a deliberate design-decision to not offer applications control over the expire-timeout to help avoiding cluttering the desktop with notifications. It works in tandem with other spam-protection mechanisms in notify-osd. This prevents these situations from happening:

http://www.futurecrue.com/wp-content/uploads/2009/07/notification-daemon.jpg
http://urchin.earth.li/~jds/twitter-linux.jpg
http://3.bp.blogspot.com/_IWryv4TJmYk/SFHbL--EEWI/AAAAAAAAAEQ/ke9HSqN858M/s320/TwitterPop.jpg

Please also see https://wiki.ubuntu.com/NotifyOSD#org.freedesktop.Notifications.Notify for further details on this topic.

Changed in notify-osd:
status: New → Won't Fix
Justin Clift (justinclift) wrote :

The design is broken, and needs to be revisited.

Being able to get the notification bubble off the screen prior to our app taking a screenshot is critical. Removing timeout ability breaks that.

Changed in notify-osd:
status: Won't Fix → Confirmed
phillamg (me-phillg) wrote :

Surely this is duplicate of bug #390508

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers