test_parts.TestFocus.test_parts_delete_when_empty fails on maguro

Bug #1267755 reported by Olivier Tilloy on 2014-01-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
notes-app
Undecided
Olivier Tilloy
notes-app (Ubuntu)
Undecided
Unassigned

Bug Description

Related branches

Olivier Tilloy (osomon) wrote :
Download full text (5.9 KiB)

And here is the full log of the failure (from the smoke tests on image 114):

ADB_RC=0
Loading tests from: /home/phablet/autopilot

05:23:47.121 INFO autopilot:139 - Autopilot Source Version: 1.4.0
Autopilot Package Version: 1.4+14.04.20131125-0ubuntu3
now serving on port 12345
05:23:47.584 INFO globals:56 - ************************************************************
05:23:47.586 INFO globals:57 - Starting test notes_app.tests.test_parts.TestFocus.test_parts_delete_when_empty (with touch)
05:23:47.586 WARNING testcase:117 - No tracing available - install the python-autopilot-trace package!
05:23:47.769 WARNING testcase:154 - Process manager backend unavailable, application snapshot support disabled.
initctl: Unknown instance: com.ubuntu.notes_notes_1.4.235
05:23:50.496 INFO testcase:352 - Click package com.ubuntu.notes_notes_1.4.235 has been launched with PID 3161
127.0.0.1 - - [06/Jan/2014 05:23:51] "GET /image.png HTTP/1.1" 200 -
127.0.0.1 - - [06/Jan/2014 05:23:51] "GET /image.png HTTP/1.1" 200 -
127.0.0.1 - - [06/Jan/2014 05:23:51] "GET /image.png HTTP/1.1" 200 -
05:23:51.606 DEBUG dbus:431 - Selecting objects of type NotesApp with attributes: {}
05:23:51.654 DEBUG dbus:431 - Selecting objects of type NotesApp with attributes: {}
05:23:51.676 INFO logging:45 - NotesApp: Close the toolbar if it's opened. Arguments (). Keyword arguments: {}.
05:23:51.677 DEBUG dbus:431 - Selecting objects of type Toolbar with attributes: {}
05:23:51.717 INFO logging:45 - Toolbar: Close the toolbar if it's opened. Arguments (). Keyword arguments: {}.
05:23:51.833 DEBUG _uinput:366 - Dragging from 360,1136 to 360,1279
05:23:53.234 DEBUG dbus:431 - Selecting objects of type NotesApp with attributes: {}
05:23:53.268 DEBUG dbus:431 - Selecting objects of type NoteItem with attributes: {}
05:23:53.351 DEBUG _common:35 - Moving to object's globalRect coordinates.
05:23:53.352 DEBUG _uinput:332 - Tapping at: 360,355
05:23:54.690 DEBUG dbus:431 - Selecting objects of type NotesApp with attributes: {}
05:23:54.725 DEBUG dbus:431 - Selecting objects of type MixedEdit with attributes: {}
05:23:54.751 DEBUG dbus:431 - Selecting objects of type QQuickColumn with attributes: {}
05:23:54.966 DEBUG _uinput:332 - Tapping at: 360,610
05:23:55.069 DEBUG dbus:431 - Selecting objects of type NotesApp with attributes: {}
05:23:55.199 DEBUG dbus:431 - Selecting objects of type MixedEdit with attributes: {}
05:23:55.222 DEBUG dbus:431 - Selecting objects of type QQuickColumn with attributes: {}
05:23:55.364 DEBUG _uinput:332 - Tapping at: 360,362
05:23:55.467 DEBUG dbus:431 - Selecting objects of type NotesApp with attributes: {}
05:23:55.517 DEBUG dbus:431 - Selecting objects of type MixedEdit with attributes: {}
05:23:55.553 DEBUG dbus:431 - Selecting objects of type QQuickColumn with attributes: {}
05:23:56.727 DEBUG dbus:431 - Selecting objects of type NotesApp with attributes: {}
05:23:56.854 DEBUG dbus:431 - Selecting objects of type MixedEdit with attributes: {}
05:23:56.875 DEBUG dbus:431 - Selecting objects of type QQuickColumn with attributes: {}
05:23:58.078 DEBUG dbus:431 - Selecting objects of type NotesApp with attributes: {}
05:23:58.123 DEBUG dbus:431 - Selecting o...

Read more...

Olivier Tilloy (osomon) wrote :

I have managed to reproduce the issue locally on my Galaxy Nexus.

When this happens, after clicking on the upper part of the image to trigger the deletion of the empty part that was below it, I’m seeing a contextual menu displayed, with "Cut" and "Copy", which seems to be linked to the image part. Displaying the contextual menu happens only in an onPressAndHold handler, which means a long press (≥800ms, IIRC).

Changed in notes-app:
status: New → Confirmed
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) wrote :

I can reliably reproduce the issue if I modify the test to pass press_duration=1 to self.pointing_device.click() which as a consequence simulates a long press.

It looks like something causes slowness that makes the tap longer than it should be. My best guess at this point is the OSK coming up as a result of focusing a text area (the empty part at the end). I’ll see if waiting for the OSK to be fully up before clicking on the image improves things.

Olivier Tilloy (osomon) wrote :

It looks like waiting for the OSK to be fully up indeed improves the situation. I’ve run the test on my Galaxy Nexus 20 times in a row without a single failure, whereas before it would fail on average once every 5 runs.

Changed in notes-app:
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:notes-app at revision None, scheduled for release in notes-app, milestone ubuntu-13.04-month-5

Changed in notes-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notes-app - 1.4+14.04.20140113.1-0ubuntu1

---------------
notes-app (1.4+14.04.20140113.1-0ubuntu1) trusty; urgency=low

  [ Ugo Riboni ]
  * Fake merge request to try having jenkins run tests many times.

  [ Olivier Tilloy ]
  * Ensure the note is collapsed before testing its contents.
  * Ensure the OSK is fully up before interacting with another part of
    the note, and use a more reliable way of checking that a note part
    has been destroyed. (LP: #1267755)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 242
 -- Ubuntu daily release <email address hidden> Mon, 13 Jan 2014 11:11:45 +0000

Changed in notes-app (Ubuntu):
status: New → Fix Released
Olivier Tilloy (osomon) on 2014-01-21
Changed in notes-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers