keyboard re-appears after swiping it away

Bug #1182108 reported by Bill Filler on 2013-05-20
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
notes-app
Critical
Ugo Riboni

Bug Description

Maguro
Build 125

Steps to reproduce:
- start typing in a note
- swipe keyboard away

Expected results:
- keyboard disappears

Results:
- keyboard disappears and then pops right back up

Check the logic in the app that hides/shows the keyboard or responds to the events to make sure we're not telling it to show incorrectly.

Related branches

Bill Filler (bfiller) on 2013-05-20
Changed in notes-app:
importance: Undecided → High
assignee: nobody → Ugo Riboni (uriboni)
milestone: none → ubuntu-13.05
Bill Filler (bfiller) wrote :

This makes it impossible to bring up the toolbar to add another note, so it's being marked as critical.

Changed in notes-app:
importance: High → Critical
Ugo Riboni (uriboni) on 2013-05-21
Changed in notes-app:
status: New → In Progress
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1182108

tags: added: iso-testing
Ugo Riboni (uriboni) wrote :

The attached simple test can be useful to experiment with focus without having to use the entire notes app

Ugo Riboni (uriboni) wrote :

It seems there's a problem in TextArea.
To reproduce:
* place the attached library in /data/ubuntu/usr/lib/arm-linux-gnueabihf/qt5/plugins/platforminputcontexts/libmaliitplatforminputcontextplugin.so
* run the example attached to the previous comment (making sure that in the example the text component is a TextArea and not a TextInput)
* hide the keyboard manually
* verify that on the debug label you see FOCUS: true

Then to verify that the normal TextInput does not have this problem run the same example with a TextInput as text component and verify that hiding the keyboard will produce FOCUS: false on the debug label.

Thus there is something wrong in TextArea that does not allow the text area to lose focus properly.

Zsombor Egri (zsombi) wrote :

I've tested with the attached test app, and TextField->TextInput (Qt) and TextArea->TextEdit (Qt) all behave the same.

When OSK is hidden manually, both TextInput and TextEdit QtQuick components keep both focus and activeFocus properties on. The same happens when TextField and TextArea are used.

So the bouncing back effect seems to be caused by Notes, however the fact that text inputs have activeFocus on when the OSK is hidden seems to be still a bug in OSK.

Changed in notes-app:
status: In Progress → Fix Committed
Olivier Tilloy (osomon) on 2013-09-27
Changed in notes-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers