Can't play after install missing plugins

Bug #999735 reported by Mario Guerriero on 2012-05-15
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Noise
Fix Released
High
Adam Davies

Bug Description

If I try to play a song and I don't have the necessary plugins, Noise installs them. After, when I try to play the song, I have to close the app to listen my song

Changed in noise:
importance: Undecided → High
milestone: none → 1.0
status: New → Confirmed
David Gomes (davidgomes) wrote :

So basically you need to restart Noise after installing the necessary plugins? It's a one-time restart?

Victor Martinez (victored) wrote :

That's why I understand from reading the report

David Gomes (davidgomes) wrote :

If a fix for this bug can't be found, I suggest we tell the user "You need to restart Noise to start playing music" or something like that.

This is almost like an "upgrade" to Noise. It's OK to force a restart on an app which has just been upgraded, we just need to tell the user to restart and they will.

I would much much much rather it gets handled by the app rather than saying, "Oh, hey, can you do this for me? I'm not smart enough to take care of it myself. Thanks..." Ideally it would install the plugins then play the song once they're installed without any sort of a restart.

Daniel Fore (danrabbit) wrote :

Ideally Noise could restart the music playing backend automatically without closing the window.

Less ideally, the whole app closes and relaunches itself.

least ideally, it throws up an error message about restarting that most people probably will not read.

Mario Guerriero (mefrio-g) wrote :

Maybe stopping and restarting Gst module could be useful.

Adam Davies (adam-davies) wrote :

Seems to be a fundemental problem in the event that's triggered when the plugins are installed. It fails and spits out the error:

assertion SELF == null failed.
Noise will not function properly.

Victor Martinez (victored) wrote :

No need to restart the app. We can proceed as Mario suggested and only restart the player backend.

Adam Davies (adam-davies) wrote :

Okay, I made a branch that sort-of helped. Basically, if my debugging is right, it completely didn't run the method that is called when the installer completes. I made the method async and added a yield. That made it run, but it still doesn't work completely.

Adam Davies (adam-davies) wrote :

Sorry for spamming this report, but in further testing, when I, install the plugin the first time, I can then attempt to play a song and then attempt to re-install the plugin. Without restarting the music then plays. It seems that somehow, when the installation is repeated it works.

Changed in noise:
status: Confirmed → In Progress
Changed in noise:
status: In Progress → Fix Committed
Changed in noise:
assignee: nobody → Adam Davies (adam-davies)
Changed in noise:
status: Fix Committed → Fix Released
yEdubart (vps1992) wrote :

This bug is not fixed!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers