Fails to preserve maximized state

Bug #999628 reported by Sergey "Shnatsel" Davidoff on 2012-05-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BeatBox
Low
BeatBox Team
Files
Fix Released
Medium
Unassigned
Noise
Fix Released
Medium
Victor Martinez
Scratch
Fix Released
Medium
Mario Guerriero
Terminal
Invalid
Medium
Unassigned

Bug Description

Applications like noise, beatbox, marlin, etc fail to preserve maximized state between runs both under compiz and metacity. They do preserve window size, but the window is not treated as maximized by window manager and decorator.

They do preserve their size, but they don't go into the maximized state, it's just a regular window the size of a maximized one.

Oh, it works fine in Mutter. Weird.

This is going to be a problem in Luna unless we use a Mutter derivative (which will hopefully happen).

Changed in noise:
assignee: nobody → Victor Eduardo (victored)
importance: Undecided → Medium
milestone: none → 1.0
status: New → Fix Committed

Hmm, so it's a problem with apps themselves? Not with Granite?

Victor Martinez (victored) wrote :

Yes. Each app is responsible for listening to the configure event on their windows and properly restoring the geometry from settings during startup.

no longer affects: granite
Victor Martinez (victored) wrote :

On a side note, I'm willing to hack anything just for the sake of getting Mutter in Luna :P

Victor Martinez (victored) wrote :

Files doesn't keep the maximized state.

Changed in pantheon-files:
status: New → Confirmed

Shotwell is also affected. Gotta get the word to their Trac bug tracker.

summary: - Apps fail to preserve maximized state
+ Fails to preserve maximized state
description: updated
Mario Guerriero (mefrio-g) wrote :

in Files it was just fixed

Changed in scratch:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → luna-beta1
assignee: nobody → Mario Guerriero (mefrio-g)
Changed in pantheon-terminal:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → luna-beta1
Changed in scratch:
status: Confirmed → Fix Committed
Changed in pantheon-files:
status: Confirmed → Fix Committed

I guess Terminal does that by design. Scratch seems to follow, though I don't know why.

Changed in pantheon-terminal:
status: Confirmed → Invalid
Mario Guerriero (mefrio-g) wrote :

Sergey it is a bug for terminal. It doesn't prevserve maximized state

Changed in pantheon-terminal:
status: Invalid → Confirmed

It's not supposed to preserve it. It should always open in default 80xSMTH lines size.

Changed in pantheon-terminal:
status: Confirmed → Invalid
milestone: luna-beta1 → none
Daniel Fore (danrabbit) on 2012-05-27
Changed in pantheon-files:
milestone: none → 0.1
Daniel Fore (danrabbit) on 2012-05-27
Changed in pantheon-files:
milestone: 0.1 → luna-beta1
Changed in beat-box:
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Scott Ringwelski (sgringwe)
assignee: Scott Ringwelski (sgringwe) → nobody
milestone: none → 0.6
Changed in beat-box:
status: Fix Committed → Fix Released
assignee: nobody → BeatBox Team (beatbox-team)
Daniel Fore (danrabbit) on 2012-08-03
Changed in scratch:
status: Fix Committed → Fix Released
David Gomes (davidgomes) on 2012-12-02
Changed in pantheon-files:
importance: Undecided → Medium
Jim Nelson (yorba-jim) wrote :

I've ticketed Shotwell on Yorba's Redmine server: http://redmine.yorba.org/issues/6116

However, I can't reproduce this when running Shotwell out of trunk. Is there a specific window manager you see this in?

I can't reproduce this anymore on version 0.13.1-1~precise1 under Gala. Consider it invalid.

Jim Nelson (yorba-jim) wrote :

Done. However, I don't have rights to mark it as such here.

no longer affects: shotwell
Changed in noise:
status: Fix Committed → Fix Released
Changed in pantheon-files:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers