Disable automatic scan and the first three options in "preferences" by default

Bug #1215569 reported by GonzO on 2013-08-22
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Noise
Opinion
Critical
elementary UX

Bug Description

This is more of a request than a bug. I would very much prefer it if Noise did not automatically scan my Music folder on first (or any) launch.

Failing that request, if the scan must be kept, I would prefer that the first three options:
- Keep Music Folder Organized
- Write Metadata to File
- Copy Imported Files to Library

...be disabled by default.

The reasons are simple: the first is a complex and time-consuming operation that more often than not impacts the entirety of a system's performance and (usually, in my case) locks up Noise. I don't think a user will be expecting when they just want to launch a jukebox-type program.

The second is that the mentioned objects change (or have the potential to change) one's data, without any real input. If I understand them correctly, the first allows Noise to change the names of files and folders; the second allows Noise to change the tag data in music files; and the third allows Noise to create copies of files (which, in my case, could take up *considerable* space, given a nearly 100G collection).

In tandem, these things can be a powerful one-two punch of unintended consequences: by simply clicking on an orange box with a music note in it, my system *immediately* becomes very busy and kind of slow; all the while, my hard drive space might be diminishing and my data might be getting renamed and moved around, all from just *clicking one icon*.

At best, I would like *both* the automatic first scan *and* all three options to be "off" until I get a chance to look around and turn them on. But having the scan automatically start wouldn't be so bad if those options were off by default -- after all, the first thing anyone's probably going to want to do is import a library (as a music player isn't of much value without one).

If anyone is curious: I found out about this because my particular dual-boot setup exposed the problem. Most of my drive space belongs to windows, and I simply remap my /home/Music folder to a symlink of the one in my Windows account's iTunes folder. Imagine my surprise when subtle changes to filenames and tag data rendered a considerable amount of my iTunes database incorrect.

Related branches

zinga (zinga) wrote :

I agree absolutely.

This just made me panic while I was doing a new backup of my music files (as the old backup disk was defect) using the new Luna installation. While the backup was running I clicked on an mp3 in "Files" which made "Music/Noise" open to play the file but also start importing data. When checking the "Settings" in "Music" I was shocked to see these options - potentially modifying my music files (without me wanting it - and before I had a new backup).

Cameron Norman (cameronnemo) wrote :

I do not think we should change the defaults, but instead notify the user that their music folder will be (re)organized. Also these two items:

- Write Metadata to File
- Copy Imported Files to Library

only happen when you edit a song or use the import function in Noise, so it does not happen at startup.

David Gomes (davidgomes) on 2013-09-16
Changed in noise:
assignee: nobody → elementary UX Team (elementary-design)
Julián Unrrein (junrrein) wrote :

There is a Won't fix about the "Keep Music Folder organized" thing: https://bugs.launchpad.net/noise/+bug/1211404

Daniel Fore (danrabbit) on 2013-09-16
Changed in noise:
status: New → Won't Fix
Rico Tzschichholz (ricotz) wrote :

@dan: IMHO, this should really be *disabled* by default, and make it clear what is going to to happen if you enable it. Your argument is really right, since Noise is "virtualizing" your music-archive anyway. So why even bother how the files are organized on the disk.

Changed in noise:
status: Won't Fix → Confirmed
importance: Undecided → Critical
Rico Tzschichholz (ricotz) wrote :

@dan: Ah, I am explicitly referring to the "Keep Music Folder Organized" setting here.

Daniel Fore (danrabbit) wrote :

Cassidy and I will sit down and try to come up with an intelligent first run scenario that works for everyone.

Changed in noise:
status: Confirmed → Opinion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers