Manage Music by Default

Bug #1178463 reported by Daniel Fore on 2013-05-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Noise
Won't Fix
Undecided
Unassigned
elementary OS
Fix Released
Medium
Cody Garver

Bug Description

While it's understandable that we have the option to not manage the library, I feel like this is the exception case rather than the rule. I think most users would rather we take care of keeping their files in order.

Related branches

Daniel Fore (danrabbit) wrote :

If not in upstream Noise, this should definitely be the default in elementary OS since we are the only default music player.

Shawn McTear (syst3mfailur3) wrote :

How does Noise/Music order the files? I'm hesitant trusting an app doing what I have spent so much time on. I'm worried that if this were to become the default, compilation albums and the like might get mis-managed.

Cody Garver (codygarver) on 2013-05-10
Changed in elementaryos:
milestone: none → luna-rc1
assignee: nobody → Cody Garver (codygarver)
importance: Undecided → Medium
status: New → In Progress
tags: added: defaults
Daniel Fore (danrabbit) wrote :

Related: https://bugs.launchpad.net/noise/+bug/1178546

I think we'll probably "won't fix" this is Noise and handle it in the OS for now.

Changed in noise:
status: New → Won't Fix

I strongly oppose this change. The problem is the changes Noise does (renaming and moving files around) are not undoable. If somebody spent time to actually sort their music folder (like I did), simply opening the music player for the first time will ruin their content organization. So please DO NOT do this by default! This will alienate power users once and for all, while we are dependent on them to spread and test the OS.

To be able to enable this by default we have to either make the changes undoable (which is not worth the effort IMHO) or implement some clever migration of existing file/folder layout to e.g. tags, see https://blueprints.launchpad.net/elementaryos/+spec/easy-migration-to-librarykit

Daniel Fore (danrabbit) wrote :

Sergey, this is why we've marked it "Won't Fix" for Noise upstream and only want to apply the change to a fresh install of the OS. You have to be migrating your library from somewhere right? So by definition you have a backup.

If you're unhappy with the way Noise manages the library, please file bugs about what it does wrong. But remember we set defaults based on the majority use case, not the corner cases.

Cody Garver (codygarver) on 2013-05-16
Changed in elementaryos:
status: In Progress → Fix Released
Simeon (simeon5) wrote :

I am with Sergey on this. But lets go along and see how it is implemented and discuss/file bugs about it later.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers