noise wait a lot for focus

Bug #1030974 reported by Bence Lukács on 2012-07-30
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
BeatBox
Undecided
Unassigned
Noise
Fix Released
Undecided
Unassigned

Bug Description

If I turn back to Noise from another window, it takes a lot time until I can click on anything, or I can use Noise. It seems as it doesn't have the focus. See the attached video about the problem.

Bence Lukács (lukacs-bence1) wrote :

So here it is :)

Changed in noise:
status: New → Confirmed
Victor Martinez (victored) wrote :

Are you sure it doesn't happen with other applications too?

Changed in noise:
status: Confirmed → Incomplete
Bence Lukács (lukacs-bence1) wrote :

@victored Yes, I'm sure that only noise do this. Now it takes a bit less time, but it still annoying.

Victor Martinez (victored) wrote :

Thanks for the reply Bence. I think you are correct in the other report. It could be related to the spacing issues found in the icon view. Will look into it later.

Göran Olsson (kronstadt21) wrote :

I'm experincing the same problem, although on BeatBox. It's really sluggish to the point of being unusable when using the album grid view but snappy when using list view.

Changed in beat-box:
status: New → Invalid
status: Invalid → New
Göran Olsson (kronstadt21) wrote :

Forget the "snappy when using list view". Its now totally unusable...

Kurt Smolderen (kurt.smolderen) wrote :

@Göran: Are you talking about Noise or Beatbox now?

Göran Olsson (kronstadt21) wrote :

@Kurt: I'm talking about Beatbox.

@Göran: Are you running beatbox from Scott's ppa or did you compile it yourself? I'm asking this because Beatbox hasn't been updated in its ppa since 13 November, so in that case there must be another reason...

On which OS are you running Beatbox? I'm using Ubuntu 12.04 and everything works fine. But I have the feeling more things are broken in 12.10...

Göran Olsson (kronstadt21) wrote :
Download full text (3.2 KiB)

Noticed that beatbox seamed to snap out of its sluggishness after being idle for some time (hours), and I was able to scroll through the listview. So I exited and restarted and again its unresponsive. I should also mention that cpu load averages around 96%. Can't remember the figure for earlier builds of beatbox but it certainly wasn't as high as that.

Here's my output when running beatbox from terminal:

[_LOG_LEVEL_INFO 20:32:25.301023] Application.vala:77: BeatBox version: 0.7
[_LOG_LEVEL_INFO 20:32:25.301085] Application.vala:79: Kernel version: 3.5.0-19-generic
[_LOG_LEVEL_INFO 20:32:25.526045] Info.vala:83: Loading info from database...
[_LOG_LEVEL_INFO 20:32:25.631854] SongLibrary.vala:72: Loading songs...
[_LOG_LEVEL_INFO 20:32:28.201027] PodcastLibrary.vala:72: Loading podcasts...
[_LOG_LEVEL_INFO 20:32:28.201360] StationLibrary.vala:57: Loading stations...
[_LOG_LEVEL_INFO 20:32:28.218161] PlaylistManager.vala:42: Loading playlists from database...
[_LOG_LEVEL_INFO 20:32:28.253482] LibraryWindow.vala:172: Building user interface
[_LOG_LEVEL_WARN 20:32:28.308055] [Gtk] Theme parsing error: <unknown>:57:17: Not using units is deprecated. Assuming 'px'.
[_LOG_LEVEL_WARN 20:32:28.308124] [Gtk] Theme parsing error: <unknown>:57:19: Not using units is deprecated. Assuming 'px'.
[_LOG_LEVEL_WARN 20:32:28.308799] [Gtk] Theme parsing error: <unknown>:34:17: Not using units is deprecated. Assuming 'px'.
[_LOG_LEVEL_WARN 20:32:28.308853] [Gtk] Theme parsing error: <unknown>:34:19: Not using units is deprecated. Assuming 'px'.
[_LOG_LEVEL_WARN 20:32:28.325241] [Gtk] Theme parsing error: <unknown>:34:17: Not using units is deprecated. Assuming 'px'.
[_LOG_LEVEL_WARN 20:32:28.325306] [Gtk] Theme parsing error: <unknown>:34:19: Not using units is deprecated. Assuming 'px'.
[_LOG_LEVEL_WARN 20:32:28.414279] MusicSourceView.vala:46: TODO: Fixme
[_LOG_LEVEL_INFO 20:32:32.119159] AZLyricsPlugin.vala:38: AZLyrics Source loaded
[_LOG_LEVEL_INFO 20:32:32.119214] LastFMInfoPlugin.vala:38: Last.fm Info Source loaded
[_LOG_LEVEL_WARN 20:32:35.546581] [Gtk] Failed to set text from markup due to error parsing markup: Fel på rad 1: Entitetsnamnet "uuml" är okänt
[_LOG_LEVEL_WARN 20:32:46.998062] [Gtk] Failed to set text from markup due to error parsing markup: Fel på rad 1: Entitetsnamnet "uuml" är okänt
[_LOG_LEVEL_WARN 20:32:46.998172] [Gtk] Failed to set text from markup due to error parsing markup: Fel på rad 1: Entitetsnamnet "uuml" är okänt
[_LOG_LEVEL_WARN 20:32:46.998494] [Gtk] Failed to set text from markup due to error parsing markup: Fel på rad 1: Entitetsnamnet "uuml" är okänt
[_LOG_LEVEL_WARN 20:32:46.998586] [Gtk] Failed to set text from markup due to error parsing markup: Fel på rad 1: Entitetsnamnet "uuml" är okänt
[_LOG_LEVEL_WARN 20:32:47.084473] [Gtk] Failed to set text from markup due to error parsing markup: Fel på rad 1: Entitetsnamnet "uuml" är okänt
[_LOG_LEVEL_WARN 20:32:47.106887] [Gtk] Failed to set text from markup due to error parsing markup: Fel på rad 1: Entitetsnamnet "uuml" är okänt
[_LOG_LEVEL_WARN 20:32:47.189822] [Gtk] Failed to set text from markup due to error parsing markup: Fel på rad 1: Entitetsnamnet "uuml" är okänt
[...

Read more...

Scott Ringwelski (sgringwe) wrote :

In 12.10 the gtk iconview was redone. I'm guessing that the algorithm that resizes the grid is continuously reacting to its own resizes. The alg for 12.10 needs to be redone.

Göran Olsson (kronstadt21) wrote :

@Kurt: I'm using ubuntu 12.10 and beatbox from Scott's ppa.

Göran Olsson (kronstadt21) wrote :

Back to usable again today. Maybe on account of upgrade of libgranite to 0.2.0-0~r465+pkg45~quantal1???

Corentin Noël (tintou) wrote :

I think that this bug is fixed now

Changed in noise:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers