Comment 2 for bug 1002185

Pim Vullers (pimvullers) wrote :

I don't know, I'm not using Ubuntu but Gentoo. And I build it from source.

This is the relevant part from CMakeLists.txt:

pkg_check_modules(DEPS
    REQUIRED
    glib-2.0
...
    sqlheavy-0.1
...
    libpeas-1.0)
# Check if we have sqlheavy-0.2

if(${SQLHEAVY_USE_2})
pkg_check_modules(SQLHEAVY sqlheavy-0.2)
set(ADD_PKG ${ADD_PKG} sqlheavy-0.2)
message("-- Will use sqlheavy-0.2")
else()
set(ADD_PKG ${ADD_PKG} sqlheavy-0.1)
pkg_check_modules(SQLHEAVY sqlheavy-0.1)
message("-- Will use sqlheavy-0.1")
endif()

If I'm correct sqlheavy-0.1 should dropped from the first REQUIRED list and the check should be altered to :

else()
set(ADD_PKG ${ADD_PKG} sqlheavy-0.1)
pkg_check_modules(SQLHEAVY REQUIRED sqlheavy-0.1)
message("-- Will use sqlheavy-0.1")
endif()

i.e. do not require sqlheavy-0.1 in the first place but check if sqlheavy-0.2 is available if so use that, otherwise require sqlheavy-0.1