Errors upgrading 1.10.1 to 1.10.2

Bug #1658127 reported by Paul Pace on 2017-01-20
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nginx
Medium
Thomas Ward

Bug Description

Upgrading ngnix on 16.04 from 1.10.1 to 1.10.2 reports the following at the end of the upgrade:

Setting up libnginx-mod-http-upstream-fair (1.10.2-3+xenial4) ...
nginx: [error] open() "/run/nginx.pid" failed (2: No such file or directory)
dpkg: error processing package libnginx-mod-http-upstream-fair (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up libnginx-mod-http-xslt-filter (1.10.2-3+xenial4) ...
Setting up libnginx-mod-mail (1.10.2-3+xenial4) ...
Setting up libnginx-mod-stream (1.10.2-3+xenial4) ...
dpkg: dependency problems prevent configuration of nginx-full:
 nginx-full depends on libnginx-mod-http-upstream-fair (= 1.10.2-3+xenial4); however:
  Package libnginx-mod-http-upstream-fair is not configured yet.

dpkg: error processing package nginx-full (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nginx:No apport report written because the error message indicates its a followup error from a previous failure.

 nginx depends on nginx-full (<< 1.10.2-3+xenial4.1~) | nginx-light (<< 1.10.2-3+xenial4.1~) | nginx-extras (<< 1.10.2-3+xenial4.1~); however:
  Package nginx-full is not configured yet.
  Package nginx-light is not installed.
  Package nginx-extras is not installed.
 nginx depends on nginx-full (>= 1.10.2-3+xenial4) | nginx-light (>= 1.10.2-3+xenial4) | nginx-extras (>= 1.10.2-3+xenial4); however:
  Package nginx-full is not configured yet.
  Package nginx-light is not installed.
  Package nginx-extras is not installed.

dpkg: error processing package nginx (--configure):
 dependency problems - leaving unconfigured
Setting up libpulse0:amd64 (1:8.0-0ubuntu3.2) ...No apport report written because the error message indicates its a followup error from a previous failure.

Setting up liblxc1 (2.0.6-0ubuntu1~ubuntu16.04.2) ...
Setting up lxc-common (2.0.6-0ubuntu1~ubuntu16.04.2) ...
Processing triggers for libc-bin (2.23-0ubuntu5) ...
Errors were encountered while processing:
 libnginx-mod-http-upstream-fair
 nginx-full
 nginx
E: Sub-process /usr/bin/dpkg returned an error code (1)
Failed to perform requested operation on package. Trying to recover:
Setting up libnginx-mod-http-upstream-fair (1.10.2-3+xenial4) ...
Setting up nginx-full (1.10.2-3+xenial4) ...
Setting up nginx (1.10.2-3+xenial4) ...

Sven (muffl0n) wrote :

Seems to be the same problem on Trusty as well.

Thomas Ward (teward) on 2017-02-02
Changed in nginx:
importance: Undecided → Medium
assignee: nobody → Thomas Ward (teward)
Davide (darkenergyreactor) wrote :

Same on trusty, I had to temporarly patch the failing postinst scripts in /var/lib/dpkg/info/ to just return to get it installed.

Thomas Ward (teward) wrote :

Davide: Mind including a diff identifying what you changed?

Davide (darkenergyreactor) wrote :

I inserted a 'return' at the beginning of the following postinst scripts, but I didn't have time to check why they fail:
/var/lib/dpkg/info/libnginx-mod-http-image-filter.postinst
/var/lib/dpkg/info/libnginx-mod-http-subs-filter.postinst
/var/lib/dpkg/info/libnginx-mod-http-upstream-fair.postinst
/var/lib/dpkg/info/libnginx-mod-http-xslt-filter.postinst
/var/lib/dpkg/info/libnginx-mod-mail.postinst
/var/lib/dpkg/info/libnginx-mod-stream.postinst

This is just a quick workaround to fix the broken dependencies.

Near the end of the installation process you'll also see invoke-rc.d failing because 'upgrade' is not supported (maybe service should be used instead?)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers