child_department in category->scopes doesn't work

Bug #1604212 reported by Zhang Enwei on 2016-07-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
News Scope
High
Penk Chen
scope-aggregator
Critical
Zhang Enwei

Bug Description

From scope aggregator 4.8 release, child_department in category->scopes doesn't work.
How to reproduce:
Install news-china and sinanews, check all the departments, sinanews returns same items.
Root Cause,
utils.cpp-->load_declarations line 278 to line 294
if (agg_scope_->lang().size() == 2 && child_dept.contains(QStringLiteral("LANGCODE")))
{
    child_dept = child_dept.replace(QStringLiteral("LANGCODE"), qstr(agg_scope_->lang()));
    scopeLocalId_childDept_m[local_id] = child_dept.toStdString();
}

should be
if (agg_scope_->lang().size() == 2)
{
    if (child_dept.contains(QStringLiteral("LANGCODE")))
    {
        child_dept = child_dept.replace(QStringLiteral("LANGCODE"), qstr(agg_scope_->lang()));
    }
    scopeLocalId_childDept_m[local_id] = child_dept.toStdString();
}

Related branches

Zhang Enwei (zhangew401) on 2016-07-19
Changed in scope-aggregator:
assignee: nobody → Zhang Enwei (zhangew401)
importance: Undecided → Critical
status: New → In Progress
Zhang Enwei (zhangew401) on 2016-08-03
Changed in scope-aggregator:
status: In Progress → Fix Committed
Changed in news-scope:
assignee: nobody → Kyle Nitzsche (knitzsche)
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

marking this released in scope-aggregator since I just merged google test impl and released 4.12.

Changed in scope-aggregator:
status: Fix Committed → Fix Released
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

I rebased news (4.12.0) on scope-aggregator 4.12, thus fixing this regression.

Penk, please QA and release attached (not in clicks).

Changed in news-scope:
status: Confirmed → Fix Committed
assignee: Kyle Nitzsche (knitzsche) → Penk Chen (penk)
tags: added: ota14 store
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

Current News scope in the store is 4.7.0 (which is behind released version, see bug 1636224)

https://uappexplorer.com/app/com.canonical.scopes.news

4.7.0 version has some issues and should now be updated to latest QAd version from clicks:4.9.0

And 4.12.0 should be QAd and released in ota14 and to store.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers