fallback handling

Bug #1599948 reported by Kyle Nitzsche on 2016-07-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NearBy Scope
High
Penk Chen
News Scope
High
Penk Chen
Photos Scope
High
Penk Chen
Today Scope
High
Penk Chen
scope-aggregator
High
Kyle Nitzsche

Bug Description

New Description:
Child scopes that provide results that lack an "art" attribute trigger fallback code. This sometimes fails and throws the uncaught exception listed in the Old Description. El Pais scope and Yahoo scope are known to provide such partial results.

Old Description:
When el pais is enabled and you refresh the default Headlines dept, one gets this exception in the scope-registry.log:

[2016-07-07 14:02:05.651] ERROR: com.canonical.scopes.news_unity-scope-news: ReplyObject::push(): ReplyObject::push(VariantMap): unity::LogicException: Variant does not contain a string value:
    boost::bad_get: failed value get using boost::get
query complete, status: error

: ReplyObject::push(VariantMap): unity::LogicException: Variant does not contain a string value:
    boost::bad_get: failed value get using boost::get

Removing el pais causes no such logged exceptions.

Related branches

Changed in news-scope:
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

The problem here is in the scope-aggregator code that attempts to use fallback result fields to find art. If the result lacks the expected field, the declared fallback fields are checked in sequence. The code can try to read a result attribute that does not exist, and so an exception is thrown.

Changed in news-scope:
assignee: nobody → Kyle Nitzsche (knitzsche)
Changed in scope-aggregator:
importance: Undecided → High
assignee: nobody → Kyle Nitzsche (knitzsche)
summary: - exception in log related to el pais
+ fallback handling
description: updated
Changed in scope-aggregator:
status: New → Confirmed
Changed in nearby-scope:
status: New → Confirmed
assignee: nobody → Kyle Nitzsche (knitzsche)
Changed in photos-scope:
status: New → Confirmed
assignee: nobody → Kyle Nitzsche (knitzsche)
Changed in today-scope:
status: New → Confirmed
assignee: nobody → Kyle Nitzsche (knitzsche)
Changed in nearby-scope:
importance: Undecided → High
Changed in photos-scope:
importance: Undecided → High
Changed in today-scope:
importance: Undecided → High
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

4.9 scope-aggregator is released, fixing the fallback handling bug.

Changed in scope-aggregator:
status: Confirmed → Fix Released
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

News scope 4.9.0 is released and attached here (but not added to clicks) including this rebase/fix.

Testing doc: https://docs.google.com/document/d/1a6ad4IKefC8jhzAoYFIgDqd3VcofSg-fq_kGSnx3a9I/edit#

Changed in news-scope:
status: Confirmed → Fix Committed
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

Today scope 4.9.0 is released and attached here (but not added to clicks), including this fix.

Testing doc: https://docs.google.com/document/d/1BdmVF3F2ZYJr-ErY4M7MeZrIL8olQHZCV7rze7eWiL0/edit#

Changed in today-scope:
status: Confirmed → Fix Committed
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

Nearby scope 4.9.0 is ready and attached here (but not added to clicks), including this fix.

Testing doc: https://docs.google.com/document/d/1pTSM8DufocwVVfKjtx3YNrHvIcW3jQ7KBoM475hBjSY/edit#

Changed in nearby-scope:
status: Confirmed → Fix Committed
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

Photos scope 4.9.0 is ready and attached here (but not added to clicks), including this fix and two others:
* Dropbox scope ID is fixed (it changed to dropboxcp.canonicalpartners_dropbox)
* Douban declaration is simplified (no user detectable change though)

Testing doc: https://docs.google.com/document/d/1UhxVoFJ5ISseyrN7AH7uQ3h7E88kOM9dX1ucVj-JWCs/edit#

Changed in photos-scope:
status: Confirmed → Fix Committed
tags: added: ota13
Changed in nearby-scope:
assignee: Kyle Nitzsche (knitzsche) → Penk Chen (penk)
Changed in news-scope:
assignee: Kyle Nitzsche (knitzsche) → Penk Chen (penk)
Changed in photos-scope:
assignee: Kyle Nitzsche (knitzsche) → Penk Chen (penk)
Changed in today-scope:
assignee: Kyle Nitzsche (knitzsche) → Penk Chen (penk)
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

Hi Penk,

This bug now contains the 4.9.0 clicks for the four euro agg scopes to fix this bug for QA and release in ota 13. (They are not in clicks branch since I believe it is frozen for ota 12 release.)

Thanks!

Revision history for this message
Ethan Chang (ethan.chang) wrote :

Verified these 4 scopes on turbo.

tags: added: cqa-verified
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

Penk, I believe these four aggregator scopes were all released at high enough versions to fix this in ota13. Thus I will change to fix-reeased.

clicks branch ota13:
$ bzr ls -r tag:ota13 | grep dashboard_
com.canonical.scopes.dashboard_4.11.1_armhf.click
$ bzr ls -r tag:ota13 | grep nearby_
com.canonical.unity-scope-nearby_4.9.1_armhf.click
$ bzr ls -r tag:ota13 | grep "\.news_"
com.canonical.scopes.news_4.9.0_armhf.click
$ bzr ls -r tag:ota13 | grep "\.photos_"
com.canonical.scopes.photos_4.11.0_armhf.click

Changed in nearby-scope:
status: Fix Committed → Fix Released
Changed in news-scope:
status: Fix Committed → Fix Released
Changed in photos-scope:
status: Fix Committed → Fix Released
Changed in today-scope:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers