"_disable_ipv6_addressing_on_interface" can't find the interface

Bug #1948832 reported by Rodolfo Alonso
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Fix Released
High
Slawek Kaplonski
tags: added: gate-failure ipv6 l3-dvr-backlog
Changed in neutron:
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Rodolfo Alonso (rodolfo-alonso-hernandez) wrote :

Hello:

The problem reported in this bug was solved in https://review.opendev.org/c/openstack/neutron/+/776427 but then reverted. If you want to push it again, this is up to whoever takes this bug. The keepalived process will delete and create the interface; during this time the L3 agent can't find it in the namespace. This is why we have those errors.

Regards.

Revision history for this message
Slawek Kaplonski (slaweq) wrote :

Hi Rodolfo,

I took a look at the bug which You pointed to and on the failures mentioned in this bug and I don't think it's the same issue. Your patch https://review.opendev.org/c/openstack/neutron/+/776427 was solving some specific issue with set_link_status() method. And in failures mentioned here, it failed in some totally different places in the code.
The only common thing is that the interface wasn't exist but I don't think that Your old patch would really solve that issue mentioned here.
So I will investigate those failures a bit more in the next days, maybe I will find something in the logs there.

Changed in neutron:
assignee: nobody → Slawek Kaplonski (slaweq)
Revision history for this message
Slawek Kaplonski (slaweq) wrote :

I analyzed failed test https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_eff/815280/2/check/neutron-functional-with-uwsgi/eff69a3/testr_results.html

In ovs-vswitchd log it can be found that sg-35fc6bda-40 was added/deleted few times:

2021-10-26T00:38:06.712Z|04062|bridge|INFO|bridge test-br535bb775: added interface sg-35fc6bda-40 on port 6
...
2021-10-26T00:38:07.453Z|04078|bridge|INFO|bridge test-br535bb775: deleted interface sg-35fc6bda-40 on port 6
...
2021-10-26T00:38:07.460Z|04079|bridge|INFO|bridge test-br535bb775: added interface sg-35fc6bda-40 on port 6
...
2021-10-26T00:38:18.612Z|04183|bridge|INFO|bridge test-br535bb775: deleted interface sg-35fc6bda-40 on port 6

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (master)

Fix proposed to branch: master
Review: https://review.opendev.org/c/openstack/neutron/+/817728

Changed in neutron:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (master)

Reviewed: https://review.opendev.org/c/openstack/neutron/+/817728
Committed: https://opendev.org/openstack/neutron/commit/ebc4766990c9f7021f60240de00370bd81bfa1e6
Submitter: "Zuul (22348)"
Branch: master

commit ebc4766990c9f7021f60240de00370bd81bfa1e6
Author: Rodolfo Alonso Hernandez <email address hidden>
Date: Fri Nov 12 10:32:25 2021 +0000

    Check interface presence in new namespace

    When an interface is moved to a new namespace, specially with OVS
    internal ports, the interface first dissapears from any network
    namespace and then is added again. ovs-vswitchd service detects
    this interface change as reported in [1]. This delay is the cause
    of the related bug, where some interfaces are not present when
    the L3 agent needs to manipulate them.

    [1]https://bugs.launchpad.net/neutron/+bug/1948832/comments/3

    Closes-Bug: #1948832
    Change-Id: I3af4d0afa784899689ccb595ce6ba64495431eb9

Changed in neutron:
status: In Progress → Fix Released
tags: added: neutron-proactive-backport-potential
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (stable/xena)

Fix proposed to branch: stable/xena
Review: https://review.opendev.org/c/openstack/neutron/+/818340

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (stable/wallaby)

Fix proposed to branch: stable/wallaby
Review: https://review.opendev.org/c/openstack/neutron/+/818341

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (stable/victoria)

Fix proposed to branch: stable/victoria
Review: https://review.opendev.org/c/openstack/neutron/+/818342

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (stable/ussuri)

Fix proposed to branch: stable/ussuri
Review: https://review.opendev.org/c/openstack/neutron/+/818343

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (stable/train)

Fix proposed to branch: stable/train
Review: https://review.opendev.org/c/openstack/neutron/+/818344

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (stable/victoria)

Reviewed: https://review.opendev.org/c/openstack/neutron/+/818342
Committed: https://opendev.org/openstack/neutron/commit/0d09c9b7c641e7d49369f53c5a0e020adee22ea9
Submitter: "Zuul (22348)"
Branch: stable/victoria

commit 0d09c9b7c641e7d49369f53c5a0e020adee22ea9
Author: Rodolfo Alonso Hernandez <email address hidden>
Date: Fri Nov 12 10:32:25 2021 +0000

    Check interface presence in new namespace

    When an interface is moved to a new namespace, specially with OVS
    internal ports, the interface first dissapears from any network
    namespace and then is added again. ovs-vswitchd service detects
    this interface change as reported in [1]. This delay is the cause
    of the related bug, where some interfaces are not present when
    the L3 agent needs to manipulate them.

    [1]https://bugs.launchpad.net/neutron/+bug/1948832/comments/3

    Conflicts:
        neutron/tests/functional/agent/linux/test_ip_lib.py

    Closes-Bug: #1948832

    Change-Id: I3af4d0afa784899689ccb595ce6ba64495431eb9
    (cherry picked from commit ebc4766990c9f7021f60240de00370bd81bfa1e6)
    (cherry picked from commit 9c41365041c581c6c742f9a33a470c2b6c33090d)

tags: added: in-stable-victoria
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (stable/ussuri)

Reviewed: https://review.opendev.org/c/openstack/neutron/+/818343
Committed: https://opendev.org/openstack/neutron/commit/9417defcdf97d06caece469b636f79a0f5f5a084
Submitter: "Zuul (22348)"
Branch: stable/ussuri

commit 9417defcdf97d06caece469b636f79a0f5f5a084
Author: Rodolfo Alonso Hernandez <email address hidden>
Date: Fri Nov 12 10:32:25 2021 +0000

    Check interface presence in new namespace

    When an interface is moved to a new namespace, specially with OVS
    internal ports, the interface first dissapears from any network
    namespace and then is added again. ovs-vswitchd service detects
    this interface change as reported in [1]. This delay is the cause
    of the related bug, where some interfaces are not present when
    the L3 agent needs to manipulate them.

    [1]https://bugs.launchpad.net/neutron/+bug/1948832/comments/3

    Conflicts:
        neutron/tests/functional/agent/linux/test_ip_lib.py

    Closes-Bug: #1948832

    Change-Id: I3af4d0afa784899689ccb595ce6ba64495431eb9
    (cherry picked from commit ebc4766990c9f7021f60240de00370bd81bfa1e6)
    (cherry picked from commit 9c41365041c581c6c742f9a33a470c2b6c33090d)

tags: added: in-stable-ussuri
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (stable/xena)

Reviewed: https://review.opendev.org/c/openstack/neutron/+/818340
Committed: https://opendev.org/openstack/neutron/commit/f5858cd621019eeafc4f8353ed283c0dcbc1bc06
Submitter: "Zuul (22348)"
Branch: stable/xena

commit f5858cd621019eeafc4f8353ed283c0dcbc1bc06
Author: Rodolfo Alonso Hernandez <email address hidden>
Date: Fri Nov 12 10:32:25 2021 +0000

    Check interface presence in new namespace

    When an interface is moved to a new namespace, specially with OVS
    internal ports, the interface first dissapears from any network
    namespace and then is added again. ovs-vswitchd service detects
    this interface change as reported in [1]. This delay is the cause
    of the related bug, where some interfaces are not present when
    the L3 agent needs to manipulate them.

    [1]https://bugs.launchpad.net/neutron/+bug/1948832/comments/3

    Closes-Bug: #1948832
    Change-Id: I3af4d0afa784899689ccb595ce6ba64495431eb9
    (cherry picked from commit ebc4766990c9f7021f60240de00370bd81bfa1e6)

tags: added: in-stable-xena
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (stable/wallaby)

Reviewed: https://review.opendev.org/c/openstack/neutron/+/818341
Committed: https://opendev.org/openstack/neutron/commit/9c41365041c581c6c742f9a33a470c2b6c33090d
Submitter: "Zuul (22348)"
Branch: stable/wallaby

commit 9c41365041c581c6c742f9a33a470c2b6c33090d
Author: Rodolfo Alonso Hernandez <email address hidden>
Date: Fri Nov 12 10:32:25 2021 +0000

    Check interface presence in new namespace

    When an interface is moved to a new namespace, specially with OVS
    internal ports, the interface first dissapears from any network
    namespace and then is added again. ovs-vswitchd service detects
    this interface change as reported in [1]. This delay is the cause
    of the related bug, where some interfaces are not present when
    the L3 agent needs to manipulate them.

    [1]https://bugs.launchpad.net/neutron/+bug/1948832/comments/3

    Conflicts:
        neutron/tests/functional/agent/linux/test_ip_lib.py

    Closes-Bug: #1948832

    Change-Id: I3af4d0afa784899689ccb595ce6ba64495431eb9
    (cherry picked from commit ebc4766990c9f7021f60240de00370bd81bfa1e6)

tags: added: in-stable-wallaby
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (stable/train)

Reviewed: https://review.opendev.org/c/openstack/neutron/+/818344
Committed: https://opendev.org/openstack/neutron/commit/d14ee014ff8dd40ba785998502fb8c3761e125c6
Submitter: "Zuul (22348)"
Branch: stable/train

commit d14ee014ff8dd40ba785998502fb8c3761e125c6
Author: Rodolfo Alonso Hernandez <email address hidden>
Date: Fri Nov 12 10:32:25 2021 +0000

    Check interface presence in new namespace

    When an interface is moved to a new namespace, specially with OVS
    internal ports, the interface first dissapears from any network
    namespace and then is added again. ovs-vswitchd service detects
    this interface change as reported in [1]. This delay is the cause
    of the related bug, where some interfaces are not present when
    the L3 agent needs to manipulate them.

    [1]https://bugs.launchpad.net/neutron/+bug/1948832/comments/3

    Conflicts:
        neutron/tests/functional/agent/linux/test_ip_lib.py

    Closes-Bug: #1948832

    Change-Id: I3af4d0afa784899689ccb595ce6ba64495431eb9
    (cherry picked from commit ebc4766990c9f7021f60240de00370bd81bfa1e6)
    (cherry picked from commit 9c41365041c581c6c742f9a33a470c2b6c33090d)

tags: added: in-stable-train
tags: removed: neutron-proactive-backport-potential
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/neutron 19.1.0

This issue was fixed in the openstack/neutron 19.1.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/neutron 17.3.0

This issue was fixed in the openstack/neutron 17.3.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/neutron 18.2.0

This issue was fixed in the openstack/neutron 18.2.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/neutron 20.0.0.0rc1

This issue was fixed in the openstack/neutron 20.0.0.0rc1 release candidate.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers