[stable/rocky] grenade job is broken

Bug #1925451 reported by Slawek Kaplonski
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Critical
Bernard Cafarelli

Bug Description

I just saw in the neutron-grenade job in stable/rocky branch error like:

2021-04-22 08:11:54.188 | Complete output from command python setup.py egg_info:
2021-04-22 08:11:54.188 | Couldn't find index page for 'pbr' (maybe misspelled?)
2021-04-22 08:11:54.188 | No local packages or download links found for pbr>=1.8
2021-04-22 08:11:54.188 | Traceback (most recent call last):
2021-04-22 08:11:54.188 | File "<string>", line 1, in <module>
2021-04-22 08:11:54.188 | File "/tmp/pip-build-9jeigq7n/devstack-tools/setup.py", line 29, in <module>
2021-04-22 08:11:54.188 | pbr=True)
2021-04-22 08:11:54.188 | File "/usr/lib/python3.5/distutils/core.py", line 108, in setup
2021-04-22 08:11:54.188 | _setup_distribution = dist = klass(attrs)
2021-04-22 08:11:54.188 | File "/usr/lib/python3/dist-packages/setuptools/dist.py", line 269, in __init__
2021-04-22 08:11:54.188 | self.fetch_build_eggs(attrs['setup_requires'])
2021-04-22 08:11:54.188 | File "/usr/lib/python3/dist-packages/setuptools/dist.py", line 313, in fetch_build_eggs
2021-04-22 08:11:54.188 | replace_conflicting=True,
2021-04-22 08:11:54.188 | File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 826, in resolve
2021-04-22 08:11:54.188 | dist = best[req.key] = env.best_match(req, ws, installer)
2021-04-22 08:11:54.188 | File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 1092, in best_match
2021-04-22 08:11:54.188 | return self.obtain(req, installer)
2021-04-22 08:11:54.188 | File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 1104, in obtain
2021-04-22 08:11:54.188 | return installer(requirement)
2021-04-22 08:11:54.188 | File "/usr/lib/python3/dist-packages/setuptools/dist.py", line 380, in fetch_build_egg
2021-04-22 08:11:54.188 | return cmd.easy_install(req)
2021-04-22 08:11:54.188 | File "/usr/lib/python3/dist-packages/setuptools/command/easy_install.py", line 657, in easy_install
2021-04-22 08:11:54.188 | raise DistutilsError(msg)
2021-04-22 08:11:54.188 | distutils.errors.DistutilsError: Could not find suitable distribution for Requirement.parse('pbr>=1.8')

Failure in https://447f476af5555fa473a2-ba0bbef8fa5bd9d33ddbd8694210833c.ssl.cf5.rackcdn.com/777123/4/check/neutron-grenade/e900d19/logs/grenade.sh.txt

Changed in neutron:
status: Confirmed → New
Revision history for this message
Bernard Cafarelli (bcafarel) wrote :
Revision history for this message
Bernard Cafarelli (bcafarel) wrote :

Checking these 4 failures, fist 2 were run on inap-mtl01 provider, 3rd on rax, 4th on ovh-gra1 so it does not seem to be linked to a specific cloud provider

Revision history for this message
Bernard Cafarelli (bcafarel) wrote :

rocky CI has been fine for some weeks, so I think we can consider this issue has disappeared

Changed in neutron:
status: New → Fix Released
assignee: nobody → Bernard Cafarelli (bcafarel)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers