tempest-slow-py3 ipv6 gate job fails on stable/stein

Bug #1916041 reported by Bernard Cafarelli on 2021-02-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Critical
Slawek Kaplonski

Bug Description

tempest-slow-py3 recently started to fail (100% from backports I checked) on 8 IPv6 tests, for example https://review.opendev.org/c/openstack/neutron/+/775102 and https://review.opendev.org/c/openstack/neutron/+/774258 :
tempest.scenario.test_network_v6.TestGettingAddress
test_dhcp6_stateless_from_os[compute,id-d7e1f858-187c-45a6-89c9-bdafde619a9f,network,slow]
test_dualnet_dhcp6_stateless_from_os[compute,id-76f26acd-9688-42b4-bc3e-cd134c4cb09e,network,slow]
test_dualnet_multi_prefix_dhcpv6_stateless[compute,id-cf1c4425-766b-45b8-be35-e2959728eb00,network,slow]
test_dualnet_multi_prefix_slaac[compute,id-9178ad42-10e4-47e9-8987-e02b170cc5cd,network,slow]
test_dualnet_slaac_from_os[compute,id-b6399d76-4438-4658-bcf5-0d6c8584fde2,network,slow]
test_multi_prefix_dhcpv6_stateless[compute,id-7ab23f41-833b-4a16-a7c9-5b42fe6d4123,network,slow]
test_multi_prefix_slaac[compute,id-dec222b1-180c-4098-b8c5-cc1b8342d611,network,slow]
test_slaac_from_os[compute,id-2c92df61-29f0-4eaa-bee3-7c65bef62a43,network,slow]

Typical error message:
tempest.lib.exceptions.BadRequest: Bad request
Details: {'type': 'BadRequest', 'message': 'Bad router request: Cidr 2001:db8::/64 of subnet b7a37aa7-22c6-4eed-b4de-98587b434556 overlaps with cidr 2001:db8::/64 of subnet d6a91c9f-c268-4724-b2aa-ac5187d167da.', 'detail': ''}

(grabbed from https://storage.gra.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_b92/77 5102/1/check/tempest-slow-py3/b924f4d/testr_results.html sample failure)

Bernard Cafarelli (bcafarel) wrote :

It looks like a fallout of https://bugs.launchpad.net/neutron/+bug/1915692 and devstack fix https://review.opendev.org/c/openstack/devstack/+/774103

In https://review.opendev.org/c/openstack/neutron/+/775102 the job passed before tempest was pinned to older version (when the neutron-tempest-plugin* jobs were failing)), and failed in next recheck with other jobs fixed

This may be caused by missing https://review.opendev.org/c/openstack/tempest/+/774764 as https://review.opendev.org/c/openstack/neutron/+/770034 is in stein?

Changed in neutron:
status: New → Confirmed
importance: Undecided → Critical
tags: added: ipv6
Changed in neutron:
assignee: nobody → Slawek Kaplonski (slaweq)
Bernard Cafarelli (bcafarel) wrote :
Bernard Cafarelli (bcafarel) wrote :

devstack-gate change did not seem to help

Slawek Kaplonski (slaweq) wrote :

Fix https://review.opendev.org/c/openstack/neutron/+/777389 merged. This bug should be solved now.

Changed in neutron:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers