OVN based scenario jobs failing 100% of times

Bug #1898863 reported by Slawek Kaplonski on 2020-10-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Critical
Slawek Kaplonski

Bug Description

Job like neutron-ovn-tempest-slow and neutron-ovn-tempest-full-multinode-ovs-master are failing on spawning devstack with error like:

Oct 06 19:17:08 ubuntu-focal-ovh-gra1-0020322316 dstat.sh[84041]: File "/usr/bin/dstat", line 519, in show
Oct 06 19:17:08 ubuntu-focal-ovh-gra1-0020322316 dstat.sh[84041]: line = line + cprintlist(self.val[name], ctype, self.width, scale)
Oct 06 19:17:08 ubuntu-focal-ovh-gra1-0020322316 dstat.sh[84041]: File "/usr/bin/dstat", line 2087, in cprintlist
Oct 06 19:17:08 ubuntu-focal-ovh-gra1-0020322316 dstat.sh[84041]: ret = ret + sep + cprint(var, ctype, width, scale)
Oct 06 19:17:08 ubuntu-focal-ovh-gra1-0020322316 dstat.sh[84041]: File "/usr/bin/dstat", line 2137, in cprint
Oct 06 19:17:08 ubuntu-focal-ovh-gra1-0020322316 dstat.sh[84041]: ret, c = dchg(var, width, base)
Oct 06 19:17:08 ubuntu-focal-ovh-gra1-0020322316 dstat.sh[84041]: File "/usr/bin/dstat", line 2037, in dchg
Oct 06 19:17:08 ubuntu-focal-ovh-gra1-0020322316 dstat.sh[84041]: ret = str(int(round(var)))
Oct 06 19:17:08 ubuntu-focal-ovh-gra1-0020322316 dstat.sh[84041]: OverflowError: cannot convert float infinity to integer
Oct 06 19:17:08 ubuntu-focal-ovh-gra1-0020322316 systemd[1]: <email address hidden>: Succeeded.

I don't see same errors on other jobs in neutron.

Slawek Kaplonski (slaweq) wrote :

Seems that it may be related to dstat issue https://bugs.launchpad.net/ubuntu/+source/dstat/+bug/1866619

Fix proposed to branch: master
Review: https://review.opendev.org/758116

Changed in neutron:
assignee: nobody → Slawek Kaplonski (slaweq)
status: Confirmed → In Progress

Reviewed: https://review.opendev.org/758116
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=9d38c069809cffb35e4236e41b9442514e9f42c5
Submitter: Zuul
Branch: master

commit 9d38c069809cffb35e4236e41b9442514e9f42c5
Author: Slawek Kaplonski <email address hidden>
Date: Wed Oct 14 15:16:30 2020 +0200

    Disable dstat service temporary in ovn scenario jobs

    Multinode OVN jobs are failing very often due to bug [1] so
    lets disable dstat service in those jobs for now as workaround
    of the problem.

    [1] https://bugs.launchpad.net/ubuntu/+source/dstat/+bug/1866619

    Change-Id: Id9bb16d9e3e649e1538bc33bd1b7e8eab7e74048
    Closes-Bug: #1898863

Changed in neutron:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers