[RFE] Neutron ports dns_assignment does not match the designate DNS records for Neutron port

Bug #1873091 reported by hamza on 2020-04-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Wishlist
hamza

Bug Description

the Neutron port dns_assignment dont match the designate DNS records assigned to the Neutron port

as explained in the link below
https://docs.openstack.org/neutron/pike/admin/config-dns-int.html

when a user creates a neutron port using the command below
neutron port-create 37aaff3a-6047-45ac-bf4f-a825e56fd2b3 \
  --dns-name my-vm --dns_domain port-domain.org.

The actual output for dns_assignment is:
{"hostname": "my-vm", "ip_address": "203.0.113.9", "fqdn": "my-vm.example.org."}
{"hostname": "my-vm", "ip_address": "2001:db8:10::9", "fqdn": "my-vm.example.org."}

and the Designate DNS records is
67a8e83d-7e3c-4fb1-9261-0481318bb7b5 | A | my-vm.port-domain.org. | 203.0.113.9
5a4f671c-9969-47aa-82e1-e05754021852 | AAAA | my-vm.port-domain.org. | 2001:db8:10::9

while the expected output for dns-assignment:
{"hostname": "my-vm", "ip_address": "203.0.113.9", "fqdn": "my-vm.port-domain.org."}
{"hostname": "my-vm", "ip_address": "2001:db8:10::9", "fqdn": "my-vm.port-domain.org."}

most likely right now the dns_domain is taken from the Neutron network dns_domain or from neutron dns_domain configuration

A good approach would be to always make the dns_assignment for Neutron port synced with the Designate DNS records if Designate is used

Slawek Kaplonski (slaweq) wrote :

I remember we had similar discussions about it in the past. Please check https://bugs.launchpad.net/neutron/+bug/1826419 and discussion at L3 meeting http://eavesdrop.openstack.org/meetings/neutron_l3/2019/neutron_l3.2019-05-29-14.00.log.html for more details.
Basically it works as expected so I'm going to close this RFE as Won't fix for now.

Changed in neutron:
status: New → Won't Fix
Miguel Lavalle (minsel) wrote :

Whereas we have discussed this in the past and we agreed to comply with the spec for internal dns resolution (https://specs.openstack.org/openstack/neutron-specs/specs/liberty/internal-dns-resolution.html) as recorded here http://eavesdrop.openstack.org/meetings/neutron_l3/2019/neutron_l3.2019-05-29-14.00.log.html#l-42, I think more use cases have surfaced recently that warrant a reevaluation of this decision and of the original spec. Just last week, I was talking to hjensas in the Neutron channel, and he was describing a very similar need (if not the same): "in our case we have multiple ports for each instance, and instead of $server-name.$netname.example.com. they all get £server-name.example.com. now. Which is confusing. Since $netname.example.com. is in the dns_domain of the network ..." (http://eavesdrop.openstack.org/irclogs/%23openstack-neutron/%23openstack-neutron.2020-04-17.log.html#t2020-04-17T14:54:11).

I think it is time to explore a way to satisfy these new use cases while providing backwards compatibility with the original spec mentioned above.

Changed in neutron:
status: Won't Fix → Triaged
importance: Undecided → Wishlist
summary: - Neutron ports dns_assignment does not match the designate DNS records
- for Neutron port
+ [RFE] Neutron ports dns_assignment does not match the designate DNS
+ records for Neutron port
tags: added: rfe-triaged
removed: rfe
Slawek Kaplonski (slaweq) wrote :

We discussed that RFE on our last drivers meeting http://eavesdrop.openstack.org/meetings/neutron_drivers/2020/neutron_drivers.2020-05-08-14.00.log.html#l-55

We decided to approve this RFE as there are valid usecases and need to clean a bit mess with this dns integration.

As a next step we will need spec with detailed description of current situation (like what dns_domain options are used for what :)) so we can develop some good solution which will work for new use cases and will be somehow backward compatible.

tags: added: rfe-approved
removed: rfe-triaged
Changed in neutron:
status: Triaged → Confirmed
hamza (alqtaishat) wrote :

i added the following spec describing the current situation
https://review.opendev.org/#/c/726904/

Fix proposed to branch: master
Review: https://review.opendev.org/731624

Changed in neutron:
assignee: nobody → hamza (alqtaishat)
status: Confirmed → In Progress
Changed in neutron:
milestone: none → victoria-2

Reviewed: https://review.opendev.org/731624
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=ea13f2e83f8c2de3def69b6c883a5c161c3a6180
Submitter: Zuul
Branch: master

commit ea13f2e83f8c2de3def69b6c883a5c161c3a6180
Author: hamalq <email address hidden>
Date: Thu May 28 23:17:28 2020 +0000

    Sync the dns-assignment with the actual designate dns-domain

    When a port is created the dns-assignment (dns-domain part)
    was always taken form Neutron config dns_domain which is not
    always true, since it could be Neutron network dns_domain or
    the dns_domain sent when creating the port

    Change-Id: I7f4366ff5a26f73013433bfbfb299fd06294f359
    Closes-Bug:1873091

Changed in neutron:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers