designate not creating recordsets

Bug #1849690 reported by Victor Santos on 2019-10-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Undecided
Unassigned

Bug Description

Hi
I installed designate and Neutron on Stein openstack in Centos 7. Each one in a different server.

It's possible to create domain and records as well all commands related domain as 'openstack dns service list' and 'openstack zone list and openstack recordset list xxx' are ok.

Also all commands related with network is working.

I have create the network with the option --dns-domain and tried to create ports with the option --dns-name

The same when create the vms on dashboard or cli.

No recordset is created. I don't see any call to port 9001 in api log. It seems that designate plugin is not called...

The configurations to Neutron use Designate:

/etc/neutron/neutron.conf
[DEFAULT]
external_dns_driver = designate

[designate]
url = http://1.1.1.1:9001/v2
auth_type = password
auth_url = http://1.1.1.1:5000
username = designate
password = password
project_name = service
project_domain_name = Default
user_domain_name = Default
allow_reverse_dns_lookup = True
ipv4_ptr_zone_prefix_size = 24
ipv6_ptr_zone_prefix_size = 116
ptr_zone_email = <email address hidden>
insecure = true

/etc/neutron/plugins/ml2/ml2_conf.ini
[ml2]
extension_drivers = port_security,dns

Tags: dns Edit Tag help
summary: - designade
+ designate not creating recordsets
tags: added: dns
Dr. Jens Harbott (j-harbott) wrote :

Publishing DNS records for ports only happens under certain conditions, please have a look at https://docs.openstack.org/neutron/latest/admin/config-dns-int-ext-serv.html#configuration-of-the-externally-accessible-network-for-use-case-3 and verify that your setup meets these conditions.

There is also an extension being worked on that will allow users to override these conditions, see https://launchpad.net/bugs/1784879 for that.

Changed in neutron:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for neutron because there has been no activity for 60 days.]

Changed in neutron:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers