test_server_connectivity_cold_migration_revert failing

Bug #1836595 reported by Artom Lifshitz on 2019-07-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Medium
Unassigned

Bug Description

test_server_connectivity_cold_migration_revert has started failing now that we've un-skipped it [1]. It appears as though Nova is doing everything right in terms of external events and VIF plugging (see analysis on PS6 of [2]), so the thinking is that it's something with the Neutron L3 agent. Sean Mooney's noticed that the guest does get an IP from DHCP, but then we fail to ping the VM from tempest.

Logstash query: http://logstash.openstack.org/#/dashboard/file/logstash.json?query=message:%5C%22tempest.scenario.test_network_advanced_server_ops.TestNetworkAdvancedServerOps.test_server_connectivity_cold_migration_revert%5C%22%20AND%20message:%5C%22FAILED%5C%22%20AND%20tags:%5C%22job-output.txt%5C%22

[1] https://review.opendev.org/#/c/663405/
[2] https://review.opendev.org/#/c/668631/6

Artom Lifshitz (notartom) wrote :

This bug is filed under Neutron, but that's more of a placeholder based on preliminary guessing. We can easily change it to Nova or some other component once we understand better what's going on.

Hongbin Lu (hongbin.lu) on 2019-07-17
Changed in neutron:
status: New → Confirmed
tags: added: gate-failure
Changed in neutron:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers