installed neutron, but no provider network exists

Bug #1824788 reported by Realtime on 2019-04-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Low
Gabriele Cerami

Bug Description

I installed neutron (Rocky) in Ubuntu exactly following the documentation
https://docs.openstack.org/neutron/rocky/install/controller-install-ubuntu.html

I ended up with having no provider network.

Are there addional steps required to add a provider network? If so, why is the documentation keeping this fact secret?

This bug tracker is for errors with the documentation, use the following as a template and remove or add fields as you see fit. Convert [ ] into [x] to check boxes:

- [x] This doc is inaccurate in this way: Ending up with no provider network
- [x] This is a doc addition request.
- [ ] I have a fix to the document that I can paste below including example: input and output.

If you have a troubleshooting or support issue, use the following resources:

 - Ask OpenStack: http://ask.openstack.org
 - The mailing list: http://lists.openstack.org
 - IRC: 'openstack' channel on Freenode

-----------------------------------
Release: 13.0.3.dev125 on 2019-04-12 05:13
SHA: 65bee80deb976b7be02091239255390dd2af5a5e
Source: https://git.openstack.org/cgit/openstack/neutron/tree/doc/source/install/controller-install-ubuntu.rst
URL: https://docs.openstack.org/neutron/rocky/install/controller-install-ubuntu.html

Hongbin Lu (hongbin.lu) wrote :

Hi @Realtime,

It seems the document below is what you need:

https://docs.openstack.org/install-guide/launch-instance-networks-provider.html

I am going to proceed to close this bug but please feel free to re-open it if it still has problems.

Changed in neutron:
status: New → Invalid
Realtime (peter-icb) wrote :

Where is this link? I double checked the guide and still cannot find it!

https://docs.openstack.org/neutron/rocky/install/controller-install-ubuntu.html

This is not an Openstack-Bug, this is a Documentation-Bug! Probably I opened this bug in the wrong place. Where are Bugs in the documentation to be reported?

Slawek Kaplonski (slaweq) wrote :

Hmm, from quick look it indeed looks that link to https://docs.openstack.org/install-guide/launch-instance-networks-provider.html may be missing in docs' menu. Maybe that should be checked and fixed.

Changed in neutron:
status: Invalid → Confirmed
importance: Undecided → Low
tags: added: low-hanging-fruit
Changed in neutron:
assignee: nobody → Gabriele Cerami (gcerami)
Gabriele Cerami (gcerami) wrote :

The document that guides in the creation of the provider network is external to neutron. It's linked from this other document

https://docs.openstack.org/install-guide/launch-instance.html#launch-instance-networks

And it's intended to be followed right before launching an instance.
Note that the documentation there is not branched.

I think it makes sense to link it also at the end of all option 1 documents.

Changed in neutron:
status: Confirmed → In Progress

Reviewed: https://review.opendev.org/656062
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=2b9655a78474a8cbec862c086bece4b074ade696
Submitter: Zuul
Branch: master

commit 2b9655a78474a8cbec862c086bece4b074ade696
Author: Gabriele Cerami <email address hidden>
Date: Sat Apr 27 16:32:48 2019 +0100

    Install doc: append provider network creation link

    Creating the provider network is a necessary step for option 1. The step
    is only described in a document in the general installation guide.
    This patch links this document at the end of every option1 controller
    installation document

    Change-Id: I33713aec50e0646a3b42b9d202ac730d3a0578a5
    Close-Bug: #1824788

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers