Neutron-keepalived-state-change fails to check initial router state

Bug #1823038 reported by Slawek Kaplonski on 2019-04-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Status tracked in Stein
Pike
High
Unassigned
Queens
High
Unassigned
Rocky
High
Unassigned
Stein
High
Unassigned
neutron
High
Rodolfo Alonso
neutron (Ubuntu)
High
Unassigned
Bionic
High
Unassigned
Cosmic
High
Unassigned
Disco
High
Unassigned

Bug Description

[Impact]
Fix for bug 1818614 in *-proposed includes a regression is the deployment is not using the rootwrap-daemon.

[Test Case]
See bug 1818614

[Regression Potential]
Low - this is a minor fix to resolve a regression due to the SRU bug 1818614.

[Original Description]

As fix for bug https://bugs.launchpad.net/neutron/+bug/1818614 we added to neutron-keepalived-state-change monitor possibility to check initial status of router (master or slave).

Unfortunately for some reason I see now in journal log of functional job that this check is failing with error like:

Apr 03 09:19:09 ubuntu-bionic-ovh-gra1-0004666718 neutron-keepalived-state-change[1553]: 2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change [-] Failed to get initial status of router cd300e6b-8222-4100-8f6a-3b5c4d5fe37b: FailedToDropPrivileges: privsep helper command exited non-zero (96)
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change Traceback (most recent call last):
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change File "/home/zuul/src/git.openstack.org/openstack/neutron/neutron/agent/l3/keepalived_state_change.py", line 98, in handle_initial_state
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change for address in ip.addr.list():
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change File "/home/zuul/src/git.openstack.org/openstack/neutron/neutron/agent/linux/ip_lib.py", line 540, in list
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change **kwargs)
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change File "/home/zuul/src/git.openstack.org/openstack/neutron/neutron/agent/linux/ip_lib.py", line 1412, in get_devices_with_ip
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change devices = privileged.get_link_devices(namespace, **link_args)
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change File "/home/zuul/src/git.openstack.org/openstack/neutron/.tox/dsvm-functional-python27/local/lib/python2.7/site-packages/oslo_privsep/priv_context.py", line 240, in _wrap
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change self.start()
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change File "/home/zuul/src/git.openstack.org/openstack/neutron/.tox/dsvm-functional-python27/local/lib/python2.7/site-packages/oslo_privsep/priv_context.py", line 251, in start
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change channel = daemon.RootwrapClientChannel(context=self)
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change File "/home/zuul/src/git.openstack.org/openstack/neutron/.tox/dsvm-functional-python27/local/lib/python2.7/site-packages/oslo_privsep/daemon.py", line 328, in __init__
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change raise FailedToDropPrivileges(msg)
                                                                                         2019-04-03 09:19:09.778 1553 ERROR neutron.agent.l3.keepalived_state_change FailedToDropPrivileges: privsep helper command exited non-zero (96)

Example of such error: http://logs.openstack.org/25/645225/8/check/neutron-functional-python27/0704654/controller/logs/journal_log.txt.gz#_Apr_03_09_19_09

Changed in neutron:
importance: Undecided → High

Reviewed: https://review.openstack.org/649991
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=afbbec83a2578aac6aa0f16c205c5da3a788969b
Submitter: Zuul
Branch: master

commit afbbec83a2578aac6aa0f16c205c5da3a788969b
Author: Edward Hope-Morley <email address hidden>
Date: Thu Apr 4 14:22:54 2019 +0100

    Don't pass None arg to neutron-keepalived-state-change

    The original fix for bug 1818614 added two new cli args
    when spawning neutron-keepalived-state-change but if
    e.g. self.agent_conf.AGENT.root_helper_daemon is unset
    then "None" string is passed which breaks the
    neutron-keepalived-state-change daemon.

    Change-Id: I4afcdbbf2f3d2dafcad241ba3fc0778b52b8fc85
    Related-Bug: #1818614
    Related-Bug: #1823038

Reviewed: https://review.openstack.org/650576
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=21387750a9f424ef3275c2076f2152749dc5bb87
Submitter: Zuul
Branch: stable/queens

commit 21387750a9f424ef3275c2076f2152749dc5bb87
Author: Edward Hope-Morley <email address hidden>
Date: Thu Apr 4 14:22:54 2019 +0100

    Don't pass None arg to neutron-keepalived-state-change

    The original fix for bug 1818614 added two new cli args
    when spawning neutron-keepalived-state-change but if
    e.g. self.agent_conf.AGENT.root_helper_daemon is unset
    then "None" string is passed which breaks the
    neutron-keepalived-state-change daemon.

    Change-Id: I4afcdbbf2f3d2dafcad241ba3fc0778b52b8fc85
    Related-Bug: #1818614
    Related-Bug: #1823038
    (cherry picked from commit afbbec83a2578aac6aa0f16c205c5da3a788969b)
    (cherry picked from commit a7df1c458c1fcfee03abfff7e2dd5994eca3f91e)
    (cherry picked from commit 279c99ab7d69e236afe7f6cbc91b7a0586a40edd)

tags: added: in-stable-queens

Reviewed: https://review.openstack.org/650574
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=a7df1c458c1fcfee03abfff7e2dd5994eca3f91e
Submitter: Zuul
Branch: stable/stein

commit a7df1c458c1fcfee03abfff7e2dd5994eca3f91e
Author: Edward Hope-Morley <email address hidden>
Date: Thu Apr 4 14:22:54 2019 +0100

    Don't pass None arg to neutron-keepalived-state-change

    The original fix for bug 1818614 added two new cli args
    when spawning neutron-keepalived-state-change but if
    e.g. self.agent_conf.AGENT.root_helper_daemon is unset
    then "None" string is passed which breaks the
    neutron-keepalived-state-change daemon.

    Change-Id: I4afcdbbf2f3d2dafcad241ba3fc0778b52b8fc85
    Related-Bug: #1818614
    Related-Bug: #1823038
    (cherry picked from commit afbbec83a2578aac6aa0f16c205c5da3a788969b)

tags: added: in-stable-stein

Reviewed: https://review.openstack.org/650575
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=279c99ab7d69e236afe7f6cbc91b7a0586a40edd
Submitter: Zuul
Branch: stable/rocky

commit 279c99ab7d69e236afe7f6cbc91b7a0586a40edd
Author: Edward Hope-Morley <email address hidden>
Date: Thu Apr 4 14:22:54 2019 +0100

    Don't pass None arg to neutron-keepalived-state-change

    The original fix for bug 1818614 added two new cli args
    when spawning neutron-keepalived-state-change but if
    e.g. self.agent_conf.AGENT.root_helper_daemon is unset
    then "None" string is passed which breaks the
    neutron-keepalived-state-change daemon.

    Change-Id: I4afcdbbf2f3d2dafcad241ba3fc0778b52b8fc85
    Related-Bug: #1818614
    Related-Bug: #1823038
    (cherry picked from commit afbbec83a2578aac6aa0f16c205c5da3a788969b)
    (cherry picked from commit a7df1c458c1fcfee03abfff7e2dd5994eca3f91e)

tags: added: in-stable-rocky
James Page (james-page) wrote :

Ubuntu SRU information

[Impact]
Fix for bug 1818614 in *-proposed includes a regression is the deployment is not using the rootwrap-daemon.

[Test Case]
See bug 1818614

[Regression Potential]
Low - this is a minor fix to resolve a regression due to the SRU bug 1818614.

Changed in cloud-archive:
status: New → Confirmed
Changed in neutron (Ubuntu):
status: New → Confirmed
Changed in neutron (Ubuntu Bionic):
status: New → Confirmed
Changed in neutron (Ubuntu Cosmic):
status: New → Confirmed
Changed in cloud-archive:
importance: Undecided → High
Changed in neutron (Ubuntu):
importance: Undecided → High
Changed in neutron (Ubuntu Bionic):
importance: Undecided → High
Changed in neutron (Ubuntu Cosmic):
importance: Undecided → High
James Page (james-page) wrote :

Uploads in UNAPPROVED queue for bionic and cosmic; disco is blocked as current neutron version pending promotion of approved MIR packages to main.

Reviewed: https://review.openstack.org/650596
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=36a1e193cb73f79ffdfafe91987839de4760b2de
Submitter: Zuul
Branch: stable/pike

commit 36a1e193cb73f79ffdfafe91987839de4760b2de
Author: Edward Hope-Morley <email address hidden>
Date: Thu Apr 4 14:22:54 2019 +0100

    Don't pass None arg to neutron-keepalived-state-change

    The original fix for bug 1818614 added two new cli args
    when spawning neutron-keepalived-state-change but if
    e.g. self.agent_conf.AGENT.root_helper_daemon is unset
    then "None" string is passed which breaks the
    neutron-keepalived-state-change daemon.

    Change-Id: I4afcdbbf2f3d2dafcad241ba3fc0778b52b8fc85
    Related-Bug: #1818614
    Related-Bug: #1823038
    (cherry picked from commit afbbec83a2578aac6aa0f16c205c5da3a788969b)

tags: added: in-stable-pike
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:14.0.0~rc1-0ubuntu3

---------------
neutron (2:14.0.0~rc1-0ubuntu3) disco; urgency=medium

  * d/p/bug1823038.patch: Cherry pick fix to ensure that None is not
    passed as an argument when spawning the neutron-keepalived-state-change
    agent (LP: #1823038).

 -- James Page <email address hidden> Tue, 09 Apr 2019 10:03:20 +0100

Changed in neutron (Ubuntu Disco):
status: Confirmed → Fix Released

Reviewed: https://review.openstack.org/650970
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=7047f0c29303ac32f23c520a514c4b11520c8a69
Submitter: Zuul
Branch: stable/ocata

commit 7047f0c29303ac32f23c520a514c4b11520c8a69
Author: Edward Hope-Morley <email address hidden>
Date: Thu Apr 4 14:22:54 2019 +0100

    Don't pass None arg to neutron-keepalived-state-change

    The original fix for bug 1818614 added two new cli args
    when spawning neutron-keepalived-state-change but if
    e.g. self.agent_conf.AGENT.root_helper_daemon is unset
    then "None" string is passed which breaks the
    neutron-keepalived-state-change daemon.

    Change-Id: I4afcdbbf2f3d2dafcad241ba3fc0778b52b8fc85
    Related-Bug: #1818614
    Related-Bug: #1823038
    (cherry picked from commit afbbec83a2578aac6aa0f16c205c5da3a788969b)
    (cherry picked from commit a7df1c458c1fcfee03abfff7e2dd5994eca3f91e)
    (cherry picked from commit 279c99ab7d69e236afe7f6cbc91b7a0586a40edd)
    (cherry picked from commit 21387750a9f424ef3275c2076f2152749dc5bb87)

tags: added: in-stable-ocata
Changed in cloud-archive:
status: Confirmed → Fix Committed
James Page (james-page) wrote :

This bug was fixed in the package neutron - 2:14.0.0~rc1-0ubuntu3~cloud0
---------------

 neutron (2:14.0.0~rc1-0ubuntu3~cloud0) bionic-stein; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 neutron (2:14.0.0~rc1-0ubuntu3) disco; urgency=medium
 .
   * d/p/bug1823038.patch: Cherry pick fix to ensure that None is not
     passed as an argument when spawning the neutron-keepalived-state-change
     agent (LP: #1823038).

Changed in cloud-archive:
status: Fix Committed → Fix Released

Hello Slawek, or anyone else affected,

Accepted neutron into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron/2:13.0.2-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

description: updated
Changed in neutron (Ubuntu Cosmic):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Edward Hope-Morley (hopem) wrote :

Verified cosmic-proposed using test from [TESTCASE]

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic
James Page (james-page) wrote :

Hello Slawek, or anyone else affected,

Accepted neutron into rocky-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:rocky-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-rocky-needed to verification-rocky-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-rocky-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-rocky-needed
James Page (james-page) wrote :

Hello Slawek, or anyone else affected,

Accepted neutron into pike-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:pike-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-pike-needed to verification-pike-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-pike-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-pike-needed
Łukasz Zemczak (sil2100) wrote :

Hello Slawek, or anyone else affected,

Accepted neutron into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron/2:12.0.5-0ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in neutron (Ubuntu Bionic):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-bionic
removed: verification-done
Corey Bryant (corey.bryant) wrote :

Hello Slawek, or anyone else affected,

Accepted neutron into queens-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:queens-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-queens-needed to verification-queens-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-queens-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-queens-needed

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:13.0.2-0ubuntu3.1

---------------
neutron (2:13.0.2-0ubuntu3.1) cosmic; urgency=medium

  * d/p/bug1823038.patch: Cherry pick fix to ensure that None is not
    passed as an argument when spawning the neutron-keepalived-state-change
    agent (LP: #1823038).

neutron (2:13.0.2-0ubuntu3) cosmic; urgency=medium

  * d/p/fix-KeyError-in-OVS-firewall.patch: Cherry-picked from upstream
    to prevent neutron ovs agent from crashing due to creation of two
    security groups that both use the same remote security group, where
    the first group's port range is a subset of the second (LP: #1813007).
  * d/p/set-initial-ha-router-state-in-neutron-keepalived-st.patch:
    Cherry-picked from upstream stable/rocky branch to ensure proper
    detection of MASTER HA router by neutron-keepalived-state-change
    (LP: #1818614).

 -- James Page <email address hidden> Tue, 09 Apr 2019 11:37:29 +0100

Changed in neutron (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Corey Bryant (corey.bryant) wrote :

Tagging as verification-rocky-done since https://bugs.launchpad.net/neutron/+bug/1818614 has been tagged as verification-rocky-done.

tags: added: verification-rocky-done
removed: verification-rocky-needed
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package neutron - 2:13.0.2-0ubuntu3.1~cloud0
---------------

 neutron (2:13.0.2-0ubuntu3.1~cloud0) bionic-rocky; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 neutron (2:13.0.2-0ubuntu3.1) cosmic; urgency=medium
 .
   * d/p/bug1823038.patch: Cherry pick fix to ensure that None is not
     passed as an argument when spawning the neutron-keepalived-state-change
     agent (LP: #1823038).

Corey Bryant (corey.bryant) wrote :

Tagging as verification-done-bionic since https://bugs.launchpad.net/neutron/+bug/1818614 has been tagged as verification-done-bionic.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Corey Bryant (corey.bryant) wrote :

Tagging as verification-queens-done since https://bugs.launchpad.net/neutron/+bug/1818614 has been tagged as verification-queens-done.

tags: added: verification-queens-done
removed: verification-queens-needed
Corey Bryant (corey.bryant) wrote :

Tagging as verification-pike-done since https://bugs.launchpad.net/neutron/+bug/1818614 has been tagged as verification-pike-done.

tags: added: verification-pike-done
removed: verification-pike-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:12.0.5-0ubuntu4

---------------
neutron (2:12.0.5-0ubuntu4) bionic; urgency=medium

  * d/p/bug1823038.patch: Cherry pick fix to ensure that None is not
    passed as an argument when spawning the neutron-keepalived-state-change
    agent (LP: #1823038).

neutron (2:12.0.5-0ubuntu3) bionic; urgency=medium

  * d/p/fix-KeyError-in-OVS-firewall.patch: Cherry-picked from upstream
    to prevent neutron ovs agent from crashing due to creation of two
    security groups that both use the same remote security group, where
    the first group's port range is a subset of the second (LP: #1813007).
  * d/p/set-initial-ha-router-state-in-neutron-keepalived-st.patch:
    Cherry-picked from upstream stable/rocky branch to ensure proper
    detection of MASTER HA router by neutron-keepalived-state-change
    (LP: #1818614).

 -- James Page <email address hidden> Tue, 09 Apr 2019 10:59:22 +0100

Changed in neutron (Ubuntu Bionic):
status: Fix Committed → Fix Released
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package neutron - 2:12.0.5-0ubuntu4~cloud0
---------------

 neutron (2:12.0.5-0ubuntu4~cloud0) xenial-queens; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 neutron (2:12.0.5-0ubuntu4) bionic; urgency=medium
 .
   * d/p/bug1823038.patch: Cherry pick fix to ensure that None is not
     passed as an argument when spawning the neutron-keepalived-state-change
     agent (LP: #1823038).

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package neutron - 2:11.0.6-0ubuntu1~cloud2.1
---------------

 neutron (2:11.0.6-0ubuntu1~cloud2.1) xenial; urgency=medium
 .
   * d/p/bug1823038.patch: Cherry pick fix to ensure that None is not
     passed as an argument when spawning the neutron-keepalived-state-change
     agent (LP: #1823038).
 .
 neutron (2:11.0.6-0ubuntu1~cloud2) xenial-pike; urgency=medium
 .
   * d/p/fix-KeyError-in-OVS-firewall.patch: Cherry-picked from upstream
     to prevent neutron ovs agent from crashing due to creation of two
     security groups that both use the same remote security group, where
     the first group's port range is a subset of the second (LP: #1813007).
   * d/p/set-initial-ha-router-state-in-neutron-keepalived-st.patch:
     Cherry-picked from upstream stable/rocky branch to ensure proper
     detection of MASTER HA router by neutron-keepalived-state-change
     (LP: #1818614).

Changed in neutron:
assignee: nobody → Rodolfo Alonso (rodolfo-alonso-hernandez)
status: Confirmed → In Progress

Reviewed: https://review.opendev.org/657849
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=aacd11ab9f8f24291f369d23662b0cb6b3fe43e3
Submitter: Zuul
Branch: master

commit aacd11ab9f8f24291f369d23662b0cb6b3fe43e3
Author: Rodolfo Alonso Hernandez <email address hidden>
Date: Fri May 10 10:58:08 2019 +0000

    Remove rootwrap configuration from neutron-keepalived-state-change

    New IP command introduced by Ie3fe825d65408fc969c478767b411fe0156e9fbc
    requires only privsep initialization. This patch removes the prisep
    error FailedToDropPrivileges when executed under neutron-rootwrap.

    Closes-Bug: #1823038

    Change-Id: I6cde3c9dae7ffdccce49e88c3c79d1c379f291cf

Changed in neutron:
status: In Progress → Fix Released

Reviewed: https://review.opendev.org/660513
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=9a498d993fd96c63e7ac61d2b3879bb3003352e0
Submitter: Zuul
Branch: stable/rocky

commit 9a498d993fd96c63e7ac61d2b3879bb3003352e0
Author: Rodolfo Alonso Hernandez <email address hidden>
Date: Fri May 10 10:58:08 2019 +0000

    Remove rootwrap configuration from neutron-keepalived-state-change

    New IP command introduced by Ie3fe825d65408fc969c478767b411fe0156e9fbc
    requires only privsep initialization. This patch removes the prisep
    error FailedToDropPrivileges when executed under neutron-rootwrap.

    Closes-Bug: #1823038

    Change-Id: I6cde3c9dae7ffdccce49e88c3c79d1c379f291cf
    (cherry picked from commit aacd11ab9f8f24291f369d23662b0cb6b3fe43e3)

Reviewed: https://review.opendev.org/660514
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=698a5e30f488a0a62e807717510d3a81a4a2bdbe
Submitter: Zuul
Branch: stable/queens

commit 698a5e30f488a0a62e807717510d3a81a4a2bdbe
Author: Rodolfo Alonso Hernandez <email address hidden>
Date: Fri May 10 10:58:08 2019 +0000

    Remove rootwrap configuration from neutron-keepalived-state-change

    New IP command introduced by Ie3fe825d65408fc969c478767b411fe0156e9fbc
    requires only privsep initialization. This patch removes the prisep
    error FailedToDropPrivileges when executed under neutron-rootwrap.

    Closes-Bug: #1823038

    Change-Id: I6cde3c9dae7ffdccce49e88c3c79d1c379f291cf
    (cherry picked from commit aacd11ab9f8f24291f369d23662b0cb6b3fe43e3)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers