Functional and fullstack tests job definition is broken

Bug #1820993 reported by Slawek Kaplonski
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Fix Released
Critical
Slawek Kaplonski

Bug Description

All functional and fullstack jobs are now failing with RETRY_LIMIT. Example of error: http://logs.openstack.org/85/643485/5/check/neutron-functional/e06a057/job-output.txt.gz#_2019-03-20_08_37_50_698998

It looks that problem is in role: fetch_journal_log defined in neutron repo.

The error appears to have been in '/var/lib/zuul/builds/e06a057967d54e058904ad455ced1aca/untrusted/project_5/git.openstack.org/openstack/neutron/roles/fetch_journal_log/tasks/main.yaml': line 1, column 3, but may
2019-03-20 08:37:50.699070 | be elsewhere in the file depending on the exact syntax problem.
2019-03-20 08:37:50.699095 |
2019-03-20 08:37:50.699117 | The offending line appears to be:
2019-03-20 08:37:50.699138 |
2019-03-20 08:37:50.699159 |
2019-03-20 08:37:50.699179 | - name: Ensure {{ journal_log_path }} exists
2019-03-20 08:37:50.699206 | ^ here
2019-03-20 08:37:50.699227 | We could be wrong, but this one looks like it might be an issue with
2019-03-20 08:37:50.699248 | missing quotes. Always quote template expression brackets when they
2019-03-20 08:37:50.699269 | start a value. For instance:
2019-03-20 08:37:50.699291 |
2019-03-20 08:37:50.699311 | with_items:
2019-03-20 08:37:50.699332 | - {{ foo }}
2019-03-20 08:37:50.699353 |
2019-03-20 08:37:50.699373 | Should be written as:
2019-03-20 08:37:50.699394 |
2019-03-20 08:37:50.699414 | with_items:
2019-03-20 08:37:50.699434 | - "{{ foo }}"

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (master)

Fix proposed to branch: master
Review: https://review.openstack.org/644842

Changed in neutron:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (master)

Reviewed: https://review.openstack.org/644842
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=b6550e568d9c17175a8d368959e3da3f6ce24573
Submitter: Jens Harbott (frickler) (<email address hidden>)
Branch: master

commit b6550e568d9c17175a8d368959e3da3f6ce24573
Author: Slawek Kaplonski <email address hidden>
Date: Wed Mar 20 12:56:46 2019 +0100

    Remove "msg" from tasks in ansible roles

    It looks that 'msg' isn't valid attribute for a Task and
    it cause problem with jobs which uses this role.

    Change-Id: I43d09e645f60526d251703ce7ee91c29281f1eeb
    Closes-Bug: #1820993

Changed in neutron:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/neutron 14.0.0.0rc1

This issue was fixed in the openstack/neutron 14.0.0.0rc1 release candidate.

tags: added: neutron-proactive-backport-potential
tags: removed: neutron-proactive-backport-potential
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers