Duplicate iptables rule detected in Linuxbridge agent logs

Bug #1754770 reported by Slawek Kaplonski
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Medium
Slawek Kaplonski

Bug Description

After patch [1] which should close issue [2] was merged there are warnings about "Duplicate iptables rule detected." in Linuxbridge neutron agent logs. Example of such warnings is e.g. at [3].

[1] https://review.openstack.org/#/c/525607/
[2] https://bugs.launchpad.net/neutron/+bug/1720205
[3] http://logs.openstack.org/07/525607/12/check/neutron-tempest-plugin-scenario-linuxbridge/09f04f9/logs/screen-q-agt.txt.gz?level=WARNING

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (master)

Fix proposed to branch: master
Review: https://review.openstack.org/551981

Changed in neutron:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (master)

Reviewed: https://review.openstack.org/551981
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=8be0c2a551fea0c02d757c6ad460f8435423ec32
Submitter: Zuul
Branch: master

commit 8be0c2a551fea0c02d757c6ad460f8435423ec32
Author: Sławek Kapłoński <email address hidden>
Date: Mon Mar 12 13:12:18 2018 +0100

    Set trusted port only once in iptables firewall driver

    Patch [1] added configuration of forward rule for trusted ports in
    iptables firewall driver.

    This patch fixes issue with many "duplicate iptables rule detected"
    warning messages due to try to add such forward rule each time when
    trusted port is updated.
    Now such rule is added only once for port.

    [1] https://review.openstack.org/#/c/525607/

    Change-Id: Ib816887f07f16b6ac865bb81d0f27f12d0b47dfb
    Closes-Bug: #1754770

Changed in neutron:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (stable/queens)

Fix proposed to branch: stable/queens
Review: https://review.openstack.org/556659

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (stable/queens)

Reviewed: https://review.openstack.org/556659
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=3fdae4fac8424707f4b11cbaffe1c31352084870
Submitter: Zuul
Branch: stable/queens

commit 3fdae4fac8424707f4b11cbaffe1c31352084870
Author: Sławek Kapłoński <email address hidden>
Date: Mon Mar 12 13:12:18 2018 +0100

    Set trusted port only once in iptables firewall driver

    Patch [1] added configuration of forward rule for trusted ports in
    iptables firewall driver.

    This patch fixes issue with many "duplicate iptables rule detected"
    warning messages due to try to add such forward rule each time when
    trusted port is updated.
    Now such rule is added only once for port.

    [1] https://review.openstack.org/#/c/525607/

    Change-Id: Ib816887f07f16b6ac865bb81d0f27f12d0b47dfb
    Closes-Bug: #1754770
    (cherry picked from commit 8be0c2a551fea0c02d757c6ad460f8435423ec32)

tags: added: in-stable-queens
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/neutron 12.0.1

This issue was fixed in the openstack/neutron 12.0.1 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/neutron 13.0.0.0b1

This issue was fixed in the openstack/neutron 13.0.0.0b1 development milestone.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (stable/pike)

Fix proposed to branch: stable/pike
Review: https://review.openstack.org/582920

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (stable/pike)

Reviewed: https://review.openstack.org/582920
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=ee1ae8b2b029b448198030ef0df5434ef2002730
Submitter: Zuul
Branch: stable/pike

commit ee1ae8b2b029b448198030ef0df5434ef2002730
Author: Sławek Kapłoński <email address hidden>
Date: Mon Mar 12 13:12:18 2018 +0100

    Set trusted port only once in iptables firewall driver

    Patch [1] added configuration of forward rule for trusted ports in
    iptables firewall driver.

    This patch fixes issue with many "duplicate iptables rule detected"
    warning messages due to try to add such forward rule each time when
    trusted port is updated.
    Now such rule is added only once for port.

    [1] https://review.openstack.org/#/c/525607/

    Change-Id: Ib816887f07f16b6ac865bb81d0f27f12d0b47dfb
    Closes-Bug: #1754770
    (cherry picked from commit 8be0c2a551fea0c02d757c6ad460f8435423ec32)

tags: added: in-stable-pike
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/neutron 11.0.6

This issue was fixed in the openstack/neutron 11.0.6 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers