Cannot delete a neutron network, if the currently configured MTU is lower than the network's MTU

Bug #1713499 reported by Claudiu Belu on 2017-08-28
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
Pike
High
Seyeong Kim
Queens
High
Seyeong Kim
neutron
High
Slawek Kaplonski
neutron (Ubuntu)
Undecided
Unassigned
Bionic
High
Seyeong Kim

Bug Description

Currently, the neutron API returns an error [1] when trying to delete a neutron network which has a higher MTU than the configured MTU[2][3].

This issue has been noticed in Pike.

[1] Error: http://paste.openstack.org/show/619627/
[2] neutron.conf: http://paste.openstack.org/show/619629/
[3] ml2_conf.ini: http://paste.openstack.org/show/619630/

Claudiu Belu (cbelu) on 2017-08-28
description: updated
Reedip (reedip-banerjee) wrote :

Would really appreciate if you can show the logs ( /var/log/neutron/neutron-server.log ) , or run the "openstack --debug network delete" to get more information.

Changed in neutron:
status: New → Incomplete
status: Incomplete → New
Reedip (reedip-banerjee) wrote :

Sorry, got the information in [1]

Changed in neutron:
assignee: nobody → Reedip (reedip-banerjee)
Reedip (reedip-banerjee) wrote :

I just checked out and found that I cannot create a network with MTU higher than a specified MTU.

I am interested in knowing how the network in you case was created in the first place. The steps of creation/updation and any other modifications done before the deletion operation was performed would be greatly appreciated to rule out any uneven conditions.

[1]: http://paste.openstack.org/show/619719/

Changed in neutron:
status: New → Incomplete
Claudiu Belu (cbelu) wrote :

Sure.

1. Have global_physnet_mtu to something like 1500.
2. Create a neutron network with the said MTU.
3. Change the global_physnet_mtu to a lesser value.
4. Restart the neutron services.
5. Try to delete the neutron network.

http://paste.openstack.org/show/619723/

Jakub Libosvar (libosvar) wrote :

Confirming the bug using reproduction steps from comment 4

Changed in neutron:
status: Incomplete → Confirmed
Kevin Benton (kevinbenton) wrote :

Hi,

I think the appropriate fix for this is to just not try to validate the MTU during segment deletion.

In the call to _get_network_mtu at [1] you can pass a validate=False flag. This will stop the existing network from being undeletable.

1. http://git.openstack.org/cgit/openstack/neutron/tree/neutron/plugins/ml2/plugin.py#n1883

Changed in neutron:
importance: Undecided → High

Fix proposed to branch: master
Review: https://review.openstack.org/499908

Changed in neutron:
status: Confirmed → In Progress
Miguel Lavalle (minsel) on 2018-01-26
Changed in neutron:
milestone: none → queens-rc1
tags: added: queens-backport-potential
Miguel Lavalle (minsel) wrote :

Haven't heard back from Reedip. Since we want to fix this bug early in Rocky and backport it to Queens, taking it over

Changed in neutron:
assignee: Reedip (reedip-banerjee) → Miguel Lavalle (minsel)
Changed in neutron:
assignee: Miguel Lavalle (minsel) → Brian Haley (brian-haley)
Changed in neutron:
assignee: Brian Haley (brian-haley) → Reedip (reedip-banerjee)
Changed in neutron:
assignee: Reedip (reedip-banerjee) → Brian Haley (brian-haley)
Changed in neutron:
assignee: Brian Haley (brian-haley) → Slawek Kaplonski (slaweq)

Reviewed: https://review.openstack.org/499908
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=006113e3bfd566f3b394580262a60345eec160d6
Submitter: Zuul
Branch: master

commit 006113e3bfd566f3b394580262a60345eec160d6
Author: Reedip <email address hidden>
Date: Fri Sep 1 06:20:01 2017 +0000

    Skip MTU check during deletion of Networks

    MTU check can be skipped during deletion of Networks.
    The MTU check doesn't provide any additional support during deletion
    of the networks.

    Also, if a network is created with MTU 'X' and the
    global_mtu later on is decreased to 'Y', the created
    network cannot be deleted due to the MTU check.

    Change-Id: Ia838d2a661c5098f90b58b2cb31557f2ebf78868
    Closes-Bug: #1713499

Changed in neutron:
status: In Progress → Fix Released
tags: added: neutron-proactive-backport-potential

Reviewed: https://review.openstack.org/584319
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=9bc05416efac1abed6f67393cfedffb95b474eb5
Submitter: Zuul
Branch: stable/queens

commit 9bc05416efac1abed6f67393cfedffb95b474eb5
Author: Reedip <email address hidden>
Date: Fri Sep 1 06:20:01 2017 +0000

    Skip MTU check during deletion of Networks

    MTU check can be skipped during deletion of Networks.
    The MTU check doesn't provide any additional support during deletion
    of the networks.

    Also, if a network is created with MTU 'X' and the
    global_mtu later on is decreased to 'Y', the created
    network cannot be deleted due to the MTU check.

    Change-Id: Ia838d2a661c5098f90b58b2cb31557f2ebf78868
    Closes-Bug: #1713499
    (cherry picked from commit 006113e3bfd566f3b394580262a60345eec160d6)

tags: added: in-stable-queens

This issue was fixed in the openstack/neutron 13.0.0.0b3 development milestone.

Reviewed: https://review.openstack.org/584320
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=f591c899677c5ac01d94a1585632448192004b64
Submitter: Zuul
Branch: stable/pike

commit f591c899677c5ac01d94a1585632448192004b64
Author: Reedip <email address hidden>
Date: Fri Sep 1 06:20:01 2017 +0000

    Skip MTU check during deletion of Networks

    MTU check can be skipped during deletion of Networks.
    The MTU check doesn't provide any additional support during deletion
    of the networks.

    Also, if a network is created with MTU 'X' and the
    global_mtu later on is decreased to 'Y', the created
    network cannot be deleted due to the MTU check.

    Change-Id: Ia838d2a661c5098f90b58b2cb31557f2ebf78868
    Closes-Bug: #1713499
    (cherry picked from commit 006113e3bfd566f3b394580262a60345eec160d6)

tags: added: in-stable-pike

This issue was fixed in the openstack/neutron 12.0.4 release.

Seyeong Kim (xtrusia) on 2018-10-01
tags: added: sts-sru-needed
Seyeong Kim (xtrusia) wrote :
Seyeong Kim (xtrusia) wrote :
Seyeong Kim (xtrusia) wrote :
Changed in neutron (Ubuntu):
status: New → Fix Released
Changed in neutron (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Seyeong Kim (xtrusia)
Changed in cloud-archive:
status: New → Fix Released
Changed in neutron (Ubuntu Bionic):
importance: Undecided → High
Corey Bryant (corey.bryant) wrote :

This will be included in the 12.0.4 stable point release of neutron: https://bugs.launchpad.net/ubuntu/bionic/+source/nova/+bug/1795424

Corey Bryant (corey.bryant) wrote :

For Queens ^

Hello Claudiu, or anyone else affected,

Accepted neutron into pike-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:pike-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-pike-needed to verification-pike-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-pike-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-pike-needed
Corey Bryant (corey.bryant) wrote :

Regression testing successful for xenial-pike-proposed:

======
Totals
======
Ran: 102 tests in 1187.5479 sec.
 - Passed: 94
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 604.4233 sec.

Seyeong Kim (xtrusia) wrote :

Hello

I verified this patch for pike is working.

I reproduced this as http://paste.openstack.org/show/619723/

And upgrade pkg on neutron-api node, then tried to delete again.

Then it is deleted.

dpkg -l
ii neutron-common 2:11.0.5-0ubuntu1~cloud1 all Neutron is a virtual network service for Openstack - common
ii neutron-plugin-ml2 2:11.0.5-0ubuntu1~cloud1 all Neutron is a virtual network service for Openstack - ML2 plugin
ii neutron-server 2:11.0.5-0ubuntu1~cloud1 all Neutron is a virtual network service for Openstack - server
ii python-neutron 2:11.0.5-0ubuntu1~cloud1 all Neutron is a virtual network service for Openstack - Python library

tags: added: verification-pike-done
removed: verification-pike-needed

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package neutron - 2:11.0.5-0ubuntu1~cloud1
---------------

 neutron (2:11.0.5-0ubuntu1~cloud1) xenial-pike; urgency=medium
 .
   [ Seyeong Kim ]
   * Skip MTU check during deletion of Networks (LP: #1713499).
     - Fixing issue that network can't be deleted if MTU is
       different.
     - d/p/0001-Skip-MTU-check-during-deletion-of-Networks.patch

An upload of neutron to xenial-proposed has been rejected from the upload queue for the following reason: "The upload contained changes from 8.4.0 to 11.0.5 in addition to the changes which would fix this specific bug.".

This issue was fixed in the openstack/neutron 11.0.6 release.

Edward Hope-Morley (hopem) wrote :

This is now Fix Released for Queens UCA since the patch is in 12.0.4 release and UCA no has 12.0.5 (from bug 1795424)

Changed in neutron (Ubuntu Bionic):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers