Binding info for DVR port not found error seen when notify_l2pop_port_wiring is called with DVR routers

Bug #1702769 reported by Swaminathan Vasudevan on 2017-07-06
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
neutron
Undecided
Brian Haley

Bug Description

A recent change in upstream Icd4cd4e3f735e88299e86468380c5f786e7628fe, might have introduced this problem.
Here the 'get_bound_port_context' is being called for non-HA ports and so with the given context, it is not able to retrieve the port-binding and throws the error.

Changed in neutron:
assignee: nobody → Swaminathan Vasudevan (swaminathan-vasudevan)
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/481311

Changed in neutron:
status: Confirmed → In Progress
Changed in neutron:
assignee: Swaminathan Vasudevan (swaminathan-vasudevan) → Brian Haley (brian-haley)

Reviewed: https://review.openstack.org/481311
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=9e9a8a07c3cb1eed074399af36affe857011133e
Submitter: Jenkins
Branch: master

commit 9e9a8a07c3cb1eed074399af36affe857011133e
Author: Swaminathan Vasudevan <email address hidden>
Date: Thu Jul 6 14:11:50 2017 -0700

    DVR: Fix binding info for DVR port not found error

    Recently we have been seeing an error in neutron associated
    with DVR routers, that says 'Binding info for DVR port not
    found'.
    This error is thrown when the 'get_bound_port_context' is
    called when trying to notify_l2pop_port_wiring.
    notify_l2pop_port_wiring is intended for router 'HA' ports, so
    the get_bound_port_context should be called here only for 'HA'
    ports.

    This was introduced by a recent refactor in neutron
    Icd4cd4e3f735e88299e86468380c5f786e7628fe

    Change-Id: I1c636344068518aa26be6c96c598c61b7f0f3563
    Closes-Bug: #1702769

Changed in neutron:
status: In Progress → Fix Released

This issue was fixed in the openstack/neutron 11.0.0.0b3 development milestone.

tags: added: neutron-proactive-backport-potential
tags: removed: neutron-proactive-backport-potential
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers