pep8 job (pylint) fails due to version mismatch between pylint and astroid

Bug #1696403 reported by Gary Kotton
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Fix Released
Undecided
Gary Kotton

Bug Description

2017-06-07 09:29:49.968889 | Traceback (most recent call last):
2017-06-07 09:29:49.968921 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/bin/pylint", line 11, in <module>
2017-06-07 09:29:49.968933 | sys.exit(run_pylint())
2017-06-07 09:29:49.968974 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/local/lib/python2.7/site-packages/pylint/__init__.py", line 23, in run_pylint
2017-06-07 09:29:49.968986 | Run(sys.argv[1:])
2017-06-07 09:29:49.969025 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/local/lib/python2.7/site-packages/pylint/lint.py", line 1332, in __init__
2017-06-07 09:29:49.969037 | linter.check(args)
2017-06-07 09:29:49.969074 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/local/lib/python2.7/site-packages/pylint/lint.py", line 747, in check
2017-06-07 09:29:49.969090 | self._do_check(files_or_modules)
2017-06-07 09:29:49.969129 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/local/lib/python2.7/site-packages/pylint/lint.py", line 869, in _do_check
2017-06-07 09:29:49.969152 | self.check_astroid_module(ast_node, walker, rawcheckers, tokencheckers)
2017-06-07 09:29:49.969193 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/local/lib/python2.7/site-packages/pylint/lint.py", line 946, in check_astroid_module
2017-06-07 09:29:49.969206 | walker.walk(ast_node)
2017-06-07 09:29:49.969245 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/local/lib/python2.7/site-packages/pylint/utils.py", line 874, in walk
2017-06-07 09:29:49.969255 | self.walk(child)
2017-06-07 09:29:49.969294 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/local/lib/python2.7/site-packages/pylint/utils.py", line 871, in walk
2017-06-07 09:29:49.969304 | cb(astroid)
2017-06-07 09:29:49.969349 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/local/lib/python2.7/site-packages/pylint/checkers/imports.py", line 249, in visit_import
2017-06-07 09:29:49.969368 | importedmodnode = self.get_imported_module(node, name)
2017-06-07 09:29:49.969411 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/local/lib/python2.7/site-packages/pylint/checkers/imports.py", line 288, in get_imported_module
2017-06-07 09:29:49.969428 | return importnode.do_import_module(modname)
2017-06-07 09:29:49.969469 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/local/lib/python2.7/site-packages/astroid/mixins.py", line 119, in do_import_module
2017-06-07 09:29:49.969484 | relative_only=level and level >= 1)
2017-06-07 09:29:49.969525 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/local/lib/python2.7/site-packages/astroid/scoped_nodes.py", line 415, in import_module
2017-06-07 09:29:49.969542 | return MANAGER.ast_from_module_name(modname)
2017-06-07 09:29:49.969584 | File "/home/jenkins/workspace/gate-neutron-pep8-ubuntu-xenial/.tox/pep8/local/lib/python2.7/site-packages/astroid/manager.py", line 161, in ast_from_module_name
2017-06-07 09:29:49.969592 | raise e
2017-06-07 09:29:49.969620 | astroid.exceptions.AstroidImportError: Failed to import module six.moves.urllib.parse with error:
2017-06-07 09:29:49.969636 | No module named six.moves.urllib.parse.
2017-06-07 09:29:50.688358 | ERROR: InvocationError: '/bin/sh ./tools/coding-checks.sh --pylint '
2017-06-07 09:29:50.688923 | ___________________________________ summary ____________________________________
2017-06-07 09:29:50.688975 | ERROR: pep8: commands failed

Gary Kotton (garyk)
description: updated
Akihiro Motoki (amotoki)
summary: - Pep8 fails due to six 1.10.0
+ pylint fails due to six 1.10.0
Revision history for this message
Akihiro Motoki (amotoki) wrote : Re: pylint fails due to six 1.10.0

This is caused by the requirement mismatch of pylint and astroid.
Once https://review.openstack.org/#/c/469491/ is merged, the execution exception from astroid will disappear.

On the other hand, we neutron still have pylint failure even after it is merged, but this is a different problem and neutron-specific.

Akihiro Motoki (amotoki)
summary: - pylint fails due to six 1.10.0
+ pep8 job (pylint) fails due to version mismatch between pylint and
+ astroid
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (master)

Fix proposed to branch: master
Review: https://review.openstack.org/471763

Changed in neutron:
assignee: nobody → Akihiro Motoki (amotoki)
status: New → In Progress
Changed in neutron:
assignee: Akihiro Motoki (amotoki) → Gary Kotton (garyk)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (master)

Reviewed: https://review.openstack.org/471763
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=17ed89cbc12db9d9c8882f1e4162547725d030ec
Submitter: Jenkins
Branch: master

commit 17ed89cbc12db9d9c8882f1e4162547725d030ec
Author: Akihiro Motoki <email address hidden>
Date: Wed Jun 7 13:01:03 2017 +0000

    Update pylint disable list to pass pylint 1.7.1 checks

    Recenly pylint version was bumped to 1.7.1 in global-requirements.txt.
    Pylint 1.7.1 adds more checks and breaks the neutron pep8 job.

    This commit adds new checks to the disabled list to avoid the gate
    breakage. Individual disabled tests can be fixed later.

    The new disabled list is compatible with pylint 1.4.5,
    so we can merge this regardless of pylint bump is reverted or not.

    Closes-Bug: #1696403
    Change-Id: If6228d0626413049b82f9d75bcdf3bea7ddacde5

Changed in neutron:
status: In Progress → Fix Released
tags: added: neutron-proactive-backport-potential
tags: added: neutron-easy-proactive-backport-potential
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (stable/ocata)

Fix proposed to branch: stable/ocata
Review: https://review.openstack.org/474263

tags: removed: neutron-easy-proactive-backport-potential neutron-proactive-backport-potential
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (stable/newton)

Fix proposed to branch: stable/newton
Review: https://review.openstack.org/474264

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (stable/ocata)

Reviewed: https://review.openstack.org/474263
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=b032fd257dd431a797b215a99a254af502eb59f4
Submitter: Jenkins
Branch: stable/ocata

commit b032fd257dd431a797b215a99a254af502eb59f4
Author: Akihiro Motoki <email address hidden>
Date: Wed Jun 7 13:01:03 2017 +0000

    Update pylint disable list to pass pylint 1.7.1 checks

    Recenly pylint version was bumped to 1.7.1 in global-requirements.txt.
    Pylint 1.7.1 adds more checks and breaks the neutron pep8 job.

    This commit adds new checks to the disabled list to avoid the gate
    breakage. Individual disabled tests can be fixed later.

    The new disabled list is compatible with pylint 1.4.5,
    so we can merge this regardless of pylint bump is reverted or not.

    Closes-Bug: #1696403
    Change-Id: If6228d0626413049b82f9d75bcdf3bea7ddacde5
    (cherry picked from commit 17ed89cbc12db9d9c8882f1e4162547725d030ec)

tags: added: in-stable-ocata
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (stable/newton)

Reviewed: https://review.openstack.org/474264
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=c95561e2d20867812466c9d5a275f1dc6e3263ac
Submitter: Jenkins
Branch: stable/newton

commit c95561e2d20867812466c9d5a275f1dc6e3263ac
Author: Akihiro Motoki <email address hidden>
Date: Wed Jun 7 13:01:03 2017 +0000

    Update pylint disable list to pass pylint 1.7.1 checks

    Recenly pylint version was bumped to 1.7.1 in global-requirements.txt.
    Pylint 1.7.1 adds more checks and breaks the neutron pep8 job.

    This commit adds new checks to the disabled list to avoid the gate
    breakage. Individual disabled tests can be fixed later.

    The new disabled list is compatible with pylint 1.4.5,
    so we can merge this regardless of pylint bump is reverted or not.

    Closes-Bug: #1696403
    Change-Id: If6228d0626413049b82f9d75bcdf3bea7ddacde5
    (cherry picked from commit 17ed89cbc12db9d9c8882f1e4162547725d030ec)

tags: added: in-stable-newton
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/requirements 1.1.0

This issue was fixed in the openstack/requirements 1.1.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/neutron 11.0.0.0b3

This issue was fixed in the openstack/neutron 11.0.0.0b3 development milestone.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/neutron 9.4.1

This issue was fixed in the openstack/neutron 9.4.1 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/neutron 10.0.3

This issue was fixed in the openstack/neutron 10.0.3 release.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers